aboutsummaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2005-05-31 18:20:59 +0800
committeredwin <edwin@FreeBSD.org>2005-05-31 18:20:59 +0800
commit1cdf4ebcfb4e1beae085fa476af3c1cd21d38903 (patch)
tree48b38f9e8547e770921253ce7d320f5362c63b71 /misc
parent97eb782529d54c8717cca385a15f9b3c612cdf9f (diff)
downloadfreebsd-ports-graphics-1cdf4ebcfb4e1beae085fa476af3c1cd21d38903.tar.gz
freebsd-ports-graphics-1cdf4ebcfb4e1beae085fa476af3c1cd21d38903.tar.zst
freebsd-ports-graphics-1cdf4ebcfb4e1beae085fa476af3c1cd21d38903.zip
new port: misc/gopod
new port: misc/gopod goPod is a program that allows you to remove the EU Volume limitation on EU iPod's. We can't be held responsible for the use you make with this program or any damage it could cause to your iPod. It is provided for information purpose only. However, uncapping your iPod and using it is illegal in France. goPod is not in any way affiliated with Apple Computer, Inc. Apple(tm) iPod(tm) are trademarks of Apple Computer, Inc. WWW: http://http://gopod.free-go.net/ PR: ports/79529 Submitted by: Emanuel Haupt <ehaupt@critical.ch>
Diffstat (limited to 'misc')
-rw-r--r--misc/Makefile1
-rw-r--r--misc/gopod/Makefile75
-rw-r--r--misc/gopod/distinfo2
-rw-r--r--misc/gopod/files/patch-main.c32
-rw-r--r--misc/gopod/pkg-descr14
-rw-r--r--misc/gopod/pkg-message7
6 files changed, 131 insertions, 0 deletions
diff --git a/misc/Makefile b/misc/Makefile
index 6bd5030e0af..b1211f6eda6 100644
--- a/misc/Makefile
+++ b/misc/Makefile
@@ -131,6 +131,7 @@
SUBDIR += goldstr
SUBDIR += gone
SUBDIR += gonvert
+ SUBDIR += gopod
SUBDIR += gplbp
SUBDIR += gplink
SUBDIR += gpt
diff --git a/misc/gopod/Makefile b/misc/gopod/Makefile
new file mode 100644
index 00000000000..c3039a1da0e
--- /dev/null
+++ b/misc/gopod/Makefile
@@ -0,0 +1,75 @@
+# New ports collection makefile for: gopod
+# Date created: 4 April 2005
+# Whom: Emanuel Haupt <ehaupt@critical.ch>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gopod
+PORTVERSION= 1.1
+CATEGORIES= misc
+MASTER_SITES= http://gopod.free-go.net/
+DISTNAME= goPod-${PORTVERSION}_linux_bsd
+
+MAINTAINER= ehaupt@critical.ch
+COMMENT= Utility to cap/uncap an iPod
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+RESTRICTED= Unclear legal status in EU countries
+NO_PACKAGE= Unclear legal status in EU countries
+
+PATCH_WRKSRC= ${WRKDIR}/${DISTNAME}/gtk-version
+
+PLIST_FILES= bin/gopod
+
+.if defined(WITH_GUI)
+USE_X_PREFIX= yes
+USE_GNOME= gtk20
+WRKSRC= ${WRKDIR}/${DISTNAME}/gtk-version
+PLIST_FILES+= share/${PORTNAME}/capped.png \
+ share/${PORTNAME}/go.png \
+ share/${PORTNAME}/go_.png \
+ share/${PORTNAME}/mask.xpm \
+ share/${PORTNAME}/notdetected.png \
+ share/${PORTNAME}/uncapped.png
+PLIST_DIRS+= share/${PORTNAME}
+.else
+WRKSRC= ${WRKDIR}/${DISTNAME}/console-version
+.endif
+
+pre-everything::
+.if !defined(WITH_GUI)
+ @${ECHO_MSG}
+ @${ECHO_MSG} "You may define WITH_GUI if you want the gui version"
+ @${ECHO_MSG}
+.endif
+
+post-patch:
+ @${SED} -e "s|%%PREFIX%%|${PREFIX}|g" \
+ ${WRKSRC}/main.c > ${WRKSRC}/main.c.freebsd
+ ${MV} ${WRKSRC}/main.c.freebsd ${WRKSRC}/main.c
+
+do-install:
+.if defined(WITH_GUI)
+ @${MKDIR} ${PREFIX}/share/${PORTNAME}
+.for file in capped.png go.png go_.png mask.xpm notdetected.png uncapped.png
+ ${INSTALL_DATA} -m 0644 ${WRKSRC}/gfx/${file} ${PREFIX}/share/${PORTNAME}/${file}
+.endfor
+ ${INSTALL_PROGRAM} -m 0110 ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+.else
+ ${INSTALL_PROGRAM} -m 0110 ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+.endif
+
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README_EN ${WRKSRC}/README_FR ${DOCSDIR}
+PLIST_FILES+= share/doc/${PORTNAME}/README_EN \
+ share/doc/${PORTNAME}/README_FR
+PLIST_DIRS+= share/doc/${PORTNAME}
+.endif
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/misc/gopod/distinfo b/misc/gopod/distinfo
new file mode 100644
index 00000000000..7e2058baabb
--- /dev/null
+++ b/misc/gopod/distinfo
@@ -0,0 +1,2 @@
+MD5 (goPod-1.1_linux_bsd.tar.gz) = 569be8629845cd6f027b802d1e909841
+SIZE (goPod-1.1_linux_bsd.tar.gz) = 98330
diff --git a/misc/gopod/files/patch-main.c b/misc/gopod/files/patch-main.c
new file mode 100644
index 00000000000..8bc6081aeb1
--- /dev/null
+++ b/misc/gopod/files/patch-main.c
@@ -0,0 +1,32 @@
+--- main.c.orig Wed Nov 3 19:43:23 2004
++++ main.c Mon Apr 4 10:05:06 2005
+@@ -16,11 +16,11 @@
+ #include <gtk/gtk.h>
+ #include "gfx/mask.xpm"
+
+-#define GFX_GO "gfx/go.png"
+-#define GFX_GO_ "gfx/go_.png"
+-#define GFX_NOTDETECTED "gfx/notdetected.png"
+-#define GFX_CAPPED "gfx/capped.png"
+-#define GFX_UNCAPPED "gfx/uncapped.png"
++#define GFX_GO "%%PREFIX%%/share/gopod/go.png"
++#define GFX_GO_ "%%PREFIX%%/share/gopod/go_.png"
++#define GFX_NOTDETECTED "%%PREFIX%%/share/gopod/notdetected.png"
++#define GFX_CAPPED "%%PREFIX%%/share/gopod/capped.png"
++#define GFX_UNCAPPED "%%PREFIX%%/share/gopod/uncapped.png"
+
+ #if defined(__LINUX__)
+ #define DEV "/dev/sd%c"
+@@ -69,10 +69,10 @@
+ {
+ char x;
+
+- for (x = START; x <= END; x++)
++ for (x = 0; x <= 15; x++)
+ {
+ char devstring[8];
+- sprintf(devstring, DEV, x);
++ sprintf(devstring, "/dev/da%i", x);
+ dev = open(devstring, O_RDWR);
+ lseek(dev, FIRMWARE_START, SEEK_CUR);
+ read(dev, buffer, BLOCK_SIZE);
diff --git a/misc/gopod/pkg-descr b/misc/gopod/pkg-descr
new file mode 100644
index 00000000000..04fe73aa1e4
--- /dev/null
+++ b/misc/gopod/pkg-descr
@@ -0,0 +1,14 @@
+goPod is a program that allows you to remove the EU Volume limitation
+on EU iPod's.
+
+We can't be held responsible for the use you make with this program
+or any damage it could cause to your iPod.
+
+It is provided for information purpose only. However, uncapping your
+iPod and using it is illegal in France.
+
+goPod is not in any way affiliated with Apple Computer, Inc.
+
+Apple(tm) iPod(tm) are trademarks of Apple Computer, Inc.
+
+WWW: http://gopod.free-go.net/
diff --git a/misc/gopod/pkg-message b/misc/gopod/pkg-message
new file mode 100644
index 00000000000..662196a5ef9
--- /dev/null
+++ b/misc/gopod/pkg-message
@@ -0,0 +1,7 @@
+===========================================================================
+
+Please make sure you have write permissions on your iPod harddisk device.
+Usually this is da0. You can plug in your iPod and run "camcontrol devlist"
+to figure out which device it is.
+
+===========================================================================