aboutsummaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
authorarved <arved@FreeBSD.org>2004-03-03 18:03:15 +0800
committerarved <arved@FreeBSD.org>2004-03-03 18:03:15 +0800
commit2538e011f3a78d1089a2a10de26a0d51807ef230 (patch)
tree518beb81d5c68f46f636e47de6299f65fc30c333 /misc
parentf7161ebf78fad97bc9b6ef3228eb547d51a596c1 (diff)
downloadfreebsd-ports-graphics-2538e011f3a78d1089a2a10de26a0d51807ef230.tar.gz
freebsd-ports-graphics-2538e011f3a78d1089a2a10de26a0d51807ef230.tar.zst
freebsd-ports-graphics-2538e011f3a78d1089a2a10de26a0d51807ef230.zip
Fix Build on CURRENT, I am not sure why this worked on STABLE [1]
Add WITHOUT_NLS knob. [1]: Reported by: adamw, ale Pointy hat to: arved
Diffstat (limited to 'misc')
-rw-r--r--misc/help2man/Makefile16
-rw-r--r--misc/help2man/files/patch-configure13
2 files changed, 25 insertions, 4 deletions
diff --git a/misc/help2man/Makefile b/misc/help2man/Makefile
index d657b9e7601..9df4ce0f9f4 100644
--- a/misc/help2man/Makefile
+++ b/misc/help2man/Makefile
@@ -16,18 +16,26 @@ DISTNAME= ${PORTNAME}_${PORTVERSION}
MAINTAINER= arved@FreeBSD.org
COMMENT= Automatically generating simple manual pages from program output
+.if !defined(WITHOUT_NLS)
BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Locale/gettext.pm:${PORTSDIR}/devel/p5-Locale-gettext
RUN_DEPENDS= ${BUILD_DEPENDS}
+MANLANG= "" pl fr
+PLIST_SUB= NLS=""
+.else
+CONFIGURE_ARGS+= --disable-nls
+PLIST_SUB= NLS="@comment "
+.endif
+
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
GNU_CONFIGURE= yes
USE_PERL5= yes
MAN1= help2man.1
-MANLANG= "" pl fr
+
INFO= help2man
-PLIST_FILES= bin/help2man lib/hacklocaledir.so \
- share/locale/fr/LC_MESSAGES/help2man.mo \
- share/locale/pl/LC_MESSAGES/help2man.mo
+PLIST_FILES= bin/help2man %%NLS%%lib/hacklocaledir.so \
+ %%NLS%%share/locale/fr/LC_MESSAGES/help2man.mo \
+ %%NLS%%share/locale/pl/LC_MESSAGES/help2man.mo
.include <bsd.port.mk>
diff --git a/misc/help2man/files/patch-configure b/misc/help2man/files/patch-configure
new file mode 100644
index 00000000000..0f91e78552e
--- /dev/null
+++ b/misc/help2man/files/patch-configure
@@ -0,0 +1,13 @@
+--- configure.orig Wed Mar 3 10:56:35 2004
++++ configure Wed Mar 3 10:56:54 2004
+@@ -2307,10 +2307,6 @@
+ preload=`LD_PRELOAD="preloadable_libintl.so" sh -c 'echo yes' 2>/dev/null`
+ echo "$as_me:$LINENO: result: ${preload:=no}" >&5
+ echo "${ECHO_T}${preload:=no}" >&6
+- test "$preload" = no && \
+- { { echo "$as_me:$LINENO: error: libpreloadable_libintl.so required (gettext 0.12+)" >&5
+-echo "$as_me: error: libpreloadable_libintl.so required (gettext 0.12+)" >&2;}
+- { (exit 1); exit 1; }; }
+
+ extra_make_all='preload man_l10n'
+ extra_make_install='install_preload install_l10n'