aboutsummaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
authordanilo <danilo@FreeBSD.org>2013-12-08 23:08:09 +0800
committerdanilo <danilo@FreeBSD.org>2013-12-08 23:08:09 +0800
commit40023aae83da32043e1381729d63a49edf2c0276 (patch)
treea10a4cae2ae073f21c75cf9f02f7bf3b57858e13 /misc
parentfe7e4ad9259632fe756586633904a7eb9cca710e (diff)
downloadfreebsd-ports-graphics-40023aae83da32043e1381729d63a49edf2c0276.tar.gz
freebsd-ports-graphics-40023aae83da32043e1381729d63a49edf2c0276.tar.zst
freebsd-ports-graphics-40023aae83da32043e1381729d63a49edf2c0276.zip
- Add stage support
- Add LICENSE
Diffstat (limited to 'misc')
-rw-r--r--misc/geekcode/Makefile13
1 files changed, 5 insertions, 8 deletions
diff --git a/misc/geekcode/Makefile b/misc/geekcode/Makefile
index f708d2ad603..9c1eef3a9b1 100644
--- a/misc/geekcode/Makefile
+++ b/misc/geekcode/Makefile
@@ -9,19 +9,16 @@ MASTER_SITES= SF
MAINTAINER= ports@FreeBSD.org
COMMENT= Geek Code Generator
+LICENSE= GPLv2
+
MAKE_ARGS= CC="${CC}" CFLAGS="${CFLAGS}"
PLIST_FILES= bin/geekcode
PORTDOCS= geekcode.txt
-NO_STAGE= yes
-.include <bsd.port.options.mk>
-
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/geekcode ${PREFIX}/bin
-.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/geekcode.txt ${DOCSDIR}
-.endif
+ ${INSTALL_PROGRAM} ${WRKSRC}/geekcode ${STAGEDIR}${PREFIX}/bin
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/geekcode.txt ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>