aboutsummaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2004-01-06 15:56:32 +0800
committerijliao <ijliao@FreeBSD.org>2004-01-06 15:56:32 +0800
commit4f13a3f927bd299908421ade455580a1f1b29dc9 (patch)
treea4ed77ce7e6f4dfca122a84e0d45e73044431b50 /misc
parentea676a2a35aa333facbe29d697ddeff71e0be0d6 (diff)
downloadfreebsd-ports-graphics-4f13a3f927bd299908421ade455580a1f1b29dc9.tar.gz
freebsd-ports-graphics-4f13a3f927bd299908421ade455580a1f1b29dc9.tar.zst
freebsd-ports-graphics-4f13a3f927bd299908421ade455580a1f1b29dc9.zip
add wotsap 0.5
Web of trust statistics and pathfinder
Diffstat (limited to 'misc')
-rw-r--r--misc/Makefile1
-rw-r--r--misc/wotsap/Makefile27
-rw-r--r--misc/wotsap/distinfo1
-rw-r--r--misc/wotsap/pkg-descr15
-rw-r--r--misc/wotsap/pkg-plist1
5 files changed, 45 insertions, 0 deletions
diff --git a/misc/Makefile b/misc/Makefile
index 8cfa91be764..6f0a358dcec 100644
--- a/misc/Makefile
+++ b/misc/Makefile
@@ -377,6 +377,7 @@
SUBDIR += wmweather+
SUBDIR += wmwork
SUBDIR += wmx10
+ SUBDIR += wotsap
SUBDIR += xd
SUBDIR += xdelta
SUBDIR += xdf
diff --git a/misc/wotsap/Makefile b/misc/wotsap/Makefile
new file mode 100644
index 00000000000..7de69464f76
--- /dev/null
+++ b/misc/wotsap/Makefile
@@ -0,0 +1,27 @@
+# ex:ts=8
+# Ports collection makefile for: wotsap
+# Date created: Jan 6, 2004
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= wotsap
+PORTVERSION= 0.5
+CATEGORIES= misc
+MASTER_SITES= http://www.lysator.liu.se/~jc/wotsap/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Web of trust statistics and pathfinder
+
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/PIL.pth:${PORTSDIR}/graphics/py-imaging
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+USE_PYTHON= yes
+NO_BUILD= yes
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/wotsap.py ${PREFIX}/bin/wotsap
+
+.include <bsd.port.mk>
diff --git a/misc/wotsap/distinfo b/misc/wotsap/distinfo
new file mode 100644
index 00000000000..b619ec68334
--- /dev/null
+++ b/misc/wotsap/distinfo
@@ -0,0 +1 @@
+MD5 (wotsap-0.5.tgz) = e2eee7c0b68de4a968ca359391463551
diff --git a/misc/wotsap/pkg-descr b/misc/wotsap/pkg-descr
new file mode 100644
index 00000000000..3b76ad401e3
--- /dev/null
+++ b/misc/wotsap/pkg-descr
@@ -0,0 +1,15 @@
+Find paths between two keys in the OpenPGP Web of Trust, and get statistics
+about a key or the whole web.
+
+Observe:
+ * We only search the largest strongly connected set.
+ * No attempt is made to verify the signatures. For you to be able to trust
+ a path, you must verify all signatures yourself.
+ * Even if there exists a path between you and another key, you have to
+ trust the other people in at least one path in the graph to trust the key.
+
+Keys can be specified as normal key IDs (0x12345678 or 12345678), or a number
+of space-separated case-insensitive search terms (i.e. "rms@gnu.org" or
+"@gnu Stallman").
+
+WWW: http://www.lysator.liu.se/~jc/wotsap/
diff --git a/misc/wotsap/pkg-plist b/misc/wotsap/pkg-plist
new file mode 100644
index 00000000000..d59ea13ad3a
--- /dev/null
+++ b/misc/wotsap/pkg-plist
@@ -0,0 +1 @@
+bin/wotsap