aboutsummaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2010-06-03 23:54:29 +0800
committerpav <pav@FreeBSD.org>2010-06-03 23:54:29 +0800
commit53f4b372e0b67aa39ec24b0473e3454201de1c92 (patch)
treefddadccc505dc31b17790691a28204f894c9d8af /misc
parent37d148ed9c0d6a016f957b09a710ba200db77dae (diff)
downloadfreebsd-ports-graphics-53f4b372e0b67aa39ec24b0473e3454201de1c92.tar.gz
freebsd-ports-graphics-53f4b372e0b67aa39ec24b0473e3454201de1c92.tar.zst
freebsd-ports-graphics-53f4b372e0b67aa39ec24b0473e3454201de1c92.zip
- Convert unzip -a to USE_DOS2UNIX
PR: ports/146533 Submitted by: Alex Kozlov <spam@rm-rf.kiev.ua>
Diffstat (limited to 'misc')
-rw-r--r--misc/astrolog/Makefile3
-rw-r--r--misc/projectionlib/Makefile3
2 files changed, 3 insertions, 3 deletions
diff --git a/misc/astrolog/Makefile b/misc/astrolog/Makefile
index 5abf781349b..a2936771ea1 100644
--- a/misc/astrolog/Makefile
+++ b/misc/astrolog/Makefile
@@ -22,6 +22,7 @@ MAINTAINER= ache@FreeBSD.org
COMMENT= An astrology program for X11 and alpha-numeric terminals
USE_ZIP= yes
+USE_DOS2UNIX= ephem/EPHINDEX.TXT
.if !defined(WITHOUT_X11)
USE_XORG= x11
MAKE_ARGS= -DX11
@@ -35,7 +36,7 @@ NO_WRKSUBDIR= yes
post-extract:
-@${MKDIR} ${WRKDIR}/ephem
- ${UNZIP_CMD} -qao ${_DISTDIR}/${EPHEM} -d ${WRKDIR}/ephem
+ ${UNZIP_CMD} ${EXTRACT_BEFORE_ARGS} ${_DISTDIR}/${EPHEM} -d ${WRKDIR}/ephem
post-patch:
@${REINPLACE_CMD} -e "s@malloc.h@stdlib.h@g" \
diff --git a/misc/projectionlib/Makefile b/misc/projectionlib/Makefile
index da34f307400..2919d976e0a 100644
--- a/misc/projectionlib/Makefile
+++ b/misc/projectionlib/Makefile
@@ -16,11 +16,10 @@ COMMENT= A C++ wrapper for the USGS GCTP projection library
LIB_DEPENDS= gctpc.1:${PORTSDIR}/misc/gctpc
-EXTRACT_CMD= unzip -a
-
WRKSRC= ${WRKDIR}/dlgv32/ProjectionLib
USE_ZIP= yes
+USE_DOS2UNIX= *.cpp *.h
USE_LDCONFIG= yes
MAKEFILE= ${FILESDIR}/Makefile