aboutsummaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
authortabthorpe <tabthorpe@FreeBSD.org>2012-07-01 11:49:28 +0800
committertabthorpe <tabthorpe@FreeBSD.org>2012-07-01 11:49:28 +0800
commit766042869d55cca789d0d13e7094e155c812da0a (patch)
treeb072f4c6632694a5e8723759830939686be65ebe /misc
parent5dc8c8b3081d56ba230a3770d0c96f4c832ae435 (diff)
downloadfreebsd-ports-graphics-766042869d55cca789d0d13e7094e155c812da0a.tar.gz
freebsd-ports-graphics-766042869d55cca789d0d13e7094e155c812da0a.tar.zst
freebsd-ports-graphics-766042869d55cca789d0d13e7094e155c812da0a.zip
- Depend on x11/yelp
- Add options to build rendering engine PR: ports/169514 Submitted by: John Marshall <john.marshall riverwillow.com.au>
Diffstat (limited to 'misc')
-rw-r--r--misc/xiphos/Makefile31
1 files changed, 28 insertions, 3 deletions
diff --git a/misc/xiphos/Makefile b/misc/xiphos/Makefile
index 8e9fbaffcbf..1fe2f8bce54 100644
--- a/misc/xiphos/Makefile
+++ b/misc/xiphos/Makefile
@@ -7,7 +7,7 @@
PORTNAME= xiphos
PORTVERSION= 3.1.5
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= misc gnome
MASTER_SITES= SF/gnomesword/Xiphos/${PORTVERSION}
@@ -16,7 +16,8 @@ COMMENT= A bible interface utilizing the sword framework
LICENSE= GPLv2
-RUN_DEPENDS= ${LOCALBASE}/lib/libsword-1.6.2.so:${PORTSDIR}/misc/sword
+RUN_DEPENDS= ${LOCALBASE}/lib/libsword-1.6.2.so:${PORTSDIR}/misc/sword \
+ yelp:${PORTSDIR}/x11/yelp
BUILD_DEPENDS:= ${RUN_DEPENDS} \
docbook2html:${PORTSDIR}/textproc/docbook-utils \
gnome-doc-tool:${PORTSDIR}/textproc/gnome-doc-utils \
@@ -28,10 +29,34 @@ INSTALLS_OMF= yes
INSTALLS_ICONS= yes
USE_GNOME= gnomehack gnomeprefix gtkhtml3 intlhack libgsf
+OPTIONS_SINGLE= BACKEND
+OPTIONS_SINGLE_BACKEND= GTKHTML LIBXUL WEBKIT
+GTKHTML_DESC= Use gtkhtml for rendering
+LIBXUL_DESC= Use xulrunner for rendering
+WEBKIT_DESC= Use webkit for rendering (preferred)
+
+OPTIONS_DEFAULT= WEBKIT
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MWEBKIT}
+WAF_CONFIGURE_ARGS= --backend=webkit
+LIB_DEPENDS= webkitgtk:${PORTSDIR}/www/webkit-gtk2
+.endif
+
+.if ${PORT_OPTIONS:MLIBXUL}
+WAF_CONFIGURE_ARGS= --backend=xulrunner
+USE_GECKO= libxul
+.endif
+
+.if ${PORT_OPTIONS:MGTKHTML}
+WAF_CONFIGURE_ARGS= --backend=gtkhtml
+.endif
+
do-configure:
@cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} ./waf configure \
--prefix=${PREFIX} --destdir=${PREFIX} \
- --backend gtkhtml --gtk=2
+ ${WAF_CONFIGURE_ARGS} --gtk=2
do-build:
@cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ./waf build