aboutsummaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2011-10-20 14:46:04 +0800
committersunpoet <sunpoet@FreeBSD.org>2011-10-20 14:46:04 +0800
commit7dc723eb23e92c0e6d1ac593ed7a1fa164335308 (patch)
tree38f140d669bab9ee41c1c64610bb253145e0a464 /misc
parent62b9a8f8558294896ec7ed4d6954f7c96d5b1bc9 (diff)
downloadfreebsd-ports-graphics-7dc723eb23e92c0e6d1ac593ed7a1fa164335308.tar.gz
freebsd-ports-graphics-7dc723eb23e92c0e6d1ac593ed7a1fa164335308.tar.zst
freebsd-ports-graphics-7dc723eb23e92c0e6d1ac593ed7a1fa164335308.zip
- Add p5-Geo-Coder-OSM 0.02
Geo::Coder::OSM provides an interface to the OpenStreet Nominatim geocoding service. WWW: http://search.cpan.org/dist/Geo-Coder-OSM/
Diffstat (limited to 'misc')
-rw-r--r--misc/Makefile1
-rw-r--r--misc/p5-Geo-Coder-OSM/Makefile36
-rw-r--r--misc/p5-Geo-Coder-OSM/distinfo2
-rw-r--r--misc/p5-Geo-Coder-OSM/pkg-descr4
-rw-r--r--misc/p5-Geo-Coder-OSM/pkg-plist7
5 files changed, 50 insertions, 0 deletions
diff --git a/misc/Makefile b/misc/Makefile
index 7a2efbd76ac..29b891afaa2 100644
--- a/misc/Makefile
+++ b/misc/Makefile
@@ -408,6 +408,7 @@
SUBDIR += p5-Geo-Coder-Multimap
SUBDIR += p5-Geo-Coder-Multiple
SUBDIR += p5-Geo-Coder-Navteq
+ SUBDIR += p5-Geo-Coder-OSM
SUBDIR += p5-Geo-Postcodes
SUBDIR += p5-Geo-Postcodes-DK
SUBDIR += p5-Geo-Postcodes-NO
diff --git a/misc/p5-Geo-Coder-OSM/Makefile b/misc/p5-Geo-Coder-OSM/Makefile
new file mode 100644
index 00000000000..3eab85b1d36
--- /dev/null
+++ b/misc/p5-Geo-Coder-OSM/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: p5-Geo-Coder-OSM
+# Date created: 2011-10-13
+# Whom: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Geo-Coder-OSM
+PORTVERSION= 0.02
+CATEGORIES= misc geography perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Geocode addresses with the OpenStreetMap Nominatim API
+
+BUILD_DEPENDS= p5-JSON>=2:${PORTSDIR}/converters/p5-JSON \
+ p5-JSON-XS>=2:${PORTSDIR}/converters/p5-JSON-XS \
+ p5-URI>=1.36:${PORTSDIR}/net/p5-URI \
+ p5-libwww>=0:${PORTSDIR}/www/p5-libwww
+RUN_DEPENDS= p5-JSON>=2:${PORTSDIR}/converters/p5-JSON \
+ p5-JSON-XS>=2:${PORTSDIR}/converters/p5-JSON-XS \
+ p5-URI>=1.36:${PORTSDIR}/net/p5-URI \
+ p5-libwww>=0:${PORTSDIR}/www/p5-libwww
+
+PERL_CONFIGURE= yes
+
+MAN3= Geo::Coder::OSM.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 501001
+TEST_DEPENDS+= p5-Test-Simple>=0.82:${PORTSDIR}/devel/p5-Test-Simple
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/misc/p5-Geo-Coder-OSM/distinfo b/misc/p5-Geo-Coder-OSM/distinfo
new file mode 100644
index 00000000000..22ccbeba5ff
--- /dev/null
+++ b/misc/p5-Geo-Coder-OSM/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Geo-Coder-OSM-0.02.tar.gz) = bb813b188ac64dfaca46ee1398eb88c73cc12a2ab13b10bf865a45462b63a885
+SIZE (Geo-Coder-OSM-0.02.tar.gz) = 5653
diff --git a/misc/p5-Geo-Coder-OSM/pkg-descr b/misc/p5-Geo-Coder-OSM/pkg-descr
new file mode 100644
index 00000000000..736022981c5
--- /dev/null
+++ b/misc/p5-Geo-Coder-OSM/pkg-descr
@@ -0,0 +1,4 @@
+Geo::Coder::OSM provides an interface to the OpenStreet Nominatim geocoding
+service.
+
+WWW: http://search.cpan.org/dist/Geo-Coder-OSM/
diff --git a/misc/p5-Geo-Coder-OSM/pkg-plist b/misc/p5-Geo-Coder-OSM/pkg-plist
new file mode 100644
index 00000000000..9f717f57f19
--- /dev/null
+++ b/misc/p5-Geo-Coder-OSM/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/Geo/Coder/OSM.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Geo/Coder/OSM/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Geo/Coder/OSM
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Geo/Coder
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Geo
+@dirrmtry %%SITE_PERL%%/Geo/Coder
+@dirrmtry %%SITE_PERL%%/Geo