aboutsummaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2011-10-20 14:47:34 +0800
committersunpoet <sunpoet@FreeBSD.org>2011-10-20 14:47:34 +0800
commitb5d9e8f8be70e8eda4049711e9000f3a071553da (patch)
treebfe8aceb47071aeec8f121d286dfb8bd0d295fbc /misc
parent237000bd824bb330164d59252518785437261d78 (diff)
downloadfreebsd-ports-graphics-b5d9e8f8be70e8eda4049711e9000f3a071553da.tar.gz
freebsd-ports-graphics-b5d9e8f8be70e8eda4049711e9000f3a071553da.tar.zst
freebsd-ports-graphics-b5d9e8f8be70e8eda4049711e9000f3a071553da.zip
- Add p5-Geo-Coder-PlaceFinder 0.05
Geo::Coder::PlaceFinder provides an interface to the Yahoo PlaceFinder geocoding service. WWW: http://search.cpan.org/dist/Geo-Coder-PlaceFinder/
Diffstat (limited to 'misc')
-rw-r--r--misc/Makefile1
-rw-r--r--misc/p5-Geo-Coder-PlaceFinder/Makefile36
-rw-r--r--misc/p5-Geo-Coder-PlaceFinder/distinfo2
-rw-r--r--misc/p5-Geo-Coder-PlaceFinder/pkg-descr4
-rw-r--r--misc/p5-Geo-Coder-PlaceFinder/pkg-plist7
5 files changed, 50 insertions, 0 deletions
diff --git a/misc/Makefile b/misc/Makefile
index ead30f8a23d..a54972c924c 100644
--- a/misc/Makefile
+++ b/misc/Makefile
@@ -410,6 +410,7 @@
SUBDIR += p5-Geo-Coder-Navteq
SUBDIR += p5-Geo-Coder-OSM
SUBDIR += p5-Geo-Coder-Ovi
+ SUBDIR += p5-Geo-Coder-PlaceFinder
SUBDIR += p5-Geo-Postcodes
SUBDIR += p5-Geo-Postcodes-DK
SUBDIR += p5-Geo-Postcodes-NO
diff --git a/misc/p5-Geo-Coder-PlaceFinder/Makefile b/misc/p5-Geo-Coder-PlaceFinder/Makefile
new file mode 100644
index 00000000000..9c7a5252d2b
--- /dev/null
+++ b/misc/p5-Geo-Coder-PlaceFinder/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: p5-Geo-Coder-PlaceFinder
+# Date created: 2011-10-13
+# Whom: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Geo-Coder-PlaceFinder
+PORTVERSION= 0.05
+CATEGORIES= misc geography perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Geocode addresses with Yahoo PlaceFinder
+
+BUILD_DEPENDS= p5-JSON>=2:${PORTSDIR}/converters/p5-JSON \
+ p5-JSON-XS>=2:${PORTSDIR}/converters/p5-JSON-XS \
+ p5-URI>=1.36:${PORTSDIR}/net/p5-URI \
+ p5-libwww>=0:${PORTSDIR}/www/p5-libwww
+RUN_DEPENDS= p5-JSON>=2:${PORTSDIR}/converters/p5-JSON \
+ p5-JSON-XS>=2:${PORTSDIR}/converters/p5-JSON-XS \
+ p5-URI>=1.36:${PORTSDIR}/net/p5-URI \
+ p5-libwww>=0:${PORTSDIR}/www/p5-libwww
+
+PERL_CONFIGURE= yes
+
+MAN3= Geo::Coder::PlaceFinder.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 501001
+TEST_DEPENDS+= p5-Test-Simple>=0.82:${PORTSDIR}/devel/p5-Test-Simple
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/misc/p5-Geo-Coder-PlaceFinder/distinfo b/misc/p5-Geo-Coder-PlaceFinder/distinfo
new file mode 100644
index 00000000000..f25e01fdb3a
--- /dev/null
+++ b/misc/p5-Geo-Coder-PlaceFinder/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Geo-Coder-PlaceFinder-0.05.tar.gz) = 44915daceadb4b6e5ccbe7f759878eaf72b5fc6da4fb6c964d3febf76c7ce234
+SIZE (Geo-Coder-PlaceFinder-0.05.tar.gz) = 6400
diff --git a/misc/p5-Geo-Coder-PlaceFinder/pkg-descr b/misc/p5-Geo-Coder-PlaceFinder/pkg-descr
new file mode 100644
index 00000000000..c90b5a2c85a
--- /dev/null
+++ b/misc/p5-Geo-Coder-PlaceFinder/pkg-descr
@@ -0,0 +1,4 @@
+Geo::Coder::PlaceFinder provides an interface to the Yahoo PlaceFinder geocoding
+service.
+
+WWW: http://search.cpan.org/dist/Geo-Coder-PlaceFinder/
diff --git a/misc/p5-Geo-Coder-PlaceFinder/pkg-plist b/misc/p5-Geo-Coder-PlaceFinder/pkg-plist
new file mode 100644
index 00000000000..e3ee2d8c401
--- /dev/null
+++ b/misc/p5-Geo-Coder-PlaceFinder/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/Geo/Coder/PlaceFinder.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Geo/Coder/PlaceFinder/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Geo/Coder/PlaceFinder
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Geo/Coder
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Geo
+@dirrmtry %%SITE_PERL%%/Geo/Coder
+@dirrmtry %%SITE_PERL%%/Geo