aboutsummaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
authorfjoe <fjoe@FreeBSD.org>2010-10-06 00:44:43 +0800
committerfjoe <fjoe@FreeBSD.org>2010-10-06 00:44:43 +0800
commitcc484d0fc178b47e4c9349195b705e48b13175dc (patch)
treeb145ee48582a2e6a05e21921234167ee3a83af24 /misc
parent6d9a8cb401e61880aac0e4e6776a80ee14952397 (diff)
downloadfreebsd-ports-graphics-cc484d0fc178b47e4c9349195b705e48b13175dc.tar.gz
freebsd-ports-graphics-cc484d0fc178b47e4c9349195b705e48b13175dc.tar.zst
freebsd-ports-graphics-cc484d0fc178b47e4c9349195b705e48b13175dc.zip
Add patch to define __BIG_ENDIAN and __LITTLE_ENDIAN properly.
May fix wctdm on sparc64.
Diffstat (limited to 'misc')
-rw-r--r--misc/dahdi-kmod/Makefile2
-rw-r--r--misc/dahdi-kmod/files/patch-freebsd-include-dahdi-compat-bsd.h14
-rw-r--r--misc/dahdi/Makefile2
-rw-r--r--misc/dahdi/files/patch-freebsd-include-dahdi-compat-bsd.h14
4 files changed, 30 insertions, 2 deletions
diff --git a/misc/dahdi-kmod/Makefile b/misc/dahdi-kmod/Makefile
index 369cc5e0903..9bf67ad19be 100644
--- a/misc/dahdi-kmod/Makefile
+++ b/misc/dahdi-kmod/Makefile
@@ -7,7 +7,7 @@
PORTNAME= dahdi
PORTVERSION= ${DAHDI_VERSION:S/-//g}
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= misc kld
MASTER_SITES= ${MASTER_SITE_LOCAL}\
http://downloads.digium.com/pub/telephony/firmware/releases/:firmware
diff --git a/misc/dahdi-kmod/files/patch-freebsd-include-dahdi-compat-bsd.h b/misc/dahdi-kmod/files/patch-freebsd-include-dahdi-compat-bsd.h
new file mode 100644
index 00000000000..0f95e444421
--- /dev/null
+++ b/misc/dahdi-kmod/files/patch-freebsd-include-dahdi-compat-bsd.h
@@ -0,0 +1,14 @@
+--- freebsd/include/dahdi/compat/bsd.h.orig 2010-10-05 23:41:23.000000000 +0700
++++ freebsd/include/dahdi/compat/bsd.h 2010-10-05 23:42:01.000000000 +0700
+@@ -66,9 +66,11 @@
+ #define __be32 u_int32_t
+
+ #if _BYTE_ORDER == _LITTLE_ENDIAN
++#define __LITTLE_ENDIAN
+ #define __LITTLE_ENDIAN_BITFIELD
+ #define __constant_htons(x) ((uint16_t) (((uint16_t) (x)) << 8 | ((uint16_t) (x)) >> 8))
+ #elif _BYTE_ORDER == _BIG_ENDIAN
++#define __BIG_ENDIAN
+ #define __BIG_ENDIAN_BITFIELD
+ #define __constant_htons(x) (x)
+ #endif
diff --git a/misc/dahdi/Makefile b/misc/dahdi/Makefile
index 369cc5e0903..9bf67ad19be 100644
--- a/misc/dahdi/Makefile
+++ b/misc/dahdi/Makefile
@@ -7,7 +7,7 @@
PORTNAME= dahdi
PORTVERSION= ${DAHDI_VERSION:S/-//g}
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= misc kld
MASTER_SITES= ${MASTER_SITE_LOCAL}\
http://downloads.digium.com/pub/telephony/firmware/releases/:firmware
diff --git a/misc/dahdi/files/patch-freebsd-include-dahdi-compat-bsd.h b/misc/dahdi/files/patch-freebsd-include-dahdi-compat-bsd.h
new file mode 100644
index 00000000000..0f95e444421
--- /dev/null
+++ b/misc/dahdi/files/patch-freebsd-include-dahdi-compat-bsd.h
@@ -0,0 +1,14 @@
+--- freebsd/include/dahdi/compat/bsd.h.orig 2010-10-05 23:41:23.000000000 +0700
++++ freebsd/include/dahdi/compat/bsd.h 2010-10-05 23:42:01.000000000 +0700
+@@ -66,9 +66,11 @@
+ #define __be32 u_int32_t
+
+ #if _BYTE_ORDER == _LITTLE_ENDIAN
++#define __LITTLE_ENDIAN
+ #define __LITTLE_ENDIAN_BITFIELD
+ #define __constant_htons(x) ((uint16_t) (((uint16_t) (x)) << 8 | ((uint16_t) (x)) >> 8))
+ #elif _BYTE_ORDER == _BIG_ENDIAN
++#define __BIG_ENDIAN
+ #define __BIG_ENDIAN_BITFIELD
+ #define __constant_htons(x) (x)
+ #endif