aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/emotion
diff options
context:
space:
mode:
authorstas <stas@FreeBSD.org>2006-10-08 21:48:37 +0800
committerstas <stas@FreeBSD.org>2006-10-08 21:48:37 +0800
commit173755349dc2dd22744f67ee65b533ef3b1c3649 (patch)
treefcddf9b33a006f3b495b40ac5641012787c2a99e /multimedia/emotion
parented21c3e01f7d2d837804666f445b9249d985c327 (diff)
downloadfreebsd-ports-graphics-173755349dc2dd22744f67ee65b533ef3b1c3649.tar.gz
freebsd-ports-graphics-173755349dc2dd22744f67ee65b533ef3b1c3649.tar.zst
freebsd-ports-graphics-173755349dc2dd22744f67ee65b533ef3b1c3649.zip
- Move to LOCALBASE
- Use new EFL framework - Update all e17 ports to the lates stable cvs snapshot - Add additional knobs/options to ports makefiles to control the feature set - Add a bunch of new e17 applications/libraries - Minor improvements/modification. Approved by: vanilla (old maintainer), sem (mentor)
Diffstat (limited to 'multimedia/emotion')
-rw-r--r--multimedia/emotion/Makefile21
-rw-r--r--multimedia/emotion/distinfo6
-rw-r--r--multimedia/emotion/files/patch-configure10
-rw-r--r--multimedia/emotion/pkg-plist6
4 files changed, 21 insertions, 22 deletions
diff --git a/multimedia/emotion/Makefile b/multimedia/emotion/Makefile
index 5b92ee78f15..3887cd6ca4f 100644
--- a/multimedia/emotion/Makefile
+++ b/multimedia/emotion/Makefile
@@ -7,31 +7,25 @@
#
PORTNAME= emotion
-PORTVERSION= 20060719
+PORTVERSION= 20060926
CATEGORIES= multimedia
-MASTER_SITES= http://mbsd.msk.ru/dist/
+MASTER_SITES= http://sunner.elcomnet.ru/~stas/
-MAINTAINER= ssedov@mbsd.msk.ru
+MAINTAINER= stas@FreeBSD.org
COMMENT= Video playback wrapper library for e17
-LIB_DEPENDS= ecore.1:${PORTSDIR}/x11/ecore \
- edje.5:${PORTSDIR}/graphics/edje \
- eet.9:${PORTSDIR}/devel/eet \
- embryo.9:${PORTSDIR}/lang/embryo \
- evas.1:${PORTSDIR}/graphics/evas
-
USE_BZIP2= yes
USE_GMAKE= yes
USE_GNOME= gnomehack pkgconfig gnometarget
+USE_EFL= ecore edje eet embryo evas
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
OPTIONS= XINE "Build Xine module" on \
GST "Build GStreamer module" on
.include <bsd.port.pre.mk>
+.include "../../x11-wm/enlightenment-devel/bsd.efl.mk"
.if defined(WITHOUT_XINE) && defined(WITHOUT_GST)
IGNORE= is useless without playback library. Please run 'make config' and choose one of XINE and GST
@@ -39,14 +33,19 @@ IGNORE= is useless without playback library. Please run 'make config' and choose
.if defined(WITH_XINE)
LIB_DEPENDS+= xine.15:${PORTSDIR}/multimedia/libxine
+CONFIGURE_ARGS+=--enable-xine
PLIST_SUB+= XINE=""
.else
+CONFIGURE_ARGS+=--disable-xine
PLIST_SUB+= XINE="@comment "
.endif
+
.if defined(WITH_GST)
USE_GSTREAMER= ffmpeg good
+CONFIGURE_ARGS+=--enable-gstreamer
PLIST_SUB+= GST=""
.else
+CONFIGURE_ARGS+=--disable-gstreamer
PLIST_SUB+= GST="@comment "
.endif
diff --git a/multimedia/emotion/distinfo b/multimedia/emotion/distinfo
index dcc2f9a24be..b601eba58e9 100644
--- a/multimedia/emotion/distinfo
+++ b/multimedia/emotion/distinfo
@@ -1,3 +1,3 @@
-MD5 (emotion-20060719.tar.bz2) = e5536468ace9cd02c31ae7994eca7c1d
-SHA256 (emotion-20060719.tar.bz2) = 6ec5c3e8e07df8358ef34117eeb90a278d0cab12ffdae0e06c6171c81f439668
-SIZE (emotion-20060719.tar.bz2) = 1425051
+MD5 (emotion-20060926.tar.bz2) = 20b25be2a8ae59b704dbb6b3e37100df
+SHA256 (emotion-20060926.tar.bz2) = 4e007b703cb7c2f2d52336e661968d647df9f40dcc54f5694a0e59f51b1c5886
+SIZE (emotion-20060926.tar.bz2) = 1434266
diff --git a/multimedia/emotion/files/patch-configure b/multimedia/emotion/files/patch-configure
index e032d84c6ce..ce8584392d2 100644
--- a/multimedia/emotion/files/patch-configure
+++ b/multimedia/emotion/files/patch-configure
@@ -1,6 +1,6 @@
---- configure.orig Tue Jul 18 17:40:53 2006
-+++ configure Tue Jul 18 17:41:01 2006
-@@ -21861,27 +21861,6 @@
+--- configure.orig Wed Sep 27 19:06:08 2006
++++ configure Wed Sep 27 19:08:36 2006
+@@ -22241,27 +22241,6 @@
_ACEOF
@@ -25,6 +25,6 @@
-
-
-
- # Check whether --with-eet-prefix or --without-eet-prefix was given.
+ # Check whether --with-eet-prefix was given.
if test "${with_eet_prefix+set}" = set; then
- withval="$with_eet_prefix"
+ withval=$with_eet_prefix; eet_config_prefix="$withval"
diff --git a/multimedia/emotion/pkg-plist b/multimedia/emotion/pkg-plist
index 405cc4bd2aa..da6dcdb15de 100644
--- a/multimedia/emotion/pkg-plist
+++ b/multimedia/emotion/pkg-plist
@@ -13,6 +13,6 @@ lib/libemotion.so
lib/libemotion.so.0
libdata/pkgconfig/emotion.pc
%%DATADIR%%/data/theme.edj
-@dirrmtry share/emotion/data
-@dirrmtry share/emotion
-@dirrmtry lib/emotion
+@dirrm %%DATADIR%%/data
+@dirrm %%DATADIR%%
+@dirrm lib/emotion