aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/gstreamer-plugins
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2004-11-26 14:57:46 +0800
committermarcus <marcus@FreeBSD.org>2004-11-26 14:57:46 +0800
commit6c7eae9695d8595c697792966b3080428447056f (patch)
tree016032bc504b72754601a679487d4f29c48e0a92 /multimedia/gstreamer-plugins
parent43a312f7df9e62d2b4b3158cf0f5e811cc762be8 (diff)
downloadfreebsd-ports-graphics-6c7eae9695d8595c697792966b3080428447056f.tar.gz
freebsd-ports-graphics-6c7eae9695d8595c697792966b3080428447056f.tar.zst
freebsd-ports-graphics-6c7eae9695d8595c697792966b3080428447056f.zip
Update to 0.8.6. For all the changes in this release, see
http://gstreamer.freedesktop.org/releases/gst-plugins/0.8.6.html. * Add support for polypaudio * Disable swfdec temporarily as the swfdec plug-in needs a new version of graphics/swfdec which needs liboil (not yet ported) Submitted by: kwm Approved by: maintainer (blanket)
Diffstat (limited to 'multimedia/gstreamer-plugins')
-rw-r--r--multimedia/gstreamer-plugins/Makefile38
-rw-r--r--multimedia/gstreamer-plugins/distinfo4
-rw-r--r--multimedia/gstreamer-plugins/files/patch-testsuite-multifilesink-multifilesrc_test.c19
-rw-r--r--multimedia/gstreamer-plugins/pkg-plist8
4 files changed, 36 insertions, 33 deletions
diff --git a/multimedia/gstreamer-plugins/Makefile b/multimedia/gstreamer-plugins/Makefile
index 0b11e738997..70d1d45882a 100644
--- a/multimedia/gstreamer-plugins/Makefile
+++ b/multimedia/gstreamer-plugins/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= gstreamer
-PORTVERSION= 0.8.5
-PORTREVISION= 2
+PORTVERSION= 0.8.6
CATEGORIES= multimedia audio
MASTER_SITES= http://gstreamer.freedesktop.org/src/gst-plugins/ \
${MASTER_SITE_GNOME}
@@ -32,6 +31,7 @@ USE_GNOME= gnomehack \
gconf2
USE_REINPLACE= yes
USE_LIBTOOL_VER=15
+GCONF_SCHEMAS= gstreamer-${GST_VERSION}.schemas
CONFIGURE_ARGS= --disable-tests \
--disable-alsa \
--enable-cdrom \
@@ -57,6 +57,7 @@ CONFIGURE_ARGS+=\
--disable-lcs \
--disable-shout2 \
--disable-libvisual \
+ --disable-musepack \
--disable-dirac \
--disable-librfb
@@ -345,6 +346,11 @@ WITH_PANGO=yes
WITH_PNG=yes
.endif
+# polypaudio
+.if exists(${LOCALBASE}/lib/libpolyp-0.6.a)
+WITH_POLYPAUDIO=yes
+.endif
+
# sdl
.if exists(${LOCALBASE}/lib/libSDL-1.1.a)
WITH_SDL=yes
@@ -812,6 +818,16 @@ LIB_DEPENDS+= png.5:${PORTSDIR}/graphics/png
PLIST_SUB+= PNG=""
.endif
+# polypaudio
+.ifndef(WITH_POLYPAUDIO)
+CONFIGURE_ARGS+= --disable-polyp
+PLIST_SUB+= POLYPAUDIO="@comment "
+.else
+LIB_DEPENDS+= polyp-0.6.0:${PORTSDIR}/audio/polypaudio
+
+PLIST_SUB+= POLYPAUDIO=""
+.endif
+
# sdl
.ifndef(WITH_SDL)
CONFIGURE_ARGS+= --disable-sdl \
@@ -846,15 +862,15 @@ PLIST_SUB+= SPEEX="@comment "
#.endif
# swfdec
-.ifndef(WITH_SWFDEC)
+#.ifndef(WITH_SWFDEC)
CONFIGURE_ARGS+= --disable-swfdec
PLIST_SUB+= SWFDEC="@comment "
-.else
-LIB_DEPENDS+= swfdec.0:${PORTSDIR}/graphics/swfdec
-
-CONFIGURE_ARGS+= --enable-swfdec
-PLIST_SUB+= SWFDEC=""
-.endif
+#.else
+#LIB_DEPENDS+= swfdec.0:${PORTSDIR}/graphics/swfdec
+#
+#CONFIGURE_ARGS+= --enable-swfdec
+#PLIST_SUB+= SWFDEC=""
+#.endif
# vorbis
.ifndef(WITH_VORBIS)
@@ -1080,6 +1096,10 @@ pre-everything::
@${ECHO_MSG} '===>'
@${ECHO_MSG} '===> Define WITH_PNG to enable png Video plugin'
.endif
+.ifndef(WITH_POLYPAUDIO)
+ @${ECHO_MSG} '===>'
+ @${ECHO_MSG} '===> Define WITH_POLYPAUDIO to enable polypaudio audio plugin'
+.endif
.ifndef(WITH_SDL)
@${ECHO_MSG} '===>'
@${ECHO_MSG} '===> Define WITH_SDL to enable SDL Video plugin'
diff --git a/multimedia/gstreamer-plugins/distinfo b/multimedia/gstreamer-plugins/distinfo
index dbece6d3bd7..1c4d6a648cc 100644
--- a/multimedia/gstreamer-plugins/distinfo
+++ b/multimedia/gstreamer-plugins/distinfo
@@ -1,2 +1,2 @@
-MD5 (gnome2/gst-plugins-0.8.5.tar.bz2) = da9ed7c74b9ac0ccc5d2efcf4fd60db0
-SIZE (gnome2/gst-plugins-0.8.5.tar.bz2) = 2031638
+MD5 (gnome2/gst-plugins-0.8.6.tar.bz2) = e6b04215e7d928bd2fcce390ab406ffd
+SIZE (gnome2/gst-plugins-0.8.6.tar.bz2) = 2033762
diff --git a/multimedia/gstreamer-plugins/files/patch-testsuite-multifilesink-multifilesrc_test.c b/multimedia/gstreamer-plugins/files/patch-testsuite-multifilesink-multifilesrc_test.c
deleted file mode 100644
index a7aed48e41b..00000000000
--- a/multimedia/gstreamer-plugins/files/patch-testsuite-multifilesink-multifilesrc_test.c
+++ /dev/null
@@ -1,19 +0,0 @@
---- testsuite/multifilesink/multifilesrc_test.c.orig Tue Oct 12 18:02:55 2004
-+++ testsuite/multifilesink/multifilesrc_test.c Tue Oct 12 18:24:43 2004
-@@ -3,14 +3,14 @@
- int
- main (int argc, char **argv)
- {
-- gst_init (&argc, &argv);
--
- GSList *locations;
- int i;
-
- //gboolean retval;
-
- GstElement *pipeline, *src, *sink;
-+
-+ gst_init (&argc, &argv);
-
- g_print ("creating sink\n");
- sink = gst_element_factory_make ("multifilesink", "sink");
diff --git a/multimedia/gstreamer-plugins/pkg-plist b/multimedia/gstreamer-plugins/pkg-plist
index 19df398ae3a..3278513fa2e 100644
--- a/multimedia/gstreamer-plugins/pkg-plist
+++ b/multimedia/gstreamer-plugins/pkg-plist
@@ -1,8 +1,5 @@
bin/gst-launch-ext-%%VERSION%%
bin/gst-visualise-%%VERSION%%
-@unexec env GCONF_CONFIG_SOURCE=xml::%D/etc/gconf/gconf.xml.defaults gconftool-2 --makefile-uninstall-rule %D/etc/gconf/schemas/gstreamer-%%VERSION%%.schemas >/dev/null || /usr/bin/true
-etc/gconf/schemas/gstreamer-%%VERSION%%.schemas
-@exec env GCONF_CONFIG_SOURCE=xml::%D/etc/gconf/gconf.xml.defaults gconftool-2 --makefile-install-rule %D/etc/gconf/schemas/gstreamer-%%VERSION%%.schemas >/dev/null || /usr/bin/true
include/gstreamer-%%VERSION%%/gst/audio/gstaudiofilter.h
include/gstreamer-%%VERSION%%/gst/audio/audioclock.h
include/gstreamer-%%VERSION%%/gst/audio/audio.h
@@ -67,6 +64,7 @@ lib/gstreamer-%%VERSION%%/libgstdeinterlace.so
%%LIBDVDREAD%%lib/gstreamer-%%VERSION%%/libgstdvdreadsrc.so
lib/gstreamer-%%VERSION%%/libgstefence.so
lib/gstreamer-%%VERSION%%/libgsteffectv.so
+lib/gstreamer-%%VERSION%%/libgstequalizer.so
%%ESOUND%%lib/gstreamer-%%VERSION%%/libgstesd.so
%%FAAC%%lib/gstreamer-%%VERSION%%/libgstfaac.so
%%FAAD%%lib/gstreamer-%%VERSION%%/libgstfaad.so
@@ -175,6 +173,7 @@ lib/gstreamer-%%VERSION%%/libgstximagesink.so
lib/gstreamer-%%VERSION%%/libgstxvimagesink.so
lib/gstreamer-%%VERSION%%/libgstxwindowlistener.so
lib/gstreamer-%%VERSION%%/libgsty4menc.so
+%%POLYPAUDIO%%lib/gstreamer-%%VERSION%%/libpolypaudio.so
lib/libgstgconf-%%VERSION%%.a
lib/libgstgconf-%%VERSION%%.so
lib/libgstgconf-%%VERSION%%.so.%%SHLIB_VERSION%%
@@ -198,6 +197,8 @@ share/locale/az/LC_MESSAGES/gst-plugins-%%VERSION%%.mo
share/locale/cs/LC_MESSAGES/gst-plugins-%%VERSION%%.mo
share/locale/en_GB/LC_MESSAGES/gst-plugins-%%VERSION%%.mo
share/locale/hu/LC_MESSAGES/gst-plugins-%%VERSION%%.mo
+share/locale/it/LC_MESSAGES/gst-plugins-%%VERSION%%.mo
+share/locale/nb/LC_MESSAGES/gst-plugins-%%VERSION%%.mo
share/locale/nl/LC_MESSAGES/gst-plugins-%%VERSION%%.mo
share/locale/or/LC_MESSAGES/gst-plugins-%%VERSION%%.mo
share/locale/sq/LC_MESSAGES/gst-plugins-%%VERSION%%.mo
@@ -209,6 +210,7 @@ share/locale/uk/LC_MESSAGES/gst-plugins-%%VERSION%%.mo
@dirrm include/gstreamer-%%VERSION%%/gst/xoverlay
@dirrm include/gstreamer-%%VERSION%%/gst/video
@dirrm include/gstreamer-%%VERSION%%/gst/tuner
+@dirrm include/gstreamer-%%VERSION%%/gst/tag
@dirrm include/gstreamer-%%VERSION%%/gst/riff
@dirrm include/gstreamer-%%VERSION%%/gst/resample
@dirrm include/gstreamer-%%VERSION%%/gst/propertyprobe