aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/gstreamer-plugins
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2003-11-07 15:37:03 +0800
committermarcus <marcus@FreeBSD.org>2003-11-07 15:37:03 +0800
commitfaa6da350ce5e8ba4f0f3e297d37c8c611df93b4 (patch)
treea362b1abe29d795a45c7609ee6fb5a912c7e8629 /multimedia/gstreamer-plugins
parent4f47e2606cae3b32b9d524ab9e971f5bfca2229d (diff)
downloadfreebsd-ports-graphics-faa6da350ce5e8ba4f0f3e297d37c8c611df93b4.tar.gz
freebsd-ports-graphics-faa6da350ce5e8ba4f0f3e297d37c8c611df93b4.tar.zst
freebsd-ports-graphics-faa6da350ce5e8ba4f0f3e297d37c8c611df93b4.zip
Add optional swfdec support for rendering Flash animations. Also, correct
a Makefile typo. Submitted by: bland Approved by: maintainer (implicit)
Diffstat (limited to 'multimedia/gstreamer-plugins')
-rw-r--r--multimedia/gstreamer-plugins/Makefile18
-rw-r--r--multimedia/gstreamer-plugins/pkg-plist1
2 files changed, 18 insertions, 1 deletions
diff --git a/multimedia/gstreamer-plugins/Makefile b/multimedia/gstreamer-plugins/Makefile
index 4b480db2c9e..b225e354b95 100644
--- a/multimedia/gstreamer-plugins/Makefile
+++ b/multimedia/gstreamer-plugins/Makefile
@@ -18,7 +18,7 @@ MAINTAINER= lioux@FreeBSD.org
COMMENT= GStreamer written collection of plugins handling several media types
LIB_DEPENDS= gstreamer-0.6.1:${PORTSDIR}/multimedia/gstreamer \
- popt.0:${PORTSDIR}/devel/popt \
+ popt.0:${PORTSDIR}/devel/popt
USE_X_PREFIX= yes
USE_BZIP2= yes
@@ -260,6 +260,11 @@ WITH_PNG=yes
WITH_SDL=yes
.endif
+# swfdec
+.if exists(${X11BASE}/lib/libswfdec.a)
+WITH_SWFDEC=yes
+.endif
+
# vorbis
.if exists(${LOCALBASE}/lib/libvorbis.a)
WITH_VORBIS=yes
@@ -582,6 +587,17 @@ CONFIGURE_ENV+= SDL_CONFIG=${SDL_CONFIG}
PLIST_SUB+= SDL=""
.endif
+# swfdec
+.ifndef(WITH_SWFDEC)
+CONFIGURE_ARGS+= --disable-swfdec
+PLIST_SUB+= SWFDEC="@comment "
+.else
+LIB_DEPENDS+= swfdec.0:${PORTSDIR}/graphics/swfdec
+
+CONFIGURE_ARGS+= --enable-swfdec
+PLIST_SUB+= SWFDEC=""
+.endif
+
# vorbis
.ifndef(WITH_VORBIS)
CONFIGURE_ARGS+= --disable-vorbis \
diff --git a/multimedia/gstreamer-plugins/pkg-plist b/multimedia/gstreamer-plugins/pkg-plist
index e87114aefea..72d3224c82c 100644
--- a/multimedia/gstreamer-plugins/pkg-plist
+++ b/multimedia/gstreamer-plugins/pkg-plist
@@ -96,6 +96,7 @@ lib/gstreamer-%%VERSION%%/libgstspeed.so
lib/gstreamer-%%VERSION%%/libgststereo.so
lib/gstreamer-%%VERSION%%/libgststereo2mono.so
lib/gstreamer-%%VERSION%%/libgststereosplit.so
+%%SWFDEC%%lib/gstreamer-%%VERSION%%/libgstswfdec.so
lib/gstreamer-%%VERSION%%/libgstsynaesthesia.so
lib/gstreamer-%%VERSION%%/libgstudp.so
lib/gstreamer-%%VERSION%%/libgstvbidec.so