aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/gstreamer80/files
diff options
context:
space:
mode:
authorlioux <lioux@FreeBSD.org>2002-10-27 00:25:05 +0800
committerlioux <lioux@FreeBSD.org>2002-10-27 00:25:05 +0800
commitc2a865bcb58d363ea00c16213aaba311cda9073b (patch)
treec455844af6ef30b53a3e3e910cd449b1d4a378c4 /multimedia/gstreamer80/files
parent0b1be3ce226e6dd7e682eaea5adc905b77756635 (diff)
downloadfreebsd-ports-graphics-c2a865bcb58d363ea00c16213aaba311cda9073b.tar.gz
freebsd-ports-graphics-c2a865bcb58d363ea00c16213aaba311cda9073b.tar.zst
freebsd-ports-graphics-c2a865bcb58d363ea00c16213aaba311cda9073b.zip
Update to 0.4.1
Diffstat (limited to 'multimedia/gstreamer80/files')
-rw-r--r--multimedia/gstreamer80/files/patch-gst::gstthread.c22
-rw-r--r--multimedia/gstreamer80/files/patch-libs::ext::cothreads::tests::Makefile.in6
-rw-r--r--multimedia/gstreamer80/files/patch-libs::ext::cothreads::tests::cothreads.c18
3 files changed, 3 insertions, 43 deletions
diff --git a/multimedia/gstreamer80/files/patch-gst::gstthread.c b/multimedia/gstreamer80/files/patch-gst::gstthread.c
deleted file mode 100644
index e6f33930cd3..00000000000
--- a/multimedia/gstreamer80/files/patch-gst::gstthread.c
+++ /dev/null
@@ -1,22 +0,0 @@
---- gst/gstthread.c.orig Wed Jul 10 15:22:00 2002
-+++ gst/gstthread.c Wed Jul 10 15:22:52 2002
-@@ -147,7 +147,7 @@
- thread->cond = g_cond_new ();
-
- thread->ppid = getpid ();
-- thread->thread_id = -1;
-+ thread->thread_id = (pthread_t) -1;
- }
-
- static void
-@@ -276,8 +276,8 @@
- if (pthread_attr_init (&thread->attr) != 0)
- g_warning ("pthread_attr_init returned an error !");
- if (gst_scheduler_get_preferred_stack (GST_ELEMENT_SCHED (element), &thread->stack, &stacksize)) {
-- if (pthread_attr_setstack (&thread->attr, thread->stack, stacksize) != 0) {
-- g_warning ("pthread_attr_setstack failed");
-+ if (pthread_attr_setstacksize (&thread->attr, stacksize) != 0) {
-+ g_warning ("pthread_attr_setstacksize failed");
- return GST_STATE_FAILURE;
- }
- GST_DEBUG (GST_CAT_THREAD, "pthread attr set stack at %p of size %ld",
diff --git a/multimedia/gstreamer80/files/patch-libs::ext::cothreads::tests::Makefile.in b/multimedia/gstreamer80/files/patch-libs::ext::cothreads::tests::Makefile.in
index 19d00d8a9e2..fd554c27807 100644
--- a/multimedia/gstreamer80/files/patch-libs::ext::cothreads::tests::Makefile.in
+++ b/multimedia/gstreamer80/files/patch-libs::ext::cothreads::tests::Makefile.in
@@ -1,6 +1,6 @@
---- libs/ext/cothreads/tests/Makefile.in.orig Wed Jul 10 15:44:45 2002
-+++ libs/ext/cothreads/tests/Makefile.in Wed Jul 10 15:45:06 2002
-@@ -76,7 +76,7 @@
+--- libs/ext/cothreads/tests/Makefile.in.orig Sat Sep 28 23:05:55 2002
++++ libs/ext/cothreads/tests/Makefile.in Sat Sep 28 23:06:23 2002
+@@ -83,7 +83,7 @@
GLIB_CFLAGS = @GLIB_CFLAGS@
GLIB_LIBS = @GLIB_LIBS@
GTHREAD_CFLAGS = @GTHREAD_CFLAGS@
diff --git a/multimedia/gstreamer80/files/patch-libs::ext::cothreads::tests::cothreads.c b/multimedia/gstreamer80/files/patch-libs::ext::cothreads::tests::cothreads.c
deleted file mode 100644
index a7ca2581f2b..00000000000
--- a/multimedia/gstreamer80/files/patch-libs::ext::cothreads::tests::cothreads.c
+++ /dev/null
@@ -1,18 +0,0 @@
---- libs/ext/cothreads/tests/cothreads.c.orig Fri Jun 21 01:33:11 2002
-+++ libs/ext/cothreads/tests/cothreads.c Mon Jul 15 18:11:38 2002
-@@ -79,10 +79,13 @@
- printf ("0: creating the gthreads\n");
- for (i=0; i<NGTHREADS; i++) {
- pthreadnum[i] = i+1;
-- if (posix_memalign (&stack, MAIN_STACK_SIZE, MAIN_STACK_SIZE))
-+ stack = malloc (MAIN_STACK_SIZE * (1.0 + 1.0/16));
-+ if (!stack)
- perror ("allocating pthread stack of size %d", MAIN_STACK_SIZE);
-+ stack = (void*)((int)stack &~ (int)(MAIN_STACK_SIZE / 16 - 1));
-+ stack += 1;
- pthread_attr_init (&attr[i]);
-- if (!pthread_attr_setstack (&attr[i], stack, MAIN_STACK_SIZE))
-+ if (!pthread_attr_setstacksize (&attr[i], MAIN_STACK_SIZE))
- perror ("setting stack size");
- pthread_create (&thread[i], &attr[i], pthread, &pthreadnum[i]);
- }