aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/libmatroska/Makefile
diff options
context:
space:
mode:
authorlioux <lioux@FreeBSD.org>2003-05-23 11:55:31 +0800
committerlioux <lioux@FreeBSD.org>2003-05-23 11:55:31 +0800
commit889db38e89c54414d2dc8d14cd34e89bfea7c628 (patch)
treed8f175d6f84738499b984ebf5c146ba9764e4269 /multimedia/libmatroska/Makefile
parent23429dd3eba8d7041da79a2c3c49fa4fd757c6b5 (diff)
downloadfreebsd-ports-graphics-889db38e89c54414d2dc8d14cd34e89bfea7c628.tar.gz
freebsd-ports-graphics-889db38e89c54414d2dc8d14cd34e89bfea7c628.tar.zst
freebsd-ports-graphics-889db38e89c54414d2dc8d14cd34e89bfea7c628.zip
Update to 0.4.3
Diffstat (limited to 'multimedia/libmatroska/Makefile')
-rw-r--r--multimedia/libmatroska/Makefile25
1 files changed, 22 insertions, 3 deletions
diff --git a/multimedia/libmatroska/Makefile b/multimedia/libmatroska/Makefile
index 5a9de54bfc2..26591467cf9 100644
--- a/multimedia/libmatroska/Makefile
+++ b/multimedia/libmatroska/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= libmatroska
-PORTVERSION= 0.4.2
+PORTVERSION= 0.4.3
CATEGORIES= multimedia audio
MASTER_SITES= http://matroska.sourceforge.net/downloads/
@@ -16,7 +16,6 @@ COMMENT= Extensible Multimedia Container Format
BUILD_DEPENDS= ${LOCALBASE}/lib/libebml.a:${PORTSDIR}/textproc/libebml
USE_BZIP2= yes
-USE_GCC= 3.1
USE_GMAKE= yes
USE_REINPLACE= yes
BUILD_WRKSRC= ${WRKSRC}/make/linux
@@ -44,4 +43,24 @@ do-configure:
s,^(INSTALL_OPTS_LIB|INSTALL_OPTS)[[:space:]]*=.*$$,\1=${INSTALL_DATA},' \
${WRKSRC}/make/linux/Makefile
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+# this is gcc 2.x
+CFLAGS+= -DNO_WSTRING
+.endif
+
+.if exists(${LOCALBASE}/bin/gcc32)
+WITH_GCC_32= yes
+.else if exists(${LOCALBASE}/bin/gcc31)
+WITH_GCC_31= yes
+.endif
+
+# prefer 3.2 over 3.1
+.if defined (WITH_GCC_31)
+USE_GCC=3.1
+.else
+USE_GCC=3.2
+.endif
+
+.include <bsd.port.post.mk>