aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/mythtv
diff options
context:
space:
mode:
authorgrog <grog@FreeBSD.org>2007-01-17 14:01:05 +0800
committergrog <grog@FreeBSD.org>2007-01-17 14:01:05 +0800
commit5bdb96256c8b6e35d6ca0d54fed1259bf3fecb0d (patch)
tree6c2bb9fe71f292be7fd38650264d35e0812993a8 /multimedia/mythtv
parent50aa98f277a13809e3dca876665e0634bef466f7 (diff)
downloadfreebsd-ports-graphics-5bdb96256c8b6e35d6ca0d54fed1259bf3fecb0d.tar.gz
freebsd-ports-graphics-5bdb96256c8b6e35d6ca0d54fed1259bf3fecb0d.tar.zst
freebsd-ports-graphics-5bdb96256c8b6e35d6ca0d54fed1259bf3fecb0d.zip
Install p5-XML-SAX-Expat explicitly; otherwise a parser gets installed
that is subsequently rejected. Make a better job of configuring what we can. qt-mysql-plugin is a run dependency, not a build dependency.
Diffstat (limited to 'multimedia/mythtv')
-rw-r--r--multimedia/mythtv/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/multimedia/mythtv/Makefile b/multimedia/mythtv/Makefile
index d67e4812ebd..1ddc38a4675 100644
--- a/multimedia/mythtv/Makefile
+++ b/multimedia/mythtv/Makefile
@@ -17,12 +17,13 @@ COMMENT= MythTV is a homebrew PVR project
ONLY_FOR_ARCHS= i386
BUILD_DEPENDS= qmake:${PORTSDIR}/devel/qmake \
- ${X11BASE}/lib/plugins/sqldrivers/libqsqlmysql.so:${PORTSDIR}/databases/qt-mysql-plugin
+ ${SITE_PERL}/${PERL_ARCH}/XML/Parser/Expat.pm:${PORTSDIR}/textproc/p5-XML-SAX-Expat
LIB_DEPENDS= mp3lame.0:${PORTSDIR}/audio/lame \
freetype.9:${PORTSDIR}/print/freetype2
RUN_DEPENDS= tv_check:${PORTSDIR}/textproc/p5-xmltv \
+ ${X11BASE}/lib/plugins/sqldrivers/libqsqlmysql.so:${PORTSDIR}/databases/qt-mysql-plugin \
wget:${PORTSDIR}/ftp/wget
USE_BZIP2= yes
@@ -70,9 +71,10 @@ do-configure:
-spec ${LOCALBASE}/share/qt/mkspecs/freebsd-g++ mythtv.pro
post-install:
- ${MKDIR} ${PREFIX}/share/mythtv/database
+ ${MKDIR} -p ${PREFIX}/share/mythtv/database
${CP} ${WRKSRC}/database/mc.sql ${PREFIX}/share/mythtv/database
${CP} ${WRKSRC}/programs/mythtv-setup/mythtv-setup ${PREFIX}/bin/mythtv-setup
- @${CAT} ${PKGMESSAGE}
+ ${SETENV} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
+ ${MKDIR} ${PREFIX}/share/mythtv/database
.include <bsd.port.post.mk>