aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/ogle
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2004-08-15 22:49:36 +0800
committerpav <pav@FreeBSD.org>2004-08-15 22:49:36 +0800
commit852b92d268dec5c5af8d901545ebb4d02f576f9a (patch)
tree0fa8a56e90fa187e3f0ea66414949ea0c1b2a851 /multimedia/ogle
parent133ea2ee13bd3f219bfbc10b5bc66749944f59e9 (diff)
downloadfreebsd-ports-graphics-852b92d268dec5c5af8d901545ebb4d02f576f9a.tar.gz
freebsd-ports-graphics-852b92d268dec5c5af8d901545ebb4d02f576f9a.tar.zst
freebsd-ports-graphics-852b92d268dec5c5af8d901545ebb4d02f576f9a.zip
- Fix build with gcc-3.4 by increasing optimization level to -O2
This is a workaround for what looks like preprocessor bug in gcc Clue provided by: bland
Diffstat (limited to 'multimedia/ogle')
-rw-r--r--multimedia/ogle/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/multimedia/ogle/Makefile b/multimedia/ogle/Makefile
index 7e6363f3cff..5eee53996c7 100644
--- a/multimedia/ogle/Makefile
+++ b/multimedia/ogle/Makefile
@@ -54,6 +54,12 @@ pre-configure:
.include <bsd.port.pre.mk>
+# XXX due to gcc-3.4 (20040706) bug in preprocessing of inline functions,
+# this needs at least -O2 to compile. Fails with -O
+.if ${OSVERSION} >= 502126
+CFLAGS+= -O2
+.endif
+
# hack to make ogle work with liba52 + djbfft
.if exists(${LOCALBASE}/lib/liba52.la)
LIBA52_DEP_LIBS!= ${GREP} dependency_libs ${LOCALBASE}/lib/liba52.la | ${CUT} -d \' -f 2