aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/totem
diff options
context:
space:
mode:
authorahze <ahze@FreeBSD.org>2006-04-30 07:03:03 +0800
committerahze <ahze@FreeBSD.org>2006-04-30 07:03:03 +0800
commit37141a4239ce132a460689dacc49f431214e670b (patch)
tree841e14a903993df6f2654c4de34024a326f9e59b /multimedia/totem
parent8967d0ac35824f19b6b0545589662965de0f1988 (diff)
downloadfreebsd-ports-graphics-37141a4239ce132a460689dacc49f431214e670b.tar.gz
freebsd-ports-graphics-37141a4239ce132a460689dacc49f431214e670b.tar.zst
freebsd-ports-graphics-37141a4239ce132a460689dacc49f431214e670b.zip
- Update gstreamer to 0.10
- Move all old gstreamer 0.8 ports to gstreamer*80 [1] - Chase all ports with new gstreamer or gstreaemer moves Repocopied by: marcus [1]
Diffstat (limited to 'multimedia/totem')
-rw-r--r--multimedia/totem/Makefile17
-rw-r--r--multimedia/totem/distinfo6
-rw-r--r--multimedia/totem/files/patch-src_totem-disk.c26
-rw-r--r--multimedia/totem/pkg-plist14
4 files changed, 29 insertions, 34 deletions
diff --git a/multimedia/totem/Makefile b/multimedia/totem/Makefile
index 87bbe6b2ec7..7f17eec05a8 100644
--- a/multimedia/totem/Makefile
+++ b/multimedia/totem/Makefile
@@ -6,24 +6,25 @@
#
PORTNAME= totem
-PORTVERSION= 1.2.1
-PORTREVISION= 2
+PORTVERSION= 1.4.0
CATEGORIES= multimedia gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/${PORTNAME}/${PORTVERSION:R}
+MASTER_SITE_SUBDIR= sources/${PORTNAME}/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}
DIST_SUBDIR= gnome2
MAINTAINER?= hendrik@scholz.net
COMMENT?= A Xine-based video player for the Gnome 2 Desktop
BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/iso-codes.pc:${PORTSDIR}/misc/iso-codes
+LIB_DEPENDS= musicbrainz:${PORTSDIR}/audio/libmusicbrainz
RUN_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/iso-codes.pc:${PORTSDIR}/misc/iso-codes
-USE_REINPLACE= yes
USE_BZIP2= yes
+USE_GETTEXT= yes
USE_X_PREFIX= yes
USE_GNOME= gnomeprefix intlhack gnomehack gnomedesktop desktopfileutils \
nautiluscdburner
+GNOME_DESKTOP_VERSION=2
WANT_GSTREAMER= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
@@ -40,12 +41,10 @@ OPTIONS?= DVDNAV "Enable DVD support" on \
MAN1= totem.1 totem-video-thumbnailer.1
GCONF_SCHEMAS= totem-handlers.schemas totem-video-thumbnail.schemas \
totem.schemas
-CONFLICTS= totem-gstreamer-[0-9]*
+CONFLICTS?= totem-gstreamer-[0-9]*
.include <bsd.port.pre.mk>
-LIB_DEPENDS+= musicbrainz:${PORTSDIR}/audio/libmusicbrainz
-
.if defined(WITH_MOZILLA_PLUGIN)
USE_GECKO= firefox mozilla seamonkey
.include "${.CURDIR}/../../www/mozilla/bsd.gecko.mk"
@@ -58,9 +57,7 @@ CONFIGURE_ARGS+=--disable-mozilla
.endif
.if defined(WITH_GSTREAMER)
-BUILD_DEPENDS+= ${LOCALBASE}/libdata/pkgconfig/iso-codes.pc:${PORTSDIR}/misc/iso-codes
-RUN_DEPENDS+= ${LOCALBASE}/libdata/pkgconfig/iso-codes.pc:${PORTSDIR}/misc/iso-codes
-CONFIGURE_ARGS+=--enable-gstreamer
+CONFIGURE_ARGS+=--enable-gstreamer=0.10
USE_GSTREAMER+= gnomevfs core gconf
WITHOUT_DVDNAV= yes
PLIST_SUB+= GSTREAMER=""
diff --git a/multimedia/totem/distinfo b/multimedia/totem/distinfo
index 3925a5b76a9..47d1fdd4b82 100644
--- a/multimedia/totem/distinfo
+++ b/multimedia/totem/distinfo
@@ -1,3 +1,3 @@
-MD5 (gnome2/totem-1.2.1.tar.bz2) = 7915469973500dba01d51edfd9e49cf3
-SHA256 (gnome2/totem-1.2.1.tar.bz2) = 569c265cd184ef559cf2e266812f09f93d1642c6fd612c92e1a639e0f91c6621
-SIZE (gnome2/totem-1.2.1.tar.bz2) = 1411347
+MD5 (gnome2/totem-1.4.0.tar.bz2) = 34be929fc384b078afabd6d81ab47285
+SHA256 (gnome2/totem-1.4.0.tar.bz2) = 96d19746c60416f38fbd8a82f6e0220ec5eeace054061fad7af08d61481eeb5e
+SIZE (gnome2/totem-1.4.0.tar.bz2) = 1669373
diff --git a/multimedia/totem/files/patch-src_totem-disk.c b/multimedia/totem/files/patch-src_totem-disk.c
index d522008f04b..6b6ef565e28 100644
--- a/multimedia/totem/files/patch-src_totem-disk.c
+++ b/multimedia/totem/files/patch-src_totem-disk.c
@@ -1,14 +1,8 @@
---- src/plparse/totem-disc.c.orig Sun Mar 13 08:37:57 2005
-+++ src/plparse/totem-disc.c Wed Mar 23 03:29:26 2005
-@@ -34,18 +34,40 @@
- #include <stdio.h>
- #include <stdlib.h>
- #include <errno.h>
--#include <mntent.h>
- #include <string.h>
-
- #include <sys/ioctl.h>
- #include <sys/stat.h>
+--- src/plparse/totem-disc.c.orig Thu Nov 24 16:53:02 2005
++++ src/plparse/totem-disc.c Sun Dec 18 13:34:12 2005
+@@ -43,7 +43,29 @@
+ #include <glib/gi18n.h>
+ #include <libgnomevfs/gnome-vfs.h>
+#ifdef __FreeBSD__
+#include <sys/cdio.h>
@@ -31,16 +25,8 @@
+#define ENOMEDIUM ENODEV
+#define CDROM_GET_CAPABILITY CDIOCCLRDEBUG
+#else
-+#include <mntent.h>
-+#include <linux/cdrom.h>
+ #include <linux/cdrom.h>
+#endif
-+
- #include <glib.h>
- #include <glib/gi18n.h>
- #include <libgnomevfs/gnome-vfs.h>
--#include <linux/cdrom.h>
--
#include "totem-disc.h"
- typedef struct _CdCache {
diff --git a/multimedia/totem/pkg-plist b/multimedia/totem/pkg-plist
index 3bcad3799c8..137cc15c409 100644
--- a/multimedia/totem/pkg-plist
+++ b/multimedia/totem/pkg-plist
@@ -2,6 +2,7 @@ bin/totem
bin/totem-video-thumbnailer
include/totem/1/plparser/totem-disc.h
include/totem/1/plparser/totem-pl-parser-builtins.h
+include/totem/1/plparser/totem-pl-parser-features.h
include/totem/1/plparser/totem-pl-parser.h
%%MOZILLA%%lib/browser_plugins/libtotem_mozilla.a
%%MOZILLA%%lib/browser_plugins/libtotem_mozilla.la
@@ -10,7 +11,7 @@ include/totem/1/plparser/totem-pl-parser.h
lib/libtotem-plparser.a
lib/libtotem-plparser.la
lib/libtotem-plparser.so
-lib/libtotem-plparser.so.1
+lib/libtotem-plparser.so.2
lib/nautilus/extensions-1.0/libtotem-properties-page.a
lib/nautilus/extensions-1.0/libtotem-properties-page.la
lib/nautilus/extensions-1.0/libtotem-properties-page.so
@@ -28,6 +29,9 @@ share/gnome/help/totem/C/figures/totem_volume_maximum_button.png
share/gnome/help/totem/C/figures/totem_volume_mute_button.png
share/gnome/help/totem/C/legal.xml
share/gnome/help/totem/C/totem.xml
+share/gnome/help/totem/bg/figures/totem_start_window.png
+share/gnome/help/totem/bg/legal.xml
+share/gnome/help/totem/bg/totem.xml
share/gnome/help/totem/de/figures/totem_next_button.png
share/gnome/help/totem/de/figures/totem_pause_button.png
share/gnome/help/totem/de/figures/totem_play_button.png
@@ -73,6 +77,7 @@ share/gnome/help/totem/uk/figures/totem_volume_mute_button.png
share/gnome/help/totem/uk/legal.xml
share/gnome/help/totem/uk/totem.xml
share/gnome/omf/totem/totem-C.omf
+share/gnome/omf/totem/totem-bg.omf
share/gnome/omf/totem/totem-de.omf
share/gnome/omf/totem/totem-es.omf
share/gnome/omf/totem/totem-fr.omf
@@ -109,6 +114,7 @@ share/locale/az/LC_MESSAGES/totem.mo
share/locale/be/LC_MESSAGES/totem.mo
share/locale/bg/LC_MESSAGES/totem.mo
share/locale/bn/LC_MESSAGES/totem.mo
+share/locale/br/LC_MESSAGES/totem.mo
share/locale/ca/LC_MESSAGES/totem.mo
share/locale/cs/LC_MESSAGES/totem.mo
share/locale/cy/LC_MESSAGES/totem.mo
@@ -135,6 +141,7 @@ share/locale/is/LC_MESSAGES/totem.mo
share/locale/it/LC_MESSAGES/totem.mo
share/locale/ja/LC_MESSAGES/totem.mo
share/locale/ko/LC_MESSAGES/totem.mo
+share/locale/ku/LC_MESSAGES/totem.mo
share/locale/lt/LC_MESSAGES/totem.mo
share/locale/lv/LC_MESSAGES/totem.mo
share/locale/mk/LC_MESSAGES/totem.mo
@@ -165,7 +172,10 @@ share/locale/vi/LC_MESSAGES/totem.mo
share/locale/wa/LC_MESSAGES/totem.mo
share/locale/xh/LC_MESSAGES/totem.mo
share/locale/zh_CN/LC_MESSAGES/totem.mo
+share/locale/zh_HK/LC_MESSAGES/totem.mo
share/locale/zh_TW/LC_MESSAGES/totem.mo
+@dirrmtry share/locale/ku/LC_MESSAGES
+@dirrmtry share/locale/ku
@dirrm share/gnome/totem
@dirrm share/gnome/omf/totem
@dirrm share/gnome/help/totem/uk/figures
@@ -178,6 +188,8 @@ share/locale/zh_TW/LC_MESSAGES/totem.mo
@dirrm share/gnome/help/totem/es
@dirrm share/gnome/help/totem/de/figures
@dirrm share/gnome/help/totem/de
+@dirrm share/gnome/help/totem/bg/figures
+@dirrm share/gnome/help/totem/bg
@dirrm share/gnome/help/totem/C/figures
@dirrm share/gnome/help/totem/C
@dirrm share/gnome/help/totem