aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/tunapie
diff options
context:
space:
mode:
authornivit <nivit@FreeBSD.org>2006-12-24 07:28:07 +0800
committernivit <nivit@FreeBSD.org>2006-12-24 07:28:07 +0800
commit555177720b1448ca93c00fe8863b58e513caa633 (patch)
tree57a547e86bba57a51fb4626282122544c0f168d6 /multimedia/tunapie
parent02284a9980b418baeea351bed39659f038cf7d5c (diff)
downloadfreebsd-ports-graphics-555177720b1448ca93c00fe8863b58e513caa633.tar.gz
freebsd-ports-graphics-555177720b1448ca93c00fe8863b58e513caa633.tar.zst
freebsd-ports-graphics-555177720b1448ca93c00fe8863b58e513caa633.zip
- Updated to 1.3.2
Approved by: alexbl (mentor)
Diffstat (limited to 'multimedia/tunapie')
-rw-r--r--multimedia/tunapie/Makefile4
-rw-r--r--multimedia/tunapie/distinfo6
-rw-r--r--multimedia/tunapie/files/patch-install.sh10
-rw-r--r--multimedia/tunapie/files/patch-src-TunerFrame1.py16
-rw-r--r--multimedia/tunapie/pkg-plist2
5 files changed, 25 insertions, 13 deletions
diff --git a/multimedia/tunapie/Makefile b/multimedia/tunapie/Makefile
index 46ff836afc5..2f1e1e3e912 100644
--- a/multimedia/tunapie/Makefile
+++ b/multimedia/tunapie/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= tunapie
-PORTVERSION= 1.3.1.1
+PORTVERSION= 1.3.2
CATEGORIES= multimedia audio
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -44,7 +44,7 @@ post-patch:
-e 's|%%X11BASE%%|${X11BASE}|g' {} ";"
do-install:
- ${MKDIR} ${DATADIR}
+ ${MKDIR} ${DATADIR} ${DATADIR}/pixmaps
${MKDIR} ${DESKTOPDIR}
cd ${WRKSRC} && ./install.sh ${ADULT_TVLIST}
diff --git a/multimedia/tunapie/distinfo b/multimedia/tunapie/distinfo
index 4af0406e2d9..433465b18b9 100644
--- a/multimedia/tunapie/distinfo
+++ b/multimedia/tunapie/distinfo
@@ -1,3 +1,3 @@
-MD5 (tunapie-1.3.1.1.tar.gz) = 46bfef36c6f25246ffaa549a865af3aa
-SHA256 (tunapie-1.3.1.1.tar.gz) = bf036d01411b7ccc698f8effaebb69e171ee3cec8b97072b156aa76f6ede5d7c
-SIZE (tunapie-1.3.1.1.tar.gz) = 35436
+MD5 (tunapie-1.3.2.tar.gz) = 3242913695ca406dc9461f091372837b
+SHA256 (tunapie-1.3.2.tar.gz) = 97468e7be0b84133928a5fb9b3a4d2287c01540682aafc243a910aed68512998
+SIZE (tunapie-1.3.2.tar.gz) = 39407
diff --git a/multimedia/tunapie/files/patch-install.sh b/multimedia/tunapie/files/patch-install.sh
index 4f1ebb00cc9..6ec574d76b4 100644
--- a/multimedia/tunapie/files/patch-install.sh
+++ b/multimedia/tunapie/files/patch-install.sh
@@ -1,10 +1,10 @@
---- install.sh Tue Dec 12 12:51:22 2006
-+++ install.sh.port Fri Dec 15 18:24:54 2006
-@@ -1,11 +1,9 @@
+--- install.sh Thu Dec 21 00:40:35 2006
++++ install.sh.port Fri Dec 22 23:00:51 2006
+@@ -1,12 +1,10 @@
#!/bin/sh
-if [ "$1" = "--adult" ]; then echo '1'>/etc/tunapie.config
-else echo '0'>/etc/tunapie.config
-+if [ "$1" = "--adult" ]; then echo '1'>%%LOCALBASE%%/etc/tunapie.config.default
++if [ "$1" = "--adult" ]; then echo '1'> %%LOCALBASE%%/etc/tunapie.config.default
+else echo '0'>%%LOCALBASE%%/etc/tunapie.config.default
fi
python src/compile
@@ -12,9 +12,11 @@
-rm -rf /usr/local/share/tunapie
-mkdir /usr/local/share/tunapie
-cp src/*.py src/*.pyc /usr/local/share/tunapie
+-cp src/tplogo.xpm /usr/local/share/pixmaps/
-cp tunapie.1 /usr/local/man/man1
-cp tunapie.desktop /usr/local/share/applications
+cp tunapie %%PREFIX%%/bin
+cp src/*.py src/*.pyc %%DATADIR%%
++cp src/tplogo.xpm %%DATADIR%%/pixmaps/
+cp tunapie.1 %%MANPREFIX%%/man/man1
+cp tunapie.desktop %%DESKTOPDIR%%
diff --git a/multimedia/tunapie/files/patch-src-TunerFrame1.py b/multimedia/tunapie/files/patch-src-TunerFrame1.py
index 73755b2148d..4c27e7cbd2c 100644
--- a/multimedia/tunapie/files/patch-src-TunerFrame1.py
+++ b/multimedia/tunapie/files/patch-src-TunerFrame1.py
@@ -1,7 +1,15 @@
-$FreeBSD$
---- src/TunerFrame1.py Sun Jul 2 20:16:55 2006
-+++ src/TunerFrame1.py.port Tue Jul 4 15:07:01 2006
-@@ -422,10 +422,10 @@
+--- src/TunerFrame1.py Thu Dec 21 00:40:08 2006
++++ src/TunerFrame1.py.port Fri Dec 22 23:05:45 2006
+@@ -129,7 +129,7 @@
+ self.SetBackgroundColour(wx.Colour(246, 246, 246))
+ self.SetBackgroundStyle(wx.BG_STYLE_SYSTEM)
+ self.SetThemeEnabled(True)
+- self.SetIcon(wx.Icon('pixmaps/tplogo.xpm',wx.BITMAP_TYPE_XPM))
++ self.SetIcon(wx.Icon('%%DATADIR%%/pixmaps/tplogo.xpm',wx.BITMAP_TYPE_XPM))
+ self.SetFont(wx.Font(10, wx.SWISS, wx.NORMAL, wx.NORMAL, False,u'Sans'))
+ self.SetAutoLayout(True)
+ self.SetMinSize(wx.Size(770, 410))
+@@ -564,10 +564,10 @@
for name in self.favname:
self.favorites.Append(name)
self.name=[]
diff --git a/multimedia/tunapie/pkg-plist b/multimedia/tunapie/pkg-plist
index dfc0736ce39..1d44459ab55 100644
--- a/multimedia/tunapie/pkg-plist
+++ b/multimedia/tunapie/pkg-plist
@@ -17,8 +17,10 @@ etc/tunapie.config.default
%%DATADIR%%/TunerInfoDialog.pyc
%%DATADIR%%/TunerPrefs.py
%%DATADIR%%/TunerPrefs.pyc
+%%DATADIR%%/pixmaps/tplogo.xpm
%%DATADIR%%/tuner.py
%%DATADIR%%/tuner.pyc
%%DESKTOPDIR%%/tunapie.desktop
+@dirrm %%DATADIR%%/pixmaps
@dirrm %%DATADIR%%
@dirrmtry %%DESKTOPDIR%%