aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/xine
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2009-01-06 05:36:39 +0800
committerpav <pav@FreeBSD.org>2009-01-06 05:36:39 +0800
commitce63afce79cdadc19f08fb68107d342b48f952a9 (patch)
treeb94400f72c2b6e4dfb9741e0a6ff3bc33d232358 /multimedia/xine
parent5db9c2715f2cb550af20c58ae212b7179f7759ea (diff)
downloadfreebsd-ports-graphics-ce63afce79cdadc19f08fb68107d342b48f952a9.tar.gz
freebsd-ports-graphics-ce63afce79cdadc19f08fb68107d342b48f952a9.tar.zst
freebsd-ports-graphics-ce63afce79cdadc19f08fb68107d342b48f952a9.zip
- Remove conditional checks for FreeBSD 5.x and older
Diffstat (limited to 'multimedia/xine')
-rw-r--r--multimedia/xine/Makefile21
-rw-r--r--multimedia/xine/files/extra-patch-src:xitk:common.h11
-rw-r--r--multimedia/xine/files/extra-patch-src:xitk:common.h-115
3 files changed, 0 insertions, 47 deletions
diff --git a/multimedia/xine/Makefile b/multimedia/xine/Makefile
index 96fe84e8a0a..8533a02c21e 100644
--- a/multimedia/xine/Makefile
+++ b/multimedia/xine/Makefile
@@ -52,27 +52,6 @@ CODEC_DETECTION_FILE!= ${MAKE} -f ${CODEC_PORT}/Makefile -V CODEC_DETECTION_FILE
.endif
.endif
-.if ${OSVERSION} == 500043
-EXTRA_PATCHES= ${PATCHDIR}/extra-patch-src:xitk:common.h
-.endif
-
-# PRIi64 macro is not defined
-.if ${OSVERSION} < 500040
-EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-src:xitk:common.h-1
-.endif
-
-# mbrtowc() is not implemented
-.if ${OSVERSION} < 500039
-CONFIGURE_ARGS+= --disable-mbs
-# Xft support requires --enable-mbs configure option
-WITHOUT_XFT= yes
-.endif
-
-.if ${OSVERSION} < 502000
-LIB_DEPENDS+= readline.5:${PORTSDIR}/devel/readline
-CONFIGURE_ARGS+= --with-readline=${LOCALBASE}
-.endif
-
.if defined(WITHOUT_NLS)
CONFIGURE_ARGS+=--disable-nls
PLIST_SUB+= NLS="@comment "
diff --git a/multimedia/xine/files/extra-patch-src:xitk:common.h b/multimedia/xine/files/extra-patch-src:xitk:common.h
deleted file mode 100644
index 55a644b31ff..00000000000
--- a/multimedia/xine/files/extra-patch-src:xitk:common.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/xitk/common.h.orig Mon Feb 24 22:39:16 2003
-+++ src/xitk/common.h Mon Feb 24 22:39:46 2003
-@@ -31,6 +31,8 @@
- #include <xine.h>
- #include <xine/xineutils.h>
-
-+#define ushort unsigned short
-+
- #include "Imlib-light/Imlib.h"
-
- #include "xitk.h"
diff --git a/multimedia/xine/files/extra-patch-src:xitk:common.h-1 b/multimedia/xine/files/extra-patch-src:xitk:common.h-1
deleted file mode 100644
index 1b56caf3597..00000000000
--- a/multimedia/xine/files/extra-patch-src:xitk:common.h-1
+++ /dev/null
@@ -1,15 +0,0 @@
---- src/xitk/common.h.orig Fri Apr 16 04:20:51 2004
-+++ src/xitk/common.h Wed May 12 23:17:59 2004
-@@ -114,6 +114,12 @@
- #define PLAYLIST_CONTROL_STOP 0x00000001 /* Don't start next entry in playlist */
- #define PLAYLIST_CONTROL_IGNORE 0x00000002 /* Ignore some playlist adding action */
-
-+#if defined(__alpha__) || defined(__amd64__) || defined(__ia64__) || defined(__sparc64__)
-+#define PRIi64 "li"
-+#else if defined(__i386__) || defined(__powerpc__)
-+#define PRIi64 "lli"
-+#endif
-+
- #define SAFE_FREE(x) do { \
- if((x)) { \
- free((x)); \