aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2009-05-02 05:40:07 +0800
committermiwi <miwi@FreeBSD.org>2009-05-02 05:40:07 +0800
commit308462344eb1629c8491879e3f4a50818b258882 (patch)
tree16387b8d80724d19cd6d2b2bf916fc36e2dc48d9 /multimedia
parente215f6823020ef929eb50aa11c6e9a0399bbee6b (diff)
downloadfreebsd-ports-graphics-308462344eb1629c8491879e3f4a50818b258882.tar.gz
freebsd-ports-graphics-308462344eb1629c8491879e3f4a50818b258882.tar.zst
freebsd-ports-graphics-308462344eb1629c8491879e3f4a50818b258882.zip
- Update to 0.7.3
PR: 134141 Submitted by: Alberto Villa <villa.alberto@gmail.com> (maintainer)
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/kdenlive/Makefile19
-rw-r--r--multimedia/kdenlive/distinfo6
-rw-r--r--multimedia/kdenlive/files/patch-src-CMakeLists.txt24
-rw-r--r--multimedia/kdenlive/pkg-descr10
-rw-r--r--multimedia/kdenlive/pkg-plist62
5 files changed, 105 insertions, 16 deletions
diff --git a/multimedia/kdenlive/Makefile b/multimedia/kdenlive/Makefile
index 9d87855f239..190910316d5 100644
--- a/multimedia/kdenlive/Makefile
+++ b/multimedia/kdenlive/Makefile
@@ -5,16 +5,14 @@
# $FreeBSD$
PORTNAME= kdenlive
-PORTVERSION= 0.7
-PORTREVISION= 2
+PORTVERSION= 0.7.3
CATEGORIES= multimedia kde
MASTER_SITES= SFE
MAINTAINER= villa.alberto@gmail.com
COMMENT= A professional quality non-linear video editing suite for KDE
-LIB_DEPENDS= avformat.1:${PORTSDIR}/multimedia/ffmpeg \
- mlt.1:${PORTSDIR}/multimedia/mlt \
+LIB_DEPENDS= mlt.1:${PORTSDIR}/multimedia/mlt \
mlt++.1:${PORTSDIR}/multimedia/mlt++
USE_GETTEXT= yes
@@ -22,12 +20,17 @@ USE_KDE4= automoc4 kdehier kdelibs kdeprefix sharedmime
USE_QT_VER= 4
QT_COMPONENTS= dbus gui network svg xml \
moc_build qmake_build rcc_build uic_build
+MAKE_JOBS_SAFE= yes
USE_CMAKE= yes
CMAKE_ARGS= -DNO_JOGSHUTTLE:BOOL=On
+USE_LDCONFIG= ${PREFIX}/lib/kde4
PORTDOCS= AUTHORS COPYING INSTALL README
-OPTIONS= LADSPA "Install LADSPA plugins" on
+MAN1= kdenlive.1 kdenlive_render.1
+
+OPTIONS= LADSPA "Install LADSPA plugins" on \
+ SCREENGRAB "Screen capture with recordMyDesktop" on
.include <bsd.port.pre.mk>
@@ -35,13 +38,17 @@ OPTIONS= LADSPA "Install LADSPA plugins" on
RUN_DEPENDS+= swhplugins>=0:${PORTSDIR}/audio/swhplugins
.endif
+.ifdef(WITH_SCREENGRAB)
+RUN_DEPENDS+= recordmydesktop:${PORTSDIR}/multimedia/recordmydesktop
+.endif
+
post-patch:
# prevent updating mime during build
${REINPLACE_CMD} -e '/^update_xdg_mimetypes/d; /SharedMimeInfo/d' \
${PATCH_WRKSRC}/src/mimetypes/CMakeLists.txt
post-install:
- @-update-mime-database ${KDE4_PREFIX}/share/mime
+ @-update-mime-database ${PREFIX}/share/mime
.ifndef(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
.for f in ${PORTDOCS}
diff --git a/multimedia/kdenlive/distinfo b/multimedia/kdenlive/distinfo
index c8d2b67f9fe..6919db69d34 100644
--- a/multimedia/kdenlive/distinfo
+++ b/multimedia/kdenlive/distinfo
@@ -1,3 +1,3 @@
-MD5 (kdenlive-0.7.tar.gz) = dfca2fe1fe72737d7f6af80af9c73788
-SHA256 (kdenlive-0.7.tar.gz) = 3fc59fe0be10585577f9dc08a8f9cc0a653361deaad1edcfaae21c859dd31a7d
-SIZE (kdenlive-0.7.tar.gz) = 523216
+MD5 (kdenlive-0.7.3.tar.gz) = eb527dad425427f22ae191670bcc1f14
+SHA256 (kdenlive-0.7.3.tar.gz) = dc8ef49d1fab211349a086404b499cc6f19ac34ed227ba51b2f685aac01623d5
+SIZE (kdenlive-0.7.3.tar.gz) = 1987698
diff --git a/multimedia/kdenlive/files/patch-src-CMakeLists.txt b/multimedia/kdenlive/files/patch-src-CMakeLists.txt
new file mode 100644
index 00000000000..860d0b391ff
--- /dev/null
+++ b/multimedia/kdenlive/files/patch-src-CMakeLists.txt
@@ -0,0 +1,24 @@
+--- src/CMakeLists.txt.orig 2009-05-01 17:21:12.000000000 +0200
++++ src/CMakeLists.txt 2009-05-01 17:21:48.000000000 +0200
+@@ -2,17 +2,19 @@
+ add_subdirectory( widgets )
+ add_subdirectory( mimetypes )
+
++find_package(Qt4 REQUIRED)
+ find_package(Nepomuk REQUIRED)
+
+ include_directories (
++ ${QT_INCLUDES}
++ ${LIBMLT_INCLUDE_DIR}
++ ${LIBMLTPLUS_INCLUDE_DIR}
+ ${QDBUS_INCLUDE_DIRS}
+ ${CMAKE_SOURCE_DIR}
+ ${CMAKE_BINARY_DIR}
+ ${KDE4_INCLUDES}
+
+ ${CMAKE_SOURCE_DIR}/src/widgets
+- ${LIBMLT_INCLUDE_DIR}
+- ${LIBMLTPLUS_INCLUDE_DIR}
+ ${NEPOMUK_INCLUDES}
+ )
+
diff --git a/multimedia/kdenlive/pkg-descr b/multimedia/kdenlive/pkg-descr
index 8ae4bd13503..ef8e83c3ed9 100644
--- a/multimedia/kdenlive/pkg-descr
+++ b/multimedia/kdenlive/pkg-descr
@@ -1,7 +1,7 @@
-Kdenlive is a non-linear video editor for GNU/Linux and FreeBSD,
-which supports DV, HDV and AVCHD (not complete yet) editing. Kdenlive
-relies on several other open source projects like FFmpeg and the
-MLT video framework. It was designed to answer all needs, from
-basic video editing to semi-professional work.
+Kdenlive is a non-linear video editor for GNU/Linux and FreeBSD, which
+supports DV, AVCHD (experimental support) and HDV editing. Kdenlive relies
+on several other open source projects, such as FFmpeg and the MLT video
+framework. It was designed to answer all needs, from basic video editing to
+semi-professional work.
WWW: http://www.kdenlive.org
diff --git a/multimedia/kdenlive/pkg-plist b/multimedia/kdenlive/pkg-plist
index 0bc45a0a039..343fa98c825 100644
--- a/multimedia/kdenlive/pkg-plist
+++ b/multimedia/kdenlive/pkg-plist
@@ -1,5 +1,6 @@
bin/kdenlive
bin/kdenlive_render
+lib/kde4/libkdenlive_sampleplugin.so
lib/kde4/westleypreview.so
share/applications/kde/kdenlive.desktop
share/apps/kdenlive/banner.png
@@ -8,14 +9,21 @@ share/apps/kdenlive/blacklisted_transitions.txt
share/apps/kdenlive/effects/automask.xml
share/apps/kdenlive/effects/boxblur.xml
share/apps/kdenlive/effects/brightness.xml
+share/apps/kdenlive/effects/channelcopy.xml
share/apps/kdenlive/effects/charcoal.xml
share/apps/kdenlive/effects/chroma.xml
share/apps/kdenlive/effects/chroma_hold.xml
+share/apps/kdenlive/effects/crop.xml
+share/apps/kdenlive/effects/fade_from_black.xml
+share/apps/kdenlive/effects/fade_to_black.xml
share/apps/kdenlive/effects/fadein.xml
share/apps/kdenlive/effects/fadeout.xml
share/apps/kdenlive/effects/freeze.xml
+share/apps/kdenlive/effects/frei0r_balanc0r.xml
+share/apps/kdenlive/effects/frei0r_colordistance.xml
share/apps/kdenlive/effects/frei0r_distort0r.xml
share/apps/kdenlive/effects/frei0r_squareblur.xml
+share/apps/kdenlive/effects/gain.xml
share/apps/kdenlive/effects/gamma.xml
share/apps/kdenlive/effects/greyscale.xml
share/apps/kdenlive/effects/invert.xml
@@ -33,12 +41,18 @@ share/apps/kdenlive/effects/mirror.xml
share/apps/kdenlive/effects/mute.xml
share/apps/kdenlive/effects/normalise.xml
share/apps/kdenlive/effects/obscure.xml
+share/apps/kdenlive/effects/pan_zoom.xml
share/apps/kdenlive/effects/rotation.xml
share/apps/kdenlive/effects/sepia.xml
+share/apps/kdenlive/effects/sox_band.xml
+share/apps/kdenlive/effects/sox_bass.xml
share/apps/kdenlive/effects/sox_echo.xml
share/apps/kdenlive/effects/sox_flanger.xml
+share/apps/kdenlive/effects/sox_gain.xml
+share/apps/kdenlive/effects/sox_phaser.xml
share/apps/kdenlive/effects/sox_pitch.xml
share/apps/kdenlive/effects/sox_reverb.xml
+share/apps/kdenlive/effects/sox_stretch.xml
share/apps/kdenlive/effects/sox_vibro.xml
share/apps/kdenlive/effects/threshold.xml
share/apps/kdenlive/effects/volume.xml
@@ -53,13 +67,20 @@ share/apps/kdenlive/icons/hicolor/16x16/actions/kdenlive-align-vert.png
share/apps/kdenlive/icons/hicolor/16x16/actions/kdenlive-hide-audio.png
share/apps/kdenlive/icons/hicolor/16x16/actions/kdenlive-hide-video.png
share/apps/kdenlive/icons/hicolor/16x16/actions/kdenlive-insert-rect.png
+share/apps/kdenlive/icons/hicolor/16x16/actions/kdenlive-lock.png
+share/apps/kdenlive/icons/hicolor/16x16/actions/kdenlive-select-tool.png
share/apps/kdenlive/icons/hicolor/16x16/actions/kdenlive-show-audio.png
share/apps/kdenlive/icons/hicolor/16x16/actions/kdenlive-show-audiothumb.png
share/apps/kdenlive/icons/hicolor/16x16/actions/kdenlive-show-markers.png
share/apps/kdenlive/icons/hicolor/16x16/actions/kdenlive-show-video.png
share/apps/kdenlive/icons/hicolor/16x16/actions/kdenlive-show-videothumb.png
share/apps/kdenlive/icons/hicolor/16x16/actions/kdenlive-snap.png
+share/apps/kdenlive/icons/hicolor/16x16/actions/kdenlive-spacer-tool.png
+share/apps/kdenlive/icons/hicolor/16x16/actions/kdenlive-unlock.png
+share/apps/kdenlive/icons/hicolor/16x16/actions/kdenlive-zone-end.png
+share/apps/kdenlive/icons/hicolor/16x16/actions/kdenlive-zone-start.png
share/apps/kdenlive/icons/hicolor/scalable/actions/kdenlive-select-tool.svgz
+share/apps/kdenlive/icons/hicolor/scalable/actions/kdenlive-spacer-tool.svgz
share/apps/kdenlive/icons/hicolor/scalable/actions/kdenlive-zone-end.svgz
share/apps/kdenlive/icons/hicolor/scalable/actions/kdenlive-zone-start.svgz
share/apps/kdenlive/icons/oxygen/16x16/actions/kdenlive-add-clip.png
@@ -71,17 +92,42 @@ share/apps/kdenlive/icons/oxygen/16x16/actions/kdenlive-align-vert.png
share/apps/kdenlive/icons/oxygen/16x16/actions/kdenlive-hide-audio.png
share/apps/kdenlive/icons/oxygen/16x16/actions/kdenlive-hide-video.png
share/apps/kdenlive/icons/oxygen/16x16/actions/kdenlive-insert-rect.png
+share/apps/kdenlive/icons/oxygen/16x16/actions/kdenlive-lock.png
+share/apps/kdenlive/icons/oxygen/16x16/actions/kdenlive-select-tool.png
share/apps/kdenlive/icons/oxygen/16x16/actions/kdenlive-show-audio.png
share/apps/kdenlive/icons/oxygen/16x16/actions/kdenlive-show-audiothumb.png
share/apps/kdenlive/icons/oxygen/16x16/actions/kdenlive-show-markers.png
share/apps/kdenlive/icons/oxygen/16x16/actions/kdenlive-show-video.png
share/apps/kdenlive/icons/oxygen/16x16/actions/kdenlive-show-videothumb.png
share/apps/kdenlive/icons/oxygen/16x16/actions/kdenlive-snap.png
+share/apps/kdenlive/icons/oxygen/16x16/actions/kdenlive-spacer-tool.png
+share/apps/kdenlive/icons/oxygen/16x16/actions/kdenlive-unlock.png
+share/apps/kdenlive/icons/oxygen/16x16/actions/kdenlive-zone-end.png
+share/apps/kdenlive/icons/oxygen/16x16/actions/kdenlive-zone-start.png
share/apps/kdenlive/icons/oxygen/scalable/actions/kdenlive-select-tool.svgz
+share/apps/kdenlive/icons/oxygen/scalable/actions/kdenlive-spacer-tool.svgz
share/apps/kdenlive/icons/oxygen/scalable/actions/kdenlive-zone-end.svgz
share/apps/kdenlive/icons/oxygen/scalable/actions/kdenlive-zone-start.svgz
share/apps/kdenlive/kdenlive.notifyrc
share/apps/kdenlive/kdenliveui.rc
+share/apps/kdenlive/lumas/bi-linear_x.pgm
+share/apps/kdenlive/lumas/bi-linear_y.pgm
+share/apps/kdenlive/lumas/burst.pgm
+share/apps/kdenlive/lumas/checkerboard_small.pgm
+share/apps/kdenlive/lumas/clock.pgm
+share/apps/kdenlive/lumas/cloud.pgm
+share/apps/kdenlive/lumas/curtain.pgm
+share/apps/kdenlive/lumas/horizontal_blinds.pgm
+share/apps/kdenlive/lumas/linear_x.pgm
+share/apps/kdenlive/lumas/linear_y.pgm
+share/apps/kdenlive/lumas/radial-bars.pgm
+share/apps/kdenlive/lumas/radial.pgm
+share/apps/kdenlive/lumas/spiral.pgm
+share/apps/kdenlive/lumas/spiral2.pgm
+share/apps/kdenlive/lumas/square.pgm
+share/apps/kdenlive/lumas/square2-bars.pgm
+share/apps/kdenlive/lumas/square2.pgm
+share/apps/kdenlive/lumas/symmetric_clock.pgm
share/apps/kdenlive/metadata.properties
share/apps/kdenlive/timeline_athumbs.png
share/apps/kdenlive/timeline_avthumbs.png
@@ -89,6 +135,9 @@ share/apps/kdenlive/timeline_nothumbs.png
share/apps/kdenlive/timeline_vthumbs.png
share/apps/kdenlive/transition.png
share/config.kcfg/kdenlivesettings.kcfg
+share/config/kdenlive.knsrc
+share/config/kdenlive_mltprofiles.knsrc
+share/config/kdenlive_render.knsrc
share/icons/hicolor/32x32/apps/kdenlive.png
share/icons/hicolor/48x48/apps/kdenlive.png
share/icons/hicolor/64x64/apps/kdenlive.png
@@ -103,14 +152,21 @@ share/locale/cs/LC_MESSAGES/kdenlive.mo
share/locale/da/LC_MESSAGES/kdenlive.mo
share/locale/de/LC_MESSAGES/kdenlive.mo
share/locale/es/LC_MESSAGES/kdenlive.mo
+share/locale/fi/LC_MESSAGES/kdenlive.mo
share/locale/fr/LC_MESSAGES/kdenlive.mo
+share/locale/he/LC_MESSAGES/kdenlive.mo
+share/locale/hr/LC_MESSAGES/kdenlive.mo
+share/locale/hu/LC_MESSAGES/kdenlive.mo
share/locale/it/LC_MESSAGES/kdenlive.mo
share/locale/nl/LC_MESSAGES/kdenlive.mo
+share/locale/pt_BR/LC_MESSAGES/kdenlive.mo
+share/locale/ru/LC_MESSAGES/kdenlive.mo
+share/locale/sl/LC_MESSAGES/kdenlive.mo
share/locale/zh/LC_MESSAGES/kdenlive.mo
-share/mime/application/x-kdenlive.xml
share/mime/packages/kdenlive.xml
share/mime/packages/westley.xml
-share/mime/video/mlt-playlist.xml
+@dirrmtry share/mime/packages
+@dirrmtry share/mime
@dirrmtry share/kde4/services
@dirrmtry share/kde4
@dirrmtry share/icons/oxygen/scalable/mimetypes
@@ -131,6 +187,8 @@ share/mime/video/mlt-playlist.xml
@dirrmtry share/icons/hicolor
@dirrmtry share/icons
@dirrmtry share/config.kcfg
+@dirrmtry share/config
+@dirrm share/apps/kdenlive/lumas
@dirrm share/apps/kdenlive/icons/oxygen/scalable/actions
@dirrm share/apps/kdenlive/icons/oxygen/scalable
@dirrm share/apps/kdenlive/icons/oxygen/16x16/actions