aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authornobutaka <nobutaka@FreeBSD.org>2004-02-22 22:12:40 +0800
committernobutaka <nobutaka@FreeBSD.org>2004-02-22 22:12:40 +0800
commit33b5c86014d5793fc591b43297ae7bae46f115c0 (patch)
treeed28fd185dcd0fd497d0276f5dfb2c49e7f431d1 /multimedia
parent26fc35d93b1450afcf83b9a5a3d48d37e3541a09 (diff)
downloadfreebsd-ports-graphics-33b5c86014d5793fc591b43297ae7bae46f115c0.tar.gz
freebsd-ports-graphics-33b5c86014d5793fc591b43297ae7bae46f115c0.tar.zst
freebsd-ports-graphics-33b5c86014d5793fc591b43297ae7bae46f115c0.zip
1. Fix build error.
2. SIZEify. PR: ports/63168 [1] Submitted by: Martin Kaeske <Martin.Kaeske@Stud.TU-Ilmenau.DE> [1]
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/xine/distinfo1
-rw-r--r--multimedia/xine/files/patch-src:xitk:download.c17
2 files changed, 18 insertions, 0 deletions
diff --git a/multimedia/xine/distinfo b/multimedia/xine/distinfo
index 0834359f18b..8a051a11642 100644
--- a/multimedia/xine/distinfo
+++ b/multimedia/xine/distinfo
@@ -1 +1,2 @@
MD5 (xine-ui-0.9.23.tar.gz) = 526c96a7c08d2913e6f328e347fe615f
+SIZE (xine-ui-0.9.23.tar.gz) = 2798551
diff --git a/multimedia/xine/files/patch-src:xitk:download.c b/multimedia/xine/files/patch-src:xitk:download.c
new file mode 100644
index 00000000000..7477eaa55e1
--- /dev/null
+++ b/multimedia/xine/files/patch-src:xitk:download.c
@@ -0,0 +1,17 @@
+--- src/xitk/download.c.orig Sat Feb 21 13:38:19 2004
++++ src/xitk/download.c Sat Feb 21 13:39:43 2004
+@@ -39,6 +39,14 @@
+ extern gGui_t *gGui;
+
+ #ifdef HAVE_CURL
++
++#ifndef TRUE
++#define TRUE 1
++#endif
++#ifndef FALSE
++#define FALSE 0
++#endif
++
+ static int progress_callback(void *userdata,
+ double dltotal, double dlnow, double ultotal, double ulnow) {
+ download_t *download = (download_t *) userdata;