aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authorriggs <riggs@FreeBSD.org>2014-11-17 01:20:32 +0800
committerriggs <riggs@FreeBSD.org>2014-11-17 01:20:32 +0800
commit5f9ce3cec1dd80e7192ba734db76f96c0ce4425c (patch)
tree867fe3ce2acf493b73bc50a046b2c8dccd986c4a /multimedia
parent80ba62c2a8bcba47c3c550e4993bd0b95ef814f5 (diff)
downloadfreebsd-ports-graphics-5f9ce3cec1dd80e7192ba734db76f96c0ce4425c.tar.gz
freebsd-ports-graphics-5f9ce3cec1dd80e7192ba734db76f96c0ce4425c.tar.zst
freebsd-ports-graphics-5f9ce3cec1dd80e7192ba734db76f96c0ce4425c.zip
Correct iconv handling
Bump PORTREVISION While on it: - Remove @dirrm(try) from pkg-plists PR: 195065 Submitted by: yuri@rawbw.com Reviewed by: riggs
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/mencoder/Makefile5
-rw-r--r--multimedia/mencoder/pkg-plist2
-rw-r--r--multimedia/mplayer/Makefile5
-rw-r--r--multimedia/mplayer/pkg-plist3
4 files changed, 6 insertions, 9 deletions
diff --git a/multimedia/mencoder/Makefile b/multimedia/mencoder/Makefile
index fbf0f40c94b..31a14d0c780 100644
--- a/multimedia/mencoder/Makefile
+++ b/multimedia/mencoder/Makefile
@@ -3,7 +3,7 @@
PORTNAME= mencoder
PORTVERSION= ${MPLAYER_PORT_VERSION}
-PORTREVISION= 1
+PORTREVISION= 2
COMMENT= Convenient video file and movie encoder
@@ -41,7 +41,7 @@ TOOLFILES= aconvert.sh binary_codecs.sh calcbpp.pl \
subedit.pl subsearch.sh vobshift.py \
w32codec_dl.pl wma2ogg.pl
-USES+= alias shebangfix
+USES+= alias iconv shebangfix
SHEBANG_FILES= TOOLS/calcbpp.pl TOOLS/checktree.sh TOOLS/countquant.pl \
TOOLS/divx2svcd.sh TOOLS/dvd2divxscript.pl TOOLS/mencvcd.sh \
TOOLS/mphelp_check.py TOOLS/plotpsnr.pl TOOLS/psnr-video.sh \
@@ -95,6 +95,7 @@ post-patch:
-e 's|%%LOCALBASE%%|${LOCALBASE}|' \
-e 's|-lbz2|/usr/lib/libbz2.so|' \
-e 's|-lncurses|/usr/lib/libncurses.so|' \
+ -e 's|-liconv|${ICONV_LIB}|' \
${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
@${FIND} -E ${WRKSRC} -type f \
-iregex ".*(configure|.sh|Makefile)" -print0 | \
diff --git a/multimedia/mencoder/pkg-plist b/multimedia/mencoder/pkg-plist
index aaa8adb5b24..464bfbccf83 100644
--- a/multimedia/mencoder/pkg-plist
+++ b/multimedia/mencoder/pkg-plist
@@ -23,5 +23,3 @@ man/man1/mencoder.1.gz
%%DATADIR%%/tools/vobshift.py
%%DATADIR%%/tools/w32codec_dl.pl
%%DATADIR%%/tools/wma2ogg.pl
-@dirrm %%DATADIR%%/tools
-@dirrmtry %%DATADIR%%
diff --git a/multimedia/mplayer/Makefile b/multimedia/mplayer/Makefile
index b8157288a4e..31888c03f37 100644
--- a/multimedia/mplayer/Makefile
+++ b/multimedia/mplayer/Makefile
@@ -3,7 +3,7 @@
PORTNAME= mplayer
PORTVERSION= ${MPLAYER_PORT_VERSION}
-PORTREVISION= 3
+PORTREVISION= 4
COMMENT= High performance media player supporting many formats
@@ -42,7 +42,7 @@ SUB_FILES= pkg-message
CONFLICTS= mplayer2-2.*
CONFFILES= example.conf input.conf menu.conf dvb-menu.conf
-USES+= pkgconfig
+USES+= iconv pkgconfig
.include "${.CURDIR}/Makefile.optvars"
.include <bsd.port.pre.mk>
@@ -142,6 +142,7 @@ post-patch:
-e 's|%%LOCALBASE%%|${LOCALBASE}|' \
-e 's|-lbz2|/usr/lib/libbz2.so|' \
-e 's|-lncurses|/usr/lib/libncurses.so|' \
+ -e 's|-liconv|${ICONV_LIB}|' \
${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
@${FIND} -E ${WRKSRC} -type f \
-iregex ".*(configure|.sh|Makefile)" -print0 | \
diff --git a/multimedia/mplayer/pkg-plist b/multimedia/mplayer/pkg-plist
index 5476af73780..bc6c353f282 100644
--- a/multimedia/mplayer/pkg-plist
+++ b/multimedia/mplayer/pkg-plist
@@ -7,6 +7,3 @@ man/man1/mplayer.1.gz
%%DATADIR%%/examples/etc/input.conf
%%DATADIR%%/examples/etc/menu.conf
%%DATADIR%%/examples/etc/dvb-menu.conf
-@dirrm %%DATADIR%%/examples/etc
-@dirrm %%DATADIR%%/examples
-@dirrmtry %%DATADIR%%