aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authorosa <osa@FreeBSD.org>2005-12-29 16:26:54 +0800
committerosa <osa@FreeBSD.org>2005-12-29 16:26:54 +0800
commit7711b3b5bded1c68eca2fa219e9ef71dfb8f4301 (patch)
tree7517548bdfd4968172d3fe7aa20840611333907c /multimedia
parent1f478b0f52ef746567bcd3587f8828b89eeb5519 (diff)
downloadfreebsd-ports-graphics-7711b3b5bded1c68eca2fa219e9ef71dfb8f4301.tar.gz
freebsd-ports-graphics-7711b3b5bded1c68eca2fa219e9ef71dfb8f4301.tar.zst
freebsd-ports-graphics-7711b3b5bded1c68eca2fa219e9ef71dfb8f4301.zip
Add new port: p5-Subtitles.
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/Makefile1
-rw-r--r--multimedia/p5-Subtitles/Makefile37
-rw-r--r--multimedia/p5-Subtitles/distinfo3
-rw-r--r--multimedia/p5-Subtitles/pkg-descr11
-rw-r--r--multimedia/p5-Subtitles/pkg-plist5
5 files changed, 57 insertions, 0 deletions
diff --git a/multimedia/Makefile b/multimedia/Makefile
index 4865654523e..eabcf7afcd9 100644
--- a/multimedia/Makefile
+++ b/multimedia/Makefile
@@ -143,6 +143,7 @@
SUBDIR += p5-MP4-Info
SUBDIR += p5-GStreamer
SUBDIR += p5-RIFF-Info
+ SUBDIR += p5-Subtitles
SUBDIR += p5-Video-Info
SUBDIR += p5-Video-OpenQuicktime
SUBDIR += pitivi
diff --git a/multimedia/p5-Subtitles/Makefile b/multimedia/p5-Subtitles/Makefile
new file mode 100644
index 00000000000..8077cc5bd2d
--- /dev/null
+++ b/multimedia/p5-Subtitles/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: p5-Subtitles
+# Date created: 2005-12-28
+# Whom: osa
+#
+# $FreeBSD$
+#
+
+PORTNAME= Subtitles
+PORTVERSION= 0.08
+CATEGORIES= multimedia perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Prima/KARASIK
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= osa@FreeBSD.org
+COMMENT= A Perl5 backend for fix subtitles timing
+
+USE_REINPLACE= yes
+PERL_CONFIGURE= yes
+
+MAN1= subs.1
+MAN3= Subtitles.3
+
+.if defined(WITH_SUBTITLES_SUBPLAY)
+RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Prima.pm:${PORTSDIR}/x11-toolkits/p5-Prima \
+ ${SITE_PERL}/${PERL_ARCH}/Time/HiRes.pm:${PORTSDIR}/devel/p5-Time-HiRes
+
+PLIST_SUB+= SUBPLAY=""
+MAN1+= subplay.1
+
+post-patch:
+ @${REINPLACE_CMD} -e "s|\('subs'\), 'subplay'|\1|" ${WRKSRC}/Makefile.PL
+.else
+PLIST_SUB+= SUBPLAY="@comment "
+.endif
+
+.include <bsd.port.mk>
diff --git a/multimedia/p5-Subtitles/distinfo b/multimedia/p5-Subtitles/distinfo
new file mode 100644
index 00000000000..0aa98572620
--- /dev/null
+++ b/multimedia/p5-Subtitles/distinfo
@@ -0,0 +1,3 @@
+MD5 (Subtitles-0.08.tar.gz) = 8d444216d0a03765ddf0bd965c9e200a
+SHA256 (Subtitles-0.08.tar.gz) = 66a1f0145d3e347bea0e7988255fb7119223238d687b3dec03437301192ccfdd
+SIZE (Subtitles-0.08.tar.gz) = 15538
diff --git a/multimedia/p5-Subtitles/pkg-descr b/multimedia/p5-Subtitles/pkg-descr
new file mode 100644
index 00000000000..17fc806dd57
--- /dev/null
+++ b/multimedia/p5-Subtitles/pkg-descr
@@ -0,0 +1,11 @@
+Movie files can be viewed with subtitles, which are currently
+very popular as text files. Subtitles provides means for
+simple loading, re-timing, and storing these subtitle files.
+A command-line tool subs for the same purpose and using Subtitles
+interface is included in the distribution.
+
+The module supports srt, sub, smi subtitle formats.
+
+Time values are floats, in seconds with millisecond precision.
+
+WWW: http://search.cpan.org/~karasik/
diff --git a/multimedia/p5-Subtitles/pkg-plist b/multimedia/p5-Subtitles/pkg-plist
new file mode 100644
index 00000000000..10a4c16f70f
--- /dev/null
+++ b/multimedia/p5-Subtitles/pkg-plist
@@ -0,0 +1,5 @@
+bin/subs
+%%SUBPLAY%%bin/subplay
+%%SITE_PERL%%/Subtitles.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Subtitles/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Subtitles