aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authorsem <sem@FreeBSD.org>2006-04-29 21:47:23 +0800
committersem <sem@FreeBSD.org>2006-04-29 21:47:23 +0800
commit8123e4b001d3d5c14d8d70bc4a0d1e41435f178a (patch)
tree48c82ab4d22914dd29d5ceee15467d7252c9edb1 /multimedia
parent7fa6f2538592dbb7de77b7ec21bfd02ec257f848 (diff)
downloadfreebsd-ports-graphics-8123e4b001d3d5c14d8d70bc4a0d1e41435f178a.tar.gz
freebsd-ports-graphics-8123e4b001d3d5c14d8d70bc4a0d1e41435f178a.tar.zst
freebsd-ports-graphics-8123e4b001d3d5c14d8d70bc4a0d1e41435f178a.zip
This port provides a FreeBSD kernel module that
video4linux enabled and raw yuv420p applications can use to access several USB based webcams. WWW: http://www.saillard.org/linux/pwc/ PR: ports/93464 Submitted by: Raaf <raaf@luna.afraid.org>
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/Makefile1
-rw-r--r--multimedia/pwcbsd/Makefile65
-rw-r--r--multimedia/pwcbsd/distinfo3
-rw-r--r--multimedia/pwcbsd/pkg-descr5
-rw-r--r--multimedia/pwcbsd/pkg-message17
-rw-r--r--multimedia/pwcbsd/pkg-plist7
6 files changed, 98 insertions, 0 deletions
diff --git a/multimedia/Makefile b/multimedia/Makefile
index 9bf25741747..b8b9c6bb502 100644
--- a/multimedia/Makefile
+++ b/multimedia/Makefile
@@ -152,6 +152,7 @@
SUBDIR += ppm2fli
SUBDIR += projectx
SUBDIR += pvr250
+ SUBDIR += pwcbsd
SUBDIR += py-gstreamer
SUBDIR += qdvdauthor
SUBDIR += quodlibet
diff --git a/multimedia/pwcbsd/Makefile b/multimedia/pwcbsd/Makefile
new file mode 100644
index 00000000000..0e2a71d7805
--- /dev/null
+++ b/multimedia/pwcbsd/Makefile
@@ -0,0 +1,65 @@
+# New ports collection makefile for: pwcbsd
+# Date created: 17 Feb 2006
+# Whom: Raaf <freebsd@luna.afraid.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pwcbsd
+PORTVERSION= 1.0
+CATEGORIES= multimedia sysutils
+MASTER_SITES= http://raaf.atspace.org/
+
+MAINTAINER= freebsd@luna.afraid.org
+COMMENT= The Linux pwc webcam driver ported to FreeBSD
+
+MAN4= pwc.4
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+NO_PACKAGE= should be recompiled for a particular FreeBSD kernel
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 504000
+IGNORE= requires FreeBSD 5.4 or superior
+.endif
+
+.if !exists(/usr/src/sys/Makefile)
+IGNORE= requires kernel source files
+.endif
+
+.if !defined(WITHOUT_PROGRAMS)
+ALL_TARGET= all pwcview
+PROGRAMS= pwcview
+MAN1= pwcview.1
+USE_SDL= sdl
+PLIST_SUB+= PROGRAMS=""
+.else
+PLIST_SUB+= PROGRAMS="@comment "
+.endif
+
+pre-everything::
+.if !defined(WITHOUT_PROGRAMS)
+ @${ECHO_MSG} "=================================================="
+ @${ECHO_MSG} "You may specify the following on the command line:"
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} "WITHOUT_PROGRAMS=yes to only build the driver "
+ @${ECHO_MSG} "=================================================="
+.endif
+
+post-patch:
+.if !defined(WITHOUT_PROGRAMS)
+ @${REINPLACE_CMD} -e 's|sdl11-config|${SDL_CONFIG}|g' ${WRKSRC}/Makefile
+.endif
+
+post-install:
+ ${MKDIR} ${PREFIX}/include/linux
+ ${INSTALL_DATA} ${WRKSRC}/videodev.h ${PREFIX}/include/linux
+ ${INSTALL_MAN} ${MAN4:S|^|${WRKSRC}/|} ${PREFIX}/man/man4
+.if !defined(WITHOUT_PROGRAMS)
+ ${INSTALL_PROGRAM} ${PROGRAMS:S|^|${WRKSRC}/|} ${PREFIX}/bin
+ ${INSTALL_MAN} ${MAN1:S|^|${WRKSRC}/|} ${PREFIX}/man/man1
+.endif
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>
diff --git a/multimedia/pwcbsd/distinfo b/multimedia/pwcbsd/distinfo
new file mode 100644
index 00000000000..a3fcd640e3b
--- /dev/null
+++ b/multimedia/pwcbsd/distinfo
@@ -0,0 +1,3 @@
+MD5 (pwcbsd-1.0.tar.gz) = bcc872b02c44d9b902ce63fb92567ff1
+SHA256 (pwcbsd-1.0.tar.gz) = 4b1b42d0fca32247d1fa449084619cd44f0a76f9a9e265a65d7fc44a91bb8c21
+SIZE (pwcbsd-1.0.tar.gz) = 60920
diff --git a/multimedia/pwcbsd/pkg-descr b/multimedia/pwcbsd/pkg-descr
new file mode 100644
index 00000000000..37628a85bb4
--- /dev/null
+++ b/multimedia/pwcbsd/pkg-descr
@@ -0,0 +1,5 @@
+This port provides a FreeBSD kernel module that
+video4linux enabled and raw yuv420p applications
+can use to access several USB based webcams.
+
+WWW: http://www.saillard.org/linux/pwc/
diff --git a/multimedia/pwcbsd/pkg-message b/multimedia/pwcbsd/pkg-message
new file mode 100644
index 00000000000..f3a107d85f9
--- /dev/null
+++ b/multimedia/pwcbsd/pkg-message
@@ -0,0 +1,17 @@
+===============================================================================
+
+This port has installed the pwc kernel module.
+
+To load the kernel module immediately, type the following command:
+
+ kldload pwc
+
+If your webcam was already plugged in before the kernel module
+was loaded you may have to unplug it first.
+
+To load the kernel module at boot, add the following line to
+/boot/loader.conf:
+
+ pwc_load="YES"
+
+===============================================================================
diff --git a/multimedia/pwcbsd/pkg-plist b/multimedia/pwcbsd/pkg-plist
new file mode 100644
index 00000000000..08ada8f581d
--- /dev/null
+++ b/multimedia/pwcbsd/pkg-plist
@@ -0,0 +1,7 @@
+%%PROGRAMS%%bin/pwcview
+include/linux/videodev.h
+@dirrmtry include/linux
+@cwd /boot/modules
+pwc.ko
+@exec kldxref %D
+@unexec kldxref %D