aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authorlofi <lofi@FreeBSD.org>2006-12-20 03:40:10 +0800
committerlofi <lofi@FreeBSD.org>2006-12-20 03:40:10 +0800
commit9a3de3037e8bc0af05129c5f6276e12f8c51c53a (patch)
tree660dfd4d1c5badc8e499a7b594f5f595af2647f2 /multimedia
parent30ab8aed54555e846dedc81f41aaeae4905f2871 (diff)
downloadfreebsd-ports-graphics-9a3de3037e8bc0af05129c5f6276e12f8c51c53a.tar.gz
freebsd-ports-graphics-9a3de3037e8bc0af05129c5f6276e12f8c51c53a.tar.zst
freebsd-ports-graphics-9a3de3037e8bc0af05129c5f6276e12f8c51c53a.zip
Those who would give up essential linkability to purchase a little plat-
form specific optimization, ... (Disable asm code, thus make compilable with gcc 2.95 on 4.x so C++ programs on 4.x can link to the shared library).
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/libtheora/Makefile11
1 files changed, 8 insertions, 3 deletions
diff --git a/multimedia/libtheora/Makefile b/multimedia/libtheora/Makefile
index aa4e7340870..4a0ce896b0e 100644
--- a/multimedia/libtheora/Makefile
+++ b/multimedia/libtheora/Makefile
@@ -17,18 +17,23 @@ COMMENT= Theora video codec for the Ogg multimedia streaming system
LIB_DEPENDS= vorbis.3:${PORTSDIR}/audio/libvorbis
USE_BZIP2= yes
-USE_GCC= 3.4+
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include " \
LDFLAGS="-L${LOCALBASE}/lib" \
LIBS="${PTHEAD_LIBS}"
-CONFIGURE_ARGS= --disable-sdltest \
+CONFIGURE_ARGS+=--disable-sdltest \
--enable-shared
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500035
+CONFIGURE_ARGS+=--disable-asm
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|-pthread|${PTHREAD_LIBS}|g' \
${WRKSRC}/examples/Makefile.in
@${REINPLACE_CMD} -e 's|doc||g' ${WRKSRC}/Makefile.in
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>