aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authorlawrance <lawrance@FreeBSD.org>2005-12-16 18:39:07 +0800
committerlawrance <lawrance@FreeBSD.org>2005-12-16 18:39:07 +0800
commitab4c7e1a07eaa1c7862eae6b9f080795b60d85ef (patch)
treee998000b018d6deeaea63018b40807998abeec98 /multimedia
parent869e1f3d6f389c1fd46e4e6efb241902a6af3b00 (diff)
downloadfreebsd-ports-graphics-ab4c7e1a07eaa1c7862eae6b9f080795b60d85ef.tar.gz
freebsd-ports-graphics-ab4c7e1a07eaa1c7862eae6b9f080795b60d85ef.tar.zst
freebsd-ports-graphics-ab4c7e1a07eaa1c7862eae6b9f080795b60d85ef.zip
Use BT848SFMT ioctl instead of METEORSFMT (which is incorrect). Allows
setting norm=SECAM which previously did not work. Bump PORTREVISION. PR: ports/90001 Submitted by: Vladimir Kushnir <vkushnir@i.kiev.ua> Approved by: Thomas E. Zander <riggs@rrr.de> (maintainer)
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/mplayer/Makefile2
-rw-r--r--multimedia/mplayer/files/patch-libmpdemux_tvi_bsdbt848.c74
2 files changed, 75 insertions, 1 deletions
diff --git a/multimedia/mplayer/Makefile b/multimedia/mplayer/Makefile
index 932f25b7623..63daa9d91a3 100644
--- a/multimedia/mplayer/Makefile
+++ b/multimedia/mplayer/Makefile
@@ -270,7 +270,7 @@
PORTNAME= mplayer
PORTVERSION= 0.99.7
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= multimedia audio ipv6
MASTER_SITES= http://www1.mplayerhq.hu/MPlayer/releases/ \
http://www2.mplayerhq.hu/MPlayer/releases/ \
diff --git a/multimedia/mplayer/files/patch-libmpdemux_tvi_bsdbt848.c b/multimedia/mplayer/files/patch-libmpdemux_tvi_bsdbt848.c
new file mode 100644
index 00000000000..cf4cd1e08bd
--- /dev/null
+++ b/multimedia/mplayer/files/patch-libmpdemux_tvi_bsdbt848.c
@@ -0,0 +1,74 @@
+--- libmpdemux/tvi_bsdbt848.c.orig Tue Dec 28 04:30:14 2004
++++ libmpdemux/tvi_bsdbt848.c Fri Dec 16 20:42:14 2005
+@@ -296,11 +296,11 @@
+ int req_mode = (int)*(void **)arg;
+ u_short tmp_fps;
+
+- priv->iformat = METEOR_FMT_AUTOMODE;
++ priv->iformat = BT848_IFORM_F_AUTO;
+
+ if(req_mode == TV_NORM_PAL)
+ {
+- priv->iformat = METEOR_FMT_PAL;
++ priv->iformat = BT848_IFORM_F_PALBDGHI;
+ priv->maxheight = PAL_HEIGHT;
+ priv->maxwidth = PAL_WIDTH;
+ priv->maxfps = PAL_FPS;
+@@ -321,7 +321,7 @@
+
+ if(req_mode == TV_NORM_NTSC)
+ {
+- priv->iformat = METEOR_FMT_NTSC;
++ priv->iformat = BT848_IFORM_F_NTSCM;
+ priv->maxheight = NTSC_HEIGHT;
+ priv->maxwidth = NTSC_WIDTH;
+ priv->maxfps = NTSC_FPS;
+@@ -345,9 +345,28 @@
+ }
+ }
+
+- if(req_mode == TV_NORM_SECAM) priv->iformat = METEOR_FMT_SECAM;
++ if(req_mode == TV_NORM_SECAM)
++ {
++ priv->iformat = BT848_IFORM_F_SECAM;
++ priv->maxheight = PAL_HEIGHT;
++ priv->maxwidth = PAL_WIDTH;
++ priv->maxfps = PAL_FPS;
++ priv->fps = PAL_FPS;
++
++ if(priv->fps > priv->maxfps) priv->fps = priv->maxfps;
++
++ if(priv->geom.rows > priv->maxheight)
++ {
++ priv->geom.rows = priv->maxheight;
++ }
++
++ if(priv->geom.columns > priv->maxwidth)
++ {
++ priv->geom.columns = priv->maxwidth;
++ }
++ }
+
+- if(ioctl(priv->btfd, METEORSFMT, &priv->iformat) < 0)
++ if(ioctl(priv->btfd, BT848SFMT, &priv->iformat) < 0)
+ {
+ perror("format:ioctl");
+ return(TVI_CONTROL_FALSE);
+@@ -478,7 +497,7 @@
+ priv->videoready = TRUE;
+ priv->btdev = strdup("/dev/bktr0");
+ priv->immediatemode = FALSE;
+-priv->iformat = METEOR_FMT_PAL;
++priv->iformat = BT848_IFORM_F_PALBDGHI;
+ priv->maxheight = PAL_HEIGHT;
+ priv->maxwidth = PAL_WIDTH;
+ priv->maxfps = PAL_FPS;
+@@ -503,7 +522,7 @@
+ }
+
+ if(priv->videoready == TRUE &&
+- ioctl(priv->btfd, METEORSFMT, &priv->iformat) < 0)
++ ioctl(priv->btfd, BT848SFMT, &priv->iformat) < 0)
+ {
+ perror("FMT:ioctl");
+ }