aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2011-11-27 17:42:49 +0800
committermiwi <miwi@FreeBSD.org>2011-11-27 17:42:49 +0800
commitd2b646d5320eeeb8b0c9c7369355df6553d1e3dc (patch)
treedd69e743ec4dcde2aef71c987a5871ebd75ba9c1 /multimedia
parent92672aac7c765a3820dcf712ffbb38bc5beaa23d (diff)
downloadfreebsd-ports-graphics-d2b646d5320eeeb8b0c9c7369355df6553d1e3dc.tar.gz
freebsd-ports-graphics-d2b646d5320eeeb8b0c9c7369355df6553d1e3dc.tar.zst
freebsd-ports-graphics-d2b646d5320eeeb8b0c9c7369355df6553d1e3dc.zip
- Fix MASTER_SITES
- Add OPTIONS to omit X11 dependency - Support CC/CFLAGS properly - Support PORTDOCS/PLIST_FILES - Add MAKE_JOBS_SAFE PR: 162835 Submitted by: Ports Fury Feature safe: yes
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/mpeg2codec/Makefile49
-rw-r--r--multimedia/mpeg2codec/files/patch-aa41
-rw-r--r--multimedia/mpeg2codec/pkg-plist9
3 files changed, 38 insertions, 61 deletions
diff --git a/multimedia/mpeg2codec/Makefile b/multimedia/mpeg2codec/Makefile
index 10c2482d397..af0454c780f 100644
--- a/multimedia/mpeg2codec/Makefile
+++ b/multimedia/mpeg2codec/Makefile
@@ -7,27 +7,54 @@
PORTNAME= mpeg2codec
PORTVERSION= 1.2
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= multimedia
-MASTER_SITES= http://fresh.t-systems-sfr.com/unix/src/misc/ \
- http://ftp.uni-koeln.de/graph/ \
- http://gd.tuwien.ac.at/graphics/libs/alsolibs/
-DISTFILES= mpeg2vidcodec_v12.tar.gz
+MASTER_SITES= http://fossies.org/unix/misc/old/ \
+ http://www.imagemagick.org/download/delegates/ \
+ http://gd.tuwien.ac.at/graphics/libs/alsolibs/ \
+ http://www.mpeg.org/pub_ftp/mpeg/mssg/
+DISTNAME= mpeg2vidcodec_v12
MAINTAINER= multimedia@FreeBSD.org
COMMENT= An MPEG-2 Encoder and Decoder
-USE_XORG= xext
+OPTIONS= X11 "Support for X11" on
+
WRKSRC= ${WRKDIR}/mpeg2
-DATADIR= share/mpeg2
-CFLAGS+=-DVERIFY -DVERBOSE -DTRACE
+
+MAKE_ARGS= CC="${CC}" CFLAGS="${CFLAGS}"
+MAKE_JOBS_SAFE= yes
+
+DATADIR= ${PREFIX}/share/mpeg2
+
+CFLAGS+= -DVERIFY -DVERBOSE -DTRACE
+
+PORTDOCS= mpeg2enc.doc
+PLIST_FILES= bin/mpeg2decode bin/mpeg2encode \
+ %%DATADIR%%/MPEG-1.par %%DATADIR%%/NTSC.par \
+ %%DATADIR%%/PAL.par %%DATADIR%%/inter.mat \
+ %%DATADIR%%/intra.mat
+PLIST_DIRS= %%DATADIR%%
+
+.include <bsd.port.options.mk>
+
+.if !defined(WITHOUT_X11)
+USE_XORG= xext
+MAKE_ARGS+= USE_DISP="-DDISPLAY" \
+ USE_SHMEM="-DSH_MEM" \
+ LIBS="$$(pkg-config --libs xext)" \
+ INCLUDEDIR="$$(pkg-config --cflags xext)"
+.endif
do-install:
.for i in dec enc
${INSTALL_PROGRAM} ${WRKSRC}/src/mpeg2${i}/mpeg2${i}ode ${PREFIX}/bin
.endfor
- ${MKDIR} ${PREFIX}/${DATADIR}
- ${INSTALL_DATA} ${WRKSRC}/doc/mpeg2enc.doc ${PREFIX}/${DATADIR}
- ${INSTALL_DATA} ${WRKSRC}/par/* ${PREFIX}/${DATADIR}
+ @${MKDIR} ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/par/* ${DATADIR}
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/mpeg2enc.doc ${DOCSDIR}
+.endif
.include <bsd.port.mk>
diff --git a/multimedia/mpeg2codec/files/patch-aa b/multimedia/mpeg2codec/files/patch-aa
deleted file mode 100644
index dc58c00335f..00000000000
--- a/multimedia/mpeg2codec/files/patch-aa
+++ /dev/null
@@ -1,41 +0,0 @@
---- Makefile.old Mon Nov 29 18:32:05 1999
-+++ Makefile Mon Nov 29 18:35:26 1999
-@@ -30,31 +30,32 @@
- # uncomment the following two lines if you want to include X11 support
- # (mpeg2decode)
-
--#USE_DISP = -DDISPLAY
-+USE_DISP = -DDISPLAY
- #LIBS = -lX11
-
- # uncomment the following two lines if you want to use shared memory
- # (faster display if server and client run on the same machine)
- # (mpeg2decode)
-
--#USE_SHMEM = -DSH_MEM
--#LIBS = -lXext -lX11
-+USE_SHMEM = -DSH_MEM
-+LIBS = -lXext -lX11
-
- # if your X11 include files / libraries are in a non standard location:
- # set INCLUDEDIR to -I followed by the appropriate include file path and
- # set LIBRARYDIR to -L followed by the appropriate library path
- # (mpeg2decode)
-
--#INCLUDEDIR = -I/usr/openwin/include
--#LIBRARYDIR = -L/usr/openwin/lib
-+INCLUDEDIR = -I${LOCALBASE}/include
-+LIBRARYDIR = -L${LOCALBASE}/lib
-
- # select one of the following CC CFLAGS settings
-
- #
- # GNU gcc
- #
-+.ifndef CC
- CC = gcc
--CFLAGS = -O2
-+.endif
-
- all: mpeg2decode mpeg2encode
-
diff --git a/multimedia/mpeg2codec/pkg-plist b/multimedia/mpeg2codec/pkg-plist
deleted file mode 100644
index 06904916fc4..00000000000
--- a/multimedia/mpeg2codec/pkg-plist
+++ /dev/null
@@ -1,9 +0,0 @@
-bin/mpeg2encode
-bin/mpeg2decode
-%%DATADIR%%/mpeg2enc.doc
-%%DATADIR%%/MPEG-1.par
-%%DATADIR%%/NTSC.par
-%%DATADIR%%/PAL.par
-%%DATADIR%%/inter.mat
-%%DATADIR%%/intra.mat
-@dirrm %%DATADIR%%