aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authorlioux <lioux@FreeBSD.org>2002-12-22 00:21:53 +0800
committerlioux <lioux@FreeBSD.org>2002-12-22 00:21:53 +0800
commitd50c9686e9683d37b5b0db0ac3eaf1aaf86a1be1 (patch)
tree4662db857ef82632e4af4b661d586d9d25fd2c62 /multimedia
parent6635d37a8490591d8c59c62edbd0166cf7648f45 (diff)
downloadfreebsd-ports-graphics-d50c9686e9683d37b5b0db0ac3eaf1aaf86a1be1.tar.gz
freebsd-ports-graphics-d50c9686e9683d37b5b0db0ac3eaf1aaf86a1be1.tar.zst
freebsd-ports-graphics-d50c9686e9683d37b5b0db0ac3eaf1aaf86a1be1.zip
Fix breakage if libgnugetopt is installed prior to building this
port. Only depend on libgnugetopt in such scenario: less dependencies and decreases chance of problems with -CURRENT vs libgnugetopt. Submitted by: Michael Nottebrock <michaelnottebrock@gmx.net> et al Approved by: portmgr (self & no objections)
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/mjpegtools/Makefile16
1 files changed, 16 insertions, 0 deletions
diff --git a/multimedia/mjpegtools/Makefile b/multimedia/mjpegtools/Makefile
index 21eb5437224..2bbcdc0686b 100644
--- a/multimedia/mjpegtools/Makefile
+++ b/multimedia/mjpegtools/Makefile
@@ -64,6 +64,14 @@ PLIST_SUB+= DIVX=''
.if exists(${LOCALBASE}/lib/libdv.so.2)
WITH_LIBDV= yes
.endif
+# LIBGNUGETOPT
+# If this is found in the system, the port tries to use it
+# Furthermore, we will only do this if gnugetopt is installed so
+# that we don't break -CURRENT since libgnugetopt is a problem for
+# -CURRENT right now
+.if exists(${LOCALBASE}/lib/libgnugetopt.so)
+WITH_LIBGNUGETOPT= yes
+.endif
# LIBMOVTAR
.if exists(${LOCALBASE}/lib/libmovtar.a)
WITH_LIBMOVTAR= yes
@@ -88,6 +96,10 @@ LIB_DEPENDS+= dv.2:${PORTSDIR}/multimedia/libdv
CONFIGURE_ARGS+= --with-dv=${LOCALBASE}
.endif
#
+.ifdef(WITH_LIBGNUGETOPT)
+LIB_DEPENDS+= gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
+.endif
+#
.ifdef(WITH_LIBMOVTAR)
BUILD_DEPENDS+= ${LOCALBASE}/lib/libmovtar.a:${PORTSDIR}/multimedia/libmovtar
@@ -156,6 +168,10 @@ post-patch:
@${REINPLACE_CMD} -E -e 's|^(have_pthread=).+$$|\1true|' \
${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
.endif
+.ifdef(WITH_LIBGNUGETOPT)
+ @${REINPLACE_CMD} -E -e 's|(AVIPLAY_LIBS \=.*)|\1 -lgnugetopt|' \
+ ${WRKSRC}/lavtools/Makefile.in
+.endif
post-configure:
@${CP} -f ${LOCALBASE}/bin/${LIBTOOL} ${WRKSRC}