aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
authornobutaka <nobutaka@FreeBSD.org>2008-05-18 23:26:45 +0800
committernobutaka <nobutaka@FreeBSD.org>2008-05-18 23:26:45 +0800
commitfec22798cc95a6d565c80a77b3693b149612c117 (patch)
treefbbcd9475b12b98a83af0f1bbe76d89873df2c5f /multimedia
parent7867c60ee466ffda085638af82f1393699da5f3e (diff)
downloadfreebsd-ports-graphics-fec22798cc95a6d565c80a77b3693b149612c117.tar.gz
freebsd-ports-graphics-fec22798cc95a6d565c80a77b3693b149612c117.tar.zst
freebsd-ports-graphics-fec22798cc95a6d565c80a77b3693b149612c117.zip
Add WITH_XCB knob.
PR: ports/123761 Submitted by: Max Brazhnikov <makc@issp.ac.ru>
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/libxine/Makefile9
-rw-r--r--multimedia/libxine/pkg-plist2
2 files changed, 11 insertions, 0 deletions
diff --git a/multimedia/libxine/Makefile b/multimedia/libxine/Makefile
index f32f8348933..d89512dcb26 100644
--- a/multimedia/libxine/Makefile
+++ b/multimedia/libxine/Makefile
@@ -58,6 +58,7 @@ OPTIONS= ARTS "Enable aRts support" off \
GNOMEVFS2 "Enable GnomeVFS2 support" off \
PULSEAUDIO "Enable PulseAudio support" off \
XVMC "Enable XvMC support" off \
+ XCB "Enable XCB support" off \
SMB "Enable SMB protocol support" off \
AALIB "Enable aalib support" off \
IMAGEMAGICK "Enable ImageMagick support" off \
@@ -135,6 +136,14 @@ CONFIGURE_ARGS+= --disable-xvmc
PLIST_SUB+= WITH_XVMC="@comment "
.endif
+.if defined(WITH_XCB)
+LIB_DEPENDS+= xcb.1:${PORTSDIR}/x11/libxcb
+PLIST_SUB+= WITH_XCB=""
+.else
+PLIST_SUB+= WITH_XCB="@comment "
+CONFIGURE_ARGS+= --without-xcb
+.endif
+
.if defined(WITH_SMB)
LIB_DEPENDS+= smbclient.0:${PORTSDIR}/net/samba-libsmbclient
PLIST_SUB+= WITH_SMB=""
diff --git a/multimedia/libxine/pkg-plist b/multimedia/libxine/pkg-plist
index fb44af4d298..f3199a3fee5 100644
--- a/multimedia/libxine/pkg-plist
+++ b/multimedia/libxine/pkg-plist
@@ -144,6 +144,8 @@ lib/libxine.so.1
%%PLUGINSDIR%%/xineplug_vo_out_raw.so
%%PLUGINSDIR%%/xineplug_vo_out_sdl.so
%%WITH_VIDIX%%%%PLUGINSDIR%%/xineplug_vo_out_vidix.so
+%%WITH_XCB%%%%PLUGINSDIR%%/xineplug_vo_out_xcbshm.so
+%%WITH_XCB%%%%PLUGINSDIR%%/xineplug_vo_out_xcbxv.so
%%PLUGINSDIR%%/xineplug_vo_out_xshm.so
%%PLUGINSDIR%%/xineplug_vo_out_xv.so
%%WITH_XVMC%%%%PLUGINSDIR%%/xineplug_vo_out_xvmc.so