aboutsummaryrefslogtreecommitdiffstats
path: root/net-im/gnomeicu2
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2004-12-19 06:34:52 +0800
committermarcus <marcus@FreeBSD.org>2004-12-19 06:34:52 +0800
commit21707743e7cc20a6fb40b7e3df309d68af929198 (patch)
treebcc0384d964f0a73c1038e01169c8286d77d4bdd /net-im/gnomeicu2
parent580c6d85d0afc2117b2e63392227e4770245653b (diff)
downloadfreebsd-ports-graphics-21707743e7cc20a6fb40b7e3df309d68af929198.tar.gz
freebsd-ports-graphics-21707743e7cc20a6fb40b7e3df309d68af929198.tar.zst
freebsd-ports-graphics-21707743e7cc20a6fb40b7e3df309d68af929198.zip
Fix a crash that can occur with an improperly formatted history file.
PR: 74522 Submitted by: kostik <kostik@ncport.ru>
Diffstat (limited to 'net-im/gnomeicu2')
-rw-r--r--net-im/gnomeicu2/Makefile2
-rw-r--r--net-im/gnomeicu2/files/patch-src_history.c14
2 files changed, 15 insertions, 1 deletions
diff --git a/net-im/gnomeicu2/Makefile b/net-im/gnomeicu2/Makefile
index 56785171bc9..19d47230ffc 100644
--- a/net-im/gnomeicu2/Makefile
+++ b/net-im/gnomeicu2/Makefile
@@ -7,7 +7,7 @@
PORTNAME= gnomeicu2
PORTVERSION= 0.99.5
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net gnome
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= gnomeicu
diff --git a/net-im/gnomeicu2/files/patch-src_history.c b/net-im/gnomeicu2/files/patch-src_history.c
new file mode 100644
index 00000000000..b529bd13bda
--- /dev/null
+++ b/net-im/gnomeicu2/files/patch-src_history.c
@@ -0,0 +1,14 @@
+--- src/history.c.orig Mon Nov 29 20:48:25 2004
++++ src/history.c Mon Nov 29 20:21:37 2004
+@@ -214,6 +214,11 @@
+ char direction;
+ time_t time;
+
++ if (! (ptr+4)) {
++ g_free (hp->buffer);
++ g_free (hp);
++ return FALSE;
++ }
+ /* read header info */
+ sscanf (ptr+4, "%c %d", &direction, (int *)&time);
+