aboutsummaryrefslogtreecommitdiffstats
path: root/net-im/ickle/Makefile
diff options
context:
space:
mode:
authorlioux <lioux@FreeBSD.org>2002-04-29 10:03:13 +0800
committerlioux <lioux@FreeBSD.org>2002-04-29 10:03:13 +0800
commit35dd7cb4ccfe1106ff3a7f4fa4a548a8576feea5 (patch)
tree9d60a7c6df1518a28988cd5b9b54576ec1c54f9b /net-im/ickle/Makefile
parentb42424f4d90cffe53a5e72f835b1c04be2c33c80 (diff)
downloadfreebsd-ports-graphics-35dd7cb4ccfe1106ff3a7f4fa4a548a8576feea5.tar.gz
freebsd-ports-graphics-35dd7cb4ccfe1106ff3a7f4fa4a548a8576feea5.tar.zst
freebsd-ports-graphics-35dd7cb4ccfe1106ff3a7f4fa4a548a8576feea5.zip
Update to 0.3.1
Approved by: maintainer
Diffstat (limited to 'net-im/ickle/Makefile')
-rw-r--r--net-im/ickle/Makefile23
1 files changed, 21 insertions, 2 deletions
diff --git a/net-im/ickle/Makefile b/net-im/ickle/Makefile
index a8477672232..40f26460d8e 100644
--- a/net-im/ickle/Makefile
+++ b/net-im/ickle/Makefile
@@ -7,22 +7,29 @@
#
PORTNAME= ickle
-PORTVERSION= 0.2.2
+PORTVERSION= 0.3.1
CATEGORIES= net devel
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= troff@paranoia.ru
-LIB_DEPENDS= gtkmm:${PORTSDIR}/x11-toolkits/gtk--
+LIB_DEPENDS= gtkmm:${PORTSDIR}/x11-toolkits/gtk-- \
+ iconv.3:${PORTSDIR}/converters/libiconv \
+ icq2000.4:${PORTSDIR}/net/libicq2000
WANT_GNOME= yes
+USE_GTK= yes
GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
CONFIGURE_ARGS= --with-sigc-prefix=${LOCALBASE} \
--with-gtkmm-prefix=${X11BASE}
+post-patch:
+ @${PERL} -pi -e 's|(#include <sys/socket.h>)|#include <sys/types.h>\n\1|' \
+ ${WRKSRC}/ctrlsocket/ControlSocket.h
+
.include <bsd.port.pre.mk>
.if defined(HAVE_GNOME) || defined(WITH_GNOME)
@@ -35,9 +42,21 @@ CONFIGURE_ARGS+= --with-gnome=no
PLIST_SUB+= ICKLEDATADIR="share/" GNOME="@comment " NOGNOME=""
.endif
+.if defined(WITH_ICKLE_CONTROL)
+PLIST_SUB+= ICKLECONTROL=""
+.else
+CONFIGURE_ARGS+= --without-ickle-control
+
+PLIST_SUB+= ICKLECONTROL="@comment "
+.endif
+
pre-everything::
.if !defined(HAVE_GNOME) && !defined(WITH_GNOME)
@${ECHO_MSG} "===> Define WITH_GNOME to enable GNOME support"
.endif
+.if !defined(WITH_ICKLE_CONTROL)
+ @${ECHO_MSG} "===> Define WITH_ICKLE_CONTROL to enable external command-line"
+ @${ECHO_MSG} "===> control for the ickle client"
+.endif
.include <bsd.port.post.mk>