aboutsummaryrefslogtreecommitdiffstats
path: root/net-im/ickle/Makefile
diff options
context:
space:
mode:
authorlioux <lioux@FreeBSD.org>2001-12-26 08:22:07 +0800
committerlioux <lioux@FreeBSD.org>2001-12-26 08:22:07 +0800
commit38054aaca03b795636035e87b280108ec0c85391 (patch)
treebcacf9b2d37b41b5dc16c7abcb3c2679d8e7f613 /net-im/ickle/Makefile
parent7eb1be421f2c80b2ad2ad2b1d3a446d30f9ccbb8 (diff)
downloadfreebsd-ports-graphics-38054aaca03b795636035e87b280108ec0c85391.tar.gz
freebsd-ports-graphics-38054aaca03b795636035e87b280108ec0c85391.tar.zst
freebsd-ports-graphics-38054aaca03b795636035e87b280108ec0c85391.zip
o Actually install libs
o Also, allow WITH/WITHOUT_GNOME installation Approved by: maintainer
Diffstat (limited to 'net-im/ickle/Makefile')
-rw-r--r--net-im/ickle/Makefile20
1 files changed, 19 insertions, 1 deletions
diff --git a/net-im/ickle/Makefile b/net-im/ickle/Makefile
index 7424d7f0dba..483fc0015c7 100644
--- a/net-im/ickle/Makefile
+++ b/net-im/ickle/Makefile
@@ -16,10 +16,28 @@ MAINTAINER= troff@paranoia.ru
LIB_DEPENDS= gtkmm:${PORTSDIR}/x11-toolkits/gtk--
+WANT_GNOME= yes
GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
CONFIGURE_ARGS= --with-sigc-prefix=${LOCALBASE} \
--with-gtkmm-prefix=${X11BASE}
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if defined(HAVE_GNOME) || defined(WITH_GNOME)
+USE_GNOME= yes
+
+PLIST_SUB+= ICKLEDATADIR="share/gnome/" GNOME="" NOGNOME="@comment "
+.else
+CONFIGURE_ARGS+= --disable-gnome
+
+PLIST_SUB+= ICKLEDATADIR="share/" GNOME="@comment " NOGNOME=""
+.endif
+
+pre-everything::
+.if !defined(HAVE_GNOME) && !defined(WITH_GNOME)
+ @${ECHO_MSG} "===> Define WITH_GNOME to enable GNOME support"
+.endif
+
+.include <bsd.port.post.mk>