aboutsummaryrefslogtreecommitdiffstats
path: root/net-im/libpurple/Makefile
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2014-11-26 21:08:24 +0800
committermat <mat@FreeBSD.org>2014-11-26 21:08:24 +0800
commit9debac461b7729b783ca5a0f5e46461ddac07173 (patch)
tree0d350fe6ad6a2fe3222d838f3c72856c78cd449f /net-im/libpurple/Makefile
parenteedda7c96f5b61bbadc957164c030b26a221e965 (diff)
downloadfreebsd-ports-graphics-9debac461b7729b783ca5a0f5e46461ddac07173.tar.gz
freebsd-ports-graphics-9debac461b7729b783ca5a0f5e46461ddac07173.tar.zst
freebsd-ports-graphics-9debac461b7729b783ca5a0f5e46461ddac07173.zip
Change the way Perl modules are installed, update the default Perl to 5.18.
Before, we had: site_perl : lib/perl5/site_perl/5.18 site_perl/perl_arch : lib/perl5/site_perl/5.18/mach perl_man3 : lib/perl5/5.18/man/man3 Now we have: site_perl : lib/perl5/site_perl site_arch : lib/perl5/site_perl/mach/5.18 perl_man3 : lib/perl5/site_perl/man/man3 Modules without any .so will be installed at the same place regardless of the Perl version, minimizing the upgrade when the major Perl version is changed. It uses a version dependent directory for modules with compiled bits. As PERL_ARCH is no longer needed in plists, it has been removed from PLIST_SUB. The USE_PERL5=fixpacklist keyword is removed, the .packlist file is now always removed, as is perllocal.pod. The old site_perl and site_perl/arch directories have been kept in the default Perl @INC for all Perl ports, and will be phased out as these old Perl versions expire. PR: 194969 Differential Revision: https://reviews.freebsd.org/D1019 Exp-run by: antoine Reviewed by: perl@ Approved by: portmgr
Diffstat (limited to 'net-im/libpurple/Makefile')
-rw-r--r--net-im/libpurple/Makefile8
1 files changed, 1 insertions, 7 deletions
diff --git a/net-im/libpurple/Makefile b/net-im/libpurple/Makefile
index fc01828b12a..5f9209c0937 100644
--- a/net-im/libpurple/Makefile
+++ b/net-im/libpurple/Makefile
@@ -3,7 +3,7 @@
PORTNAME?= libpurple
PORTVERSION= 2.10.10
-PORTREVISION?= 1
+PORTREVISION?= 2
CATEGORIES?= net-im
MASTER_SITES= SF/pidgin/Pidgin/${PORTVERSION}
DISTNAME= pidgin-${PORTVERSION}
@@ -325,10 +325,4 @@ post-patch:
's|$$(top_builddir)/libpurple/libpurple.la|-lpurple|'
.endif
-.if !defined(PIDGIN_SLAVE) && ${PORT_OPTIONS:MPERL}
-post-stage:
- @${SED} -i '' -e 's|^${STAGEDIR}||g' \
- ${STAGEDIR}${PREFIX}/lib/purple-2/perl/auto/Purple/.packlist
-.endif
-
.include <bsd.port.post.mk>