aboutsummaryrefslogtreecommitdiffstats
path: root/net-im/licq/files
diff options
context:
space:
mode:
authorgreen <green@FreeBSD.org>2000-02-15 09:46:27 +0800
committergreen <green@FreeBSD.org>2000-02-15 09:46:27 +0800
commitcc8a24c67a0a4aea7d9b45a30e39f383b1fe5a6c (patch)
tree321e380f5af2d349cb4504df67b8cdec06225cd3 /net-im/licq/files
parenta2eef14356500d84a413bb4a81a15a86e15d1bc1 (diff)
downloadfreebsd-ports-graphics-cc8a24c67a0a4aea7d9b45a30e39f383b1fe5a6c.tar.gz
freebsd-ports-graphics-cc8a24c67a0a4aea7d9b45a30e39f383b1fe5a6c.tar.zst
freebsd-ports-graphics-cc8a24c67a0a4aea7d9b45a30e39f383b1fe5a6c.zip
Update to Licq version 0.75.3a, done by Alexander N. Kabaev :)
This version is basically a completely new program (modules, etc), and it fixes every issue I'd ever had with Licq (for instance). You'll find tons of new features here. Submitted by: Alexander N. Kabaev <kabaev@mail.ru>
Diffstat (limited to 'net-im/licq/files')
-rw-r--r--net-im/licq/files/patch-aa77
-rw-r--r--net-im/licq/files/patch-ab60
-rw-r--r--net-im/licq/files/patch-ac11
3 files changed, 108 insertions, 40 deletions
diff --git a/net-im/licq/files/patch-aa b/net-im/licq/files/patch-aa
index 41d231f474b..2a5bd5ffe26 100644
--- a/net-im/licq/files/patch-aa
+++ b/net-im/licq/files/patch-aa
@@ -1,22 +1,55 @@
---- src/messagebox.cpp.old Tue Mar 9 15:42:14 1999
-+++ src/messagebox.cpp Tue Mar 9 15:42:55 1999
-@@ -67,7 +67,7 @@
- QColorGroup newNormal(normal.foreground(), normal.background(), normal.light(), normal.dark(),
- normal.mid(), normal.text(), QColor(192, 192, 192));
- setPalette(QPalette(newNormal, pal.disabled(), newNormal));
-- setStyle(WindowsStyle);
-+ setStyle(MotifStyle);
- setFrameStyle(QFrame::Panel | QFrame::Sunken);
-
- }
---- src/searchuserdlg.cpp.old Tue Mar 9 15:42:23 1999
-+++ src/searchuserdlg.cpp Tue Mar 9 15:42:48 1999
-@@ -115,7 +115,7 @@
- QColorGroup normal(pal.normal());
- QColorGroup newNormal(normal.foreground(), normal.background(), normal.light(), normal.dark(), normal.mid(), normal.text(), QColor(192, 192, 192));
- foundView->setPalette(QPalette(newNormal, pal.disabled(), newNormal));*/
-- foundView->setStyle(WindowsStyle);
-+ foundView->setStyle(MotifStyle);
- foundView->setFrameStyle(QFrame::Box | QFrame::Raised);
-
- connect (btnDone, SIGNAL(clicked()), this, SLOT(accept()));
+--- plugins/qt-gui/configure.orig Tue Feb 8 16:14:18 2000
++++ plugins/qt-gui/configure Tue Feb 8 16:15:42 2000
+@@ -3966,7 +3966,7 @@
+ fi
+
+ for qt_dir in $qt_library_dirs; do
+- for qt_check_lib in $qt_dir/libqt.so.2; do
++ for qt_check_lib in $qt_dir/libqt2.so.2; do
+ if test -r $qt_check_lib; then
+ ac_qt_libraries=$qt_dir
+ break 2
+@@ -3987,7 +3987,7 @@
+ have_qt_lib="yes"
+ fi
+
+- output=`eval "objdump -C -T $ac_cv_lib_qtlib/libqt.so* | grep QCString"`
++ output=`eval "objdump -C -T $ac_cv_lib_qtlib/libqt2.so* | grep QCString"`
+ if test -z "$output"; then
+ { echo "configure: error: The Qt lib directory
+ $ac_cv_lib_qtlib
+@@ -4050,6 +4050,7 @@
+ /usr/X11/include/X11/qt \
+ /usr/X11R6/include \
+ /usr/X11R6/include/qt \
++ /usr/X11R6/include/qt2 \
+ /usr/X11R6/include/X11/qt \
+ /usr/X11/lib/qt/include"
+
+@@ -4113,7 +4114,7 @@
+
+
+ # Extract the first word of "moc", so it can be a program name with args.
+-set dummy moc; ac_word=$2
++set dummy moc2; ac_word=$2
+ echo $ac_n "checking for $ac_word""... $ac_c" 1>&6
+ echo "configure:4119: checking for $ac_word" >&5
+ if eval "test \"`echo '$''{'ac_cv_path_MOC'+set}'`\" = set"; then
+@@ -4137,7 +4138,7 @@
+ fi
+ done
+ IFS="$ac_save_ifs"
+- test -z "$ac_cv_path_MOC" && ac_cv_path_MOC="$QTDIR/bin/moc"
++ test -z "$ac_cv_path_MOC" && ac_cv_path_MOC="$QTDIR/bin/moc2"
+ ;;
+ esac
+ fi
+@@ -4152,7 +4153,7 @@
+
+
+ if test -z "$QTDIR"; then
+- echo "** environment variable QTDIR is not set, moc might not be found"
++ echo "** environment variable QTDIR is not set, moc2 might not be found"
+ fi
+
+
diff --git a/net-im/licq/files/patch-ab b/net-im/licq/files/patch-ab
index 27aee2a8cbe..52f8640438b 100644
--- a/net-im/licq/files/patch-ab
+++ b/net-im/licq/files/patch-ab
@@ -1,22 +1,46 @@
---- acconfig.h.old Wed Mar 10 10:05:47 1999
-+++ acconfig.h Wed Mar 10 10:06:26 1999
-@@ -14,7 +14,7 @@
+--- plugins/qt-gui/acinclude.m4.in.orig Mon Feb 7 23:35:22 2000
++++ plugins/qt-gui/acinclude.m4.in Mon Feb 7 23:37:10 2000
+@@ -63,7 +63,7 @@
+ fi
- /* Change this to MotifStyle if you want the old-school Motif
- widget look. */
--#define STYLE WindowsStyle
-+#define STYLE MotifStyle
+ for qt_dir in $qt_library_dirs; do
+- for qt_check_lib in $qt_dir/libqt.so.2; do
++ for qt_check_lib in $qt_dir/libqt2.so.2; do
+ if test -r $qt_check_lib; then
+ ac_qt_libraries=$qt_dir
+ break 2
+@@ -84,7 +84,7 @@
+ fi
- /* The name of the package we're compiling */
- #undef PACKAGE
---- config.h.in.old Wed Mar 10 10:05:53 1999
-+++ config.h.in Wed Mar 10 10:06:17 1999
-@@ -15,7 +15,7 @@
+ dnl Check if we have the right lib
+- output=`eval "objdump -C -T $ac_cv_lib_qtlib/libqt.so* | grep QCString"`
++ output=`eval "objdump -C -T $ac_cv_lib_qtlib/libqt2.so* | grep QCString"`
+ if test -z "$output"; then
+ AC_MSG_ERROR([The Qt lib directory
+ $ac_cv_lib_qtlib
+@@ -132,6 +132,7 @@
+ /usr/X11/include/X11/qt \
+ /usr/X11R6/include \
+ /usr/X11R6/include/qt \
++ /usr/X11R6/include/qt2 \
+ /usr/X11R6/include/X11/qt \
+ /usr/X11/lib/qt/include"
- /* Change this to MotifStyle if you want the old-school Motif
- widget look. */
--#define STYLE WindowsStyle
-+#define STYLE MotifStyle
+@@ -173,14 +174,14 @@
+ [
+ AC_PATH_PROG(
+ MOC,
+- moc,
+- $QTDIR/bin/moc,
++ moc2,
++ $QTDIR/bin/moc2,
+ $QTDIR/bin:/usr/bin:/usr/X11R6/bin:/usr/lib/qt/bin:/usr/local/qt/bin:$PATH)
+
+ AC_SUBST(MOC)
+
+ if test -z "$QTDIR"; then
+- echo "** environment variable QTDIR is not set, moc might not be found"
++ echo "** environment variable QTDIR is not set, moc2 might not be found"
+ fi
+ ])
- /* The name of the package we're compiling */
- #undef PACKAGE
diff --git a/net-im/licq/files/patch-ac b/net-im/licq/files/patch-ac
new file mode 100644
index 00000000000..ceb848b1776
--- /dev/null
+++ b/net-im/licq/files/patch-ac
@@ -0,0 +1,11 @@
+--- plugins/qt-gui/src/Makefile.in.orig Tue Feb 8 16:12:30 2000
++++ plugins/qt-gui/src/Makefile.in Tue Feb 8 16:12:51 2000
+@@ -120,7 +120,7 @@
+
+ licq_qt_gui_la_LDFLAGS = $(X_LIBS) $(QT_LDFLAGS) $(KDE_LDFLAGS) -s -module -avoid-version -rpath $(libdir)
+
+-licq_qt_gui_la_LIBADD = $(KDE_LIBS) -lqt $(X_PRE_LIBS) -lX11 -lXext $(XSS_LIBS) $(X_EXTRA_LIBS) $(KDE_LIBS)
++licq_qt_gui_la_LIBADD = $(KDE_LIBS) -lqt2 $(X_PRE_LIBS) -lX11 -lXext $(XSS_LIBS) $(X_EXTRA_LIBS) $(KDE_LIBS)
+
+
+ #>- METASOURCES = AUTO