aboutsummaryrefslogtreecommitdiffstats
path: root/net-im/openfire/Makefile
diff options
context:
space:
mode:
authorgahr <gahr@FreeBSD.org>2016-10-31 23:18:59 +0800
committergahr <gahr@FreeBSD.org>2016-10-31 23:18:59 +0800
commit26d71c51cb7402455bb61694540e07ef40493cc2 (patch)
tree39dc11f142cec04a6f469a9d7b209a93a41b089f /net-im/openfire/Makefile
parent8455dc96b3baa537f1b1ddd3081cfa2e4883b0dc (diff)
downloadfreebsd-ports-graphics-26d71c51cb7402455bb61694540e07ef40493cc2.tar.gz
freebsd-ports-graphics-26d71c51cb7402455bb61694540e07ef40493cc2.tar.zst
freebsd-ports-graphics-26d71c51cb7402455bb61694540e07ef40493cc2.zip
net-im/openfire: update to 4.0.3, switch to OPTIONS helpers
https://download.igniterealtime.org/openfire/docs/4.0.3/changelog.html PR: 213929 Submitted by: Danilo G. Baio <dbaio@bsd.com.br>
Diffstat (limited to 'net-im/openfire/Makefile')
-rw-r--r--net-im/openfire/Makefile41
1 files changed, 18 insertions, 23 deletions
diff --git a/net-im/openfire/Makefile b/net-im/openfire/Makefile
index c9d9b99f074..bcfcf700a99 100644
--- a/net-im/openfire/Makefile
+++ b/net-im/openfire/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= openfire
-PORTVERSION= 4.0.2
+PORTVERSION= 4.0.3
PORTEPOCH= 1
CATEGORIES= net-im java
MASTER_SITES= http://download.igniterealtime.org/openfire/
@@ -13,10 +13,11 @@ COMMENT= Enterprise instant messaging server
LICENSE= APACHE20
-RUN_DEPENDS= ${JAVAJARDIR}/slf4j-api.jar:devel/slf4j
+RUN_DEPENDS= ${JAVALIBDIR}/slf4j-api.jar:devel/slf4j
OPTIONS_DEFINE= DOCS PLUGINS
OPTIONS_DEFAULT=PLUGINS
+OPTIONS_SUB= yes
PLUGINS_DESC= Install bundled plugins
USES= cpe dos2unix zip
@@ -44,14 +45,7 @@ GROUPS= ${USERS}
PLIST_SUB+= VARLOG=${VARLOG} \
VARDB=${VARDB}
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MPLUGINS}
-ALL_TARGET+= plugins
-PLIST_SUB+= PLUGINS=""
-.else
-PLIST_SUB+= PLUGINS="@comment "
-.endif
+PLUGINS_ALL_TARGET= plugins
do-install:
@${MKDIR} ${STAGEDIR}${DATADIR}/lib
@@ -69,19 +63,6 @@ do-install:
(cd ${INSTALL_WRKSRC}/plugins/admin && ${FIND} . \
| ${CPIO} -pvdmu -R ${SHAREOWN}:${SHAREGRP} ${STAGEDIR}${DATADIR}/plugins/admin)
-.if ${PORT_OPTIONS:MPLUGINS}
- (cd ${INSTALL_WRKSRC}/plugins && ${FIND} . \
- | ${CPIO} -pvdmu -R ${SHAREOWN}:${SHAREGRP} ${STAGEDIR}${DATADIR}/plugins)
-.endif
-
-.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${STAGEDIR}${DOCSDIR}
- (cd ${WRKSRC} && ${INSTALL_DATA} LICENSE.html README.html changelog.html \
- ${STAGEDIR}${DOCSDIR})
-
- (cd ${WRKSRC}/documentation/docs && ${FIND} . \! -path ./javadoc\* \
- | ${CPIO} -pdmu -R ${SHAREOWN}:${SHAREGRP} ${STAGEDIR}${DOCSDIR} > /dev/null 2>&1 )
-.endif
${LN} -sf ${ETCDIR} ${STAGEDIR}${DATADIR}/conf
${LN} -sf ${ETCDIR} ${STAGEDIR}${DATADIR}/resources/security
${LN} -sf ${VARDB} ${STAGEDIR}${DATADIR}/embedded-db
@@ -95,4 +76,18 @@ do-install:
${INSTALL_DATA} ${INSTALL_WRKSRC}/conf/security.xml \
${STAGEDIR}${ETCDIR}/security.xml.sample
+do-install-PLUGINS-on:
+ (cd ${INSTALL_WRKSRC}/plugins && ${FIND} . \
+ | ${CPIO} -pvdmu -R ${SHAREOWN}:${SHAREGRP} ${STAGEDIR}${DATADIR}/plugins)
+
+do-install-DOCS-on:
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ (cd ${WRKSRC} && ${INSTALL_DATA} LICENSE.html README.html changelog.html \
+ ${STAGEDIR}${DOCSDIR})
+ (cd ${WRKSRC}/documentation/docs && ${FIND} . \! -path ./javadoc\* \
+ | ${CPIO} -pdmu -R ${SHAREOWN}:${SHAREGRP} ${STAGEDIR}${DOCSDIR} > /dev/null 2>&1 )
+
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${DATADIR}/resources/nativeAuth/linux-i386/libshaj.so
+
.include <bsd.port.mk>