aboutsummaryrefslogtreecommitdiffstats
path: root/net-im/pymsn/Makefile
diff options
context:
space:
mode:
authorflz <flz@FreeBSD.org>2007-04-20 07:33:59 +0800
committerflz <flz@FreeBSD.org>2007-04-20 07:33:59 +0800
commitc079f09787715d726d02d8ec6d1d9757820608b4 (patch)
treeb52d2efe86fbc7d618da9ca21b37a33cd40139c6 /net-im/pymsn/Makefile
parentf53c503b263fca2341e5ec347e43a6acf178bb33 (diff)
downloadfreebsd-ports-graphics-c079f09787715d726d02d8ec6d1d9757820608b4.tar.gz
freebsd-ports-graphics-c079f09787715d726d02d8ec6d1d9757820608b4.tar.zst
freebsd-ports-graphics-c079f09787715d726d02d8ec6d1d9757820608b4.zip
Add pymsn, a msn python library used in the Telepathy framework.
Diffstat (limited to 'net-im/pymsn/Makefile')
-rw-r--r--net-im/pymsn/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/net-im/pymsn/Makefile b/net-im/pymsn/Makefile
new file mode 100644
index 00000000000..c9bb0be94d2
--- /dev/null
+++ b/net-im/pymsn/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: pymsn
+# Date created: Apr 19 2007
+# Whom: Florent Thoumie <flz@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pymsn
+PORTVERSION= 0.2.2
+CATEGORIES= net-im
+MASTER_SITES= http://telepathy.freedesktop.org/releases/${PORTNAME}/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= MSN Connection library
+
+LIB_PC_DEPENDS= pygobject-2.0.pc:${PORTSDIR}/devel/py-gobject
+
+BUILD_DEPENDS+= ${LIB_PC_DEPENDS:C|^|${LOCALBASE}/libdata/pkgconfig/|g}
+RUN_DEPENDS+= ${LIB_PC_DEPENDS:C|^|${LOCALBASE}/libdata/pkgconfig/|g}
+
+USE_PYTHON= 2.4+
+USE_PYDISTUTILS= yes
+
+.include <bsd.port.mk>