aboutsummaryrefslogtreecommitdiffstats
path: root/net-im/qxmpp
diff options
context:
space:
mode:
authorpawel <pawel@FreeBSD.org>2016-12-06 04:26:36 +0800
committerpawel <pawel@FreeBSD.org>2016-12-06 04:26:36 +0800
commit7b37fb87a918e67917d9bb3bcedb0f631963614c (patch)
treef85b90f5eb8d3622da27e1ebaa57de335ad1ae1b /net-im/qxmpp
parente0683aab839b915d6805adf24b7a2ffdee140c24 (diff)
downloadfreebsd-ports-graphics-7b37fb87a918e67917d9bb3bcedb0f631963614c.tar.gz
freebsd-ports-graphics-7b37fb87a918e67917d9bb3bcedb0f631963614c.tar.zst
freebsd-ports-graphics-7b37fb87a918e67917d9bb3bcedb0f631963614c.zip
Add qxmpp Qt5 slave port needed for polish/kadu update
PR: 214547 Submitted by: myself Approved by: maintainer timeout
Diffstat (limited to 'net-im/qxmpp')
-rw-r--r--net-im/qxmpp/Makefile12
-rw-r--r--net-im/qxmpp/pkg-plist4
2 files changed, 12 insertions, 4 deletions
diff --git a/net-im/qxmpp/Makefile b/net-im/qxmpp/Makefile
index c86fd6e63ac..108b3e16ffb 100644
--- a/net-im/qxmpp/Makefile
+++ b/net-im/qxmpp/Makefile
@@ -12,15 +12,23 @@ COMMENT= QXmpp is an xmpp client library based on Qt & C++
LICENSE= LGPL21
LICENSE_FILE= ${WRKSRC}/LICENSE.LGPL
+CONFLICTS?= ${PORTNAME}-qt5-[0-9]*
+
USES= qmake pathfix pkgconfig libtool
-USE_QT4= gui network qtestlib xml uic_build moc_build \
+.if defined(QXMPP_SLAVE)
+USE_QT5= core gui network xml buildtools_build
+PLIST_SUB= QDNS="@comment "
+.else
+USE_QT4= corelib gui network qtestlib xml uic_build moc_build \
rcc_build
+PLIST_SUB= QDNS=""
+.endif
QMAKE_ARGS= QXMPP_NO_TESTS=1
USE_GITHUB= yes
GH_ACCOUNT= qxmpp-project
-PLIST_SUB= VERSION=${PORTVERSION} VERSION_MAJOR=${PORTVERSION:R}
+PLIST_SUB+= VERSION=${PORTVERSION} VERSION_MAJOR=${PORTVERSION:R}
pre-configure:
${REINPLACE_CMD} -e 's|pkgconfig|../libdata/pkgconfig|g' \
diff --git a/net-im/qxmpp/pkg-plist b/net-im/qxmpp/pkg-plist
index 1f705383b7a..fbee4b67b61 100644
--- a/net-im/qxmpp/pkg-plist
+++ b/net-im/qxmpp/pkg-plist
@@ -61,8 +61,8 @@ include/qxmpp/QXmppVCardIq.h
include/qxmpp/QXmppVCardManager.h
include/qxmpp/QXmppVersionIq.h
include/qxmpp/QXmppVersionManager.h
-include/qxmpp/qdnslookup.h
-include/qxmpp/qdnslookup_p.h
+%%QDNS%%include/qxmpp/qdnslookup.h
+%%QDNS%%include/qxmpp/qdnslookup_p.h
lib/libqxmpp.so
lib/libqxmpp.so.0
lib/libqxmpp.so.%%VERSION_MAJOR%%