aboutsummaryrefslogtreecommitdiffstats
path: root/net-im
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2008-11-01 17:33:05 +0800
committerdinoex <dinoex@FreeBSD.org>2008-11-01 17:33:05 +0800
commit0a67ec98d4bec06ad5c9e5dba2d960251360d602 (patch)
tree1291400e2a310c77e03751c1a219da05a594fade /net-im
parent943360173884483d6b84d025e97614cb699c8a42 (diff)
downloadfreebsd-ports-graphics-0a67ec98d4bec06ad5c9e5dba2d960251360d602.tar.gz
freebsd-ports-graphics-0a67ec98d4bec06ad5c9e5dba2d960251360d602.tar.zst
freebsd-ports-graphics-0a67ec98d4bec06ad5c9e5dba2d960251360d602.zip
- udpate to 1.3.6
Diffstat (limited to 'net-im')
-rw-r--r--net-im/licq-console/files/patch-console.h11
-rw-r--r--net-im/licq-qt-gui/Makefile1
-rw-r--r--net-im/licq/Makefile2
-rw-r--r--net-im/licq/Makefile.inc6
-rw-r--r--net-im/licq/distinfo6
-rw-r--r--net-im/licq/files/patch-icqpacket.cpp11
6 files changed, 7 insertions, 30 deletions
diff --git a/net-im/licq-console/files/patch-console.h b/net-im/licq-console/files/patch-console.h
deleted file mode 100644
index 0115dccd927..00000000000
--- a/net-im/licq-console/files/patch-console.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/console.h.orig Mon Nov 4 00:22:38 2002
-+++ src/console.h Mon Nov 4 00:22:50 2002
-@@ -5,6 +5,8 @@
- #include "config.h"
- #endif
-
-+using namespace std;
-+
- #include "licq_icqd.h"
- #include "licq_log.h"
- #include "window.h"
diff --git a/net-im/licq-qt-gui/Makefile b/net-im/licq-qt-gui/Makefile
index 3145f06574a..7b82f44114e 100644
--- a/net-im/licq-qt-gui/Makefile
+++ b/net-im/licq-qt-gui/Makefile
@@ -7,7 +7,6 @@
PORTNAME= qt-gui
PORTVERSION= ${QT_LICQ_VER}
-PORTREVISION= 1
CATEGORIES= net-im
PKGNAMESUFFIX?= ${KDE_SUFFIX}${PKGNAMESUFFIX2}
diff --git a/net-im/licq/Makefile b/net-im/licq/Makefile
index 4b39f8fef86..a80d93d1e23 100644
--- a/net-im/licq/Makefile
+++ b/net-im/licq/Makefile
@@ -7,7 +7,6 @@
PORTNAME= base
PORTVERSION= ${LICQ_VER}
-PORTREVISION= 3
CATEGORIES= net-im
PKGNAMESUFFIX= ${SOCKS_SUFFIX}${PKGNAMESUFFIX2}
@@ -17,6 +16,7 @@ COMMENT= A popular ICQ-compatible plugin-based program
.if defined(WITH_SOCKS)
BUILD_DEPENDS= ${LOCALBASE}/lib/libsocks5.a:${PORTSDIR}/net/socks5
.endif
+LIB_DEPENDS= boost_regex.4:${PORTSDIR}/devel/boost
USE_ICONV= yes
WRKSRC= ${WRKDIR}/${DISTNAME}
diff --git a/net-im/licq/Makefile.inc b/net-im/licq/Makefile.inc
index 49e7be6162a..7d4dff4124b 100644
--- a/net-im/licq/Makefile.inc
+++ b/net-im/licq/Makefile.inc
@@ -2,11 +2,11 @@
# $FreeBSD$
PKGNAMEPREFIX= licq-
-LICQ_VER= 1.3.5
-QT_LICQ_VER= 1.3.5
+LICQ_VER= 1.3.6
+QT_LICQ_VER= 1.3.6
OSD_LICQ_VER= 1.3.2.1
RMS_LICQ_VER= 1.3.2
-CONSOLE_LICQ_VER= 1.3.5
+CONSOLE_LICQ_VER= 1.3.6
.if ${PORTNAME} != "base"
RUN_DEPENDS+= licq:${PORTSDIR}/${LICQ_PORT}
.endif
diff --git a/net-im/licq/distinfo b/net-im/licq/distinfo
index 948e3714d22..3e410b12f1f 100644
--- a/net-im/licq/distinfo
+++ b/net-im/licq/distinfo
@@ -1,3 +1,3 @@
-MD5 (licq-1.3.5.tar.bz2) = 842a73c82980721961fe824f40377292
-SHA256 (licq-1.3.5.tar.bz2) = ca6692026e87459082b33ebb6480cc5c600001c93e1d9e2bbde65f3cf2238d3e
-SIZE (licq-1.3.5.tar.bz2) = 3260471
+MD5 (licq-1.3.6.tar.bz2) = 9a2842dceba565601d0339347e6e203d
+SHA256 (licq-1.3.6.tar.bz2) = ad6ea66301923e5d106111a6b4654aaa72131d8b5c499d16dc9fbbc8cd29845e
+SIZE (licq-1.3.6.tar.bz2) = 4777777
diff --git a/net-im/licq/files/patch-icqpacket.cpp b/net-im/licq/files/patch-icqpacket.cpp
deleted file mode 100644
index 874d1c82b52..00000000000
--- a/net-im/licq/files/patch-icqpacket.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/icqpacket.cpp.orig 2007-09-28 22:11:35.000000000 +0200
-+++ src/icqpacket.cpp 2008-07-02 20:09:19.000000000 +0200
-@@ -821,7 +821,7 @@
-
- // Static versioning
- buffer->PackUnsignedLongBE(0x00160002);
-- buffer->PackUnsignedShortBE(0x010A);
-+ buffer->PackUnsignedShortBE(0x010B);
- // Client version major (4 == ICQ2000, 5 == ICQ2001)
- buffer->PackUnsignedLongBE(0x00170002);
- buffer->PackUnsignedShortBE(0x0014);