aboutsummaryrefslogtreecommitdiffstats
path: root/net-im
diff options
context:
space:
mode:
authorarved <arved@FreeBSD.org>2015-02-18 00:05:20 +0800
committerarved <arved@FreeBSD.org>2015-02-18 00:05:20 +0800
commit12385e29e280bbc91f52683f04ddb784347d4d46 (patch)
treeb87974c25c74265069feb50f36467f82fb05227a /net-im
parentfdf476d291566aa7d45319b53b6725048a1befee (diff)
downloadfreebsd-ports-graphics-12385e29e280bbc91f52683f04ddb784347d4d46.tar.gz
freebsd-ports-graphics-12385e29e280bbc91f52683f04ddb784347d4d46.tar.zst
freebsd-ports-graphics-12385e29e280bbc91f52683f04ddb784347d4d46.zip
Add profanity, an console XMPP client
Diffstat (limited to 'net-im')
-rw-r--r--net-im/Makefile1
-rw-r--r--net-im/profanity/Makefile24
-rw-r--r--net-im/profanity/distinfo2
-rw-r--r--net-im/profanity/pkg-descr4
-rw-r--r--net-im/profanity/pkg-plist15
5 files changed, 46 insertions, 0 deletions
diff --git a/net-im/Makefile b/net-im/Makefile
index 8f0c923de6f..7c972e6c7de 100644
--- a/net-im/Makefile
+++ b/net-im/Makefile
@@ -115,6 +115,7 @@
SUBDIR += plasma-applet-ktp
SUBDIR += poezio
SUBDIR += pork
+ SUBDIR += profanity
SUBDIR += prosody
SUBDIR += proxy65
SUBDIR += psi
diff --git a/net-im/profanity/Makefile b/net-im/profanity/Makefile
new file mode 100644
index 00000000000..432e840939a
--- /dev/null
+++ b/net-im/profanity/Makefile
@@ -0,0 +1,24 @@
+# $FreeBSD$
+
+PORTNAME= profanity
+PORTVERSION= 0.4.5
+CATEGORIES= net-im
+MASTER_SITES= http://www.profanity.im/
+
+MAINTAINER= arved@FreeBSD.org
+COMMENT= Console based XMPP client
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+LIB_DEPENDS= libstrophe.so:${PORTNAME}/net-im/libstrophe \
+ libglib-2.0.so:${PORTSDIR}/devel/glib20 \
+ libcurl.so:${PORTSDIR}/ftp/curl \
+ libotr.so:${PORTSDIR}/security/libotr3
+
+USES= ncurses pkgconfig
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --enable-otr
+CONFIGURE_ENV= LIBS="${CFLAGS} -lcrypto"
+
+.include <bsd.port.mk>
diff --git a/net-im/profanity/distinfo b/net-im/profanity/distinfo
new file mode 100644
index 00000000000..328d1ca16dd
--- /dev/null
+++ b/net-im/profanity/distinfo
@@ -0,0 +1,2 @@
+SHA256 (profanity-0.4.5.tar.gz) = 7436b38d03da0645f5cdb3ca3921b974a760ba68fa92e4def82519d759c7fc63
+SIZE (profanity-0.4.5.tar.gz) = 411095
diff --git a/net-im/profanity/pkg-descr b/net-im/profanity/pkg-descr
new file mode 100644
index 00000000000..094a6a65b66
--- /dev/null
+++ b/net-im/profanity/pkg-descr
@@ -0,0 +1,4 @@
+Profanity is a console based XMPP client written in C using ncurses and
+libstrophe, inspired by Irssi
+
+WWW: http://www.profanity.im/
diff --git a/net-im/profanity/pkg-plist b/net-im/profanity/pkg-plist
new file mode 100644
index 00000000000..885a0252b06
--- /dev/null
+++ b/net-im/profanity/pkg-plist
@@ -0,0 +1,15 @@
+bin/profanity
+man/man1/profanity.1.gz
+share/profanity/themes/aqua
+share/profanity/themes/batman
+share/profanity/themes/boothj5
+share/profanity/themes/hacker
+share/profanity/themes/headache
+share/profanity/themes/joker
+share/profanity/themes/orange
+share/profanity/themes/original
+share/profanity/themes/redsplash
+share/profanity/themes/shade
+share/profanity/themes/spawn
+share/profanity/themes/whiteness
+share/profanity/themes/yellowsplash