aboutsummaryrefslogtreecommitdiffstats
path: root/net-im
diff options
context:
space:
mode:
authorarved <arved@FreeBSD.org>2014-11-28 01:29:44 +0800
committerarved <arved@FreeBSD.org>2014-11-28 01:29:44 +0800
commit1ab2c38a97c74f315e13b7b66469691c95c869d9 (patch)
treef3796664abb281ce0672422fd2abea8315bea98c /net-im
parentd8257c52bee693103b8a0e1d7b878a1ac584aad2 (diff)
downloadfreebsd-ports-graphics-1ab2c38a97c74f315e13b7b66469691c95c869d9.tar.gz
freebsd-ports-graphics-1ab2c38a97c74f315e13b7b66469691c95c869d9.tar.zst
freebsd-ports-graphics-1ab2c38a97c74f315e13b7b66469691c95c869d9.zip
Add port py-sleekxmpp, an XMPP library
Diffstat (limited to 'net-im')
-rw-r--r--net-im/Makefile1
-rw-r--r--net-im/py-sleekxmpp/Makefile21
-rw-r--r--net-im/py-sleekxmpp/distinfo2
-rw-r--r--net-im/py-sleekxmpp/pkg-descr5
4 files changed, 29 insertions, 0 deletions
diff --git a/net-im/Makefile b/net-im/Makefile
index f376a2a2e70..6f84012ae51 100644
--- a/net-im/Makefile
+++ b/net-im/Makefile
@@ -124,6 +124,7 @@
SUBDIR += py-punjab
SUBDIR += py-pyxmpp
SUBDIR += py-skype4py
+ SUBDIR += py-sleekxmpp
SUBDIR += py-twistedWords
SUBDIR += py-xmpppy
SUBDIR += py-xmpppy-irc
diff --git a/net-im/py-sleekxmpp/Makefile b/net-im/py-sleekxmpp/Makefile
new file mode 100644
index 00000000000..5488d209809
--- /dev/null
+++ b/net-im/py-sleekxmpp/Makefile
@@ -0,0 +1,21 @@
+# $FreeBSD$
+
+PORTNAME= sleekxmpp
+PORTVERSION= 1.3.1
+CATEGORIES= net-im python
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= arved@FreeBSD.org
+COMMENT= XMPP Library
+
+LICENSE= MIT
+
+USES= python:3.2+
+USE_PYTHON= distutils autoplist
+USE_GITHUB= yes
+GH_ACCOUNT= fritzy
+GH_PROJECT= SleekXMPP
+GH_TAGNAME= 1.3.1
+GH_COMMIT= e558269
+
+.include <bsd.port.mk>
diff --git a/net-im/py-sleekxmpp/distinfo b/net-im/py-sleekxmpp/distinfo
new file mode 100644
index 00000000000..6905f51b6a3
--- /dev/null
+++ b/net-im/py-sleekxmpp/distinfo
@@ -0,0 +1,2 @@
+SHA256 (sleekxmpp-1.3.1.tar.gz) = e5ed93b6c4bc302573396bfc8a8bcbe3bfa6d90eca7d5ace8655843890983f13
+SIZE (sleekxmpp-1.3.1.tar.gz) = 1014109
diff --git a/net-im/py-sleekxmpp/pkg-descr b/net-im/py-sleekxmpp/pkg-descr
new file mode 100644
index 00000000000..4f3a26b5564
--- /dev/null
+++ b/net-im/py-sleekxmpp/pkg-descr
@@ -0,0 +1,5 @@
+SleekXMPP is an MIT licensed XMPP library for Python 2.6/3.1+, and is featured
+in examples in XMPP: The Definitive Guide by Kevin Smith, Remko Troncon, and
+Peter Saint-Andre.
+
+WWW: https://github.com/fritzy/SleekXMPP/