aboutsummaryrefslogtreecommitdiffstats
path: root/net-im
diff options
context:
space:
mode:
authorsem <sem@FreeBSD.org>2005-05-17 02:44:15 +0800
committersem <sem@FreeBSD.org>2005-05-17 02:44:15 +0800
commit297724b6d7ffb8391b6245d1172d754dbcc4eb0e (patch)
tree42deeb1605d1263b450c5d2644a7c80378673683 /net-im
parent795094f75d832904ac5939a81fc5407ee7920899 (diff)
downloadfreebsd-ports-graphics-297724b6d7ffb8391b6245d1172d754dbcc4eb0e.tar.gz
freebsd-ports-graphics-297724b6d7ffb8391b6245d1172d754dbcc4eb0e.tar.zst
freebsd-ports-graphics-297724b6d7ffb8391b6245d1172d754dbcc4eb0e.zip
- Add support of kde tray icon.
PR: ports/81016 Submitted by: maintainer Tahnks to: Andrej Zverev <az@inec.ru> (testing and bug reports)
Diffstat (limited to 'net-im')
-rw-r--r--net-im/psi/Makefile32
-rw-r--r--net-im/psi/pkg-plist15
2 files changed, 44 insertions, 3 deletions
diff --git a/net-im/psi/Makefile b/net-im/psi/Makefile
index da3d3c81a4f..3408aac1b0f 100644
--- a/net-im/psi/Makefile
+++ b/net-im/psi/Makefile
@@ -7,7 +7,7 @@
PORTNAME= psi
PORTVERSION= 0.9.3
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -26,13 +26,39 @@ USE_QT_VER= 3
CONFIGURE_ENV= QMAKESPEC=${LOCALBASE}/share/qt/mkspecs/freebsd-g++ \
PTHREAD_CFLAGS=${PTHREAD_CFLAGS} \
- PTHREAD_LDFLAGS=${PTHREAD_LIBS}
-CONFIGURE_ARGS= --prefix=${PREFIX} --qtdir=${X11BASE} --disable-kde \
+ PTHREAD_LDFLAGS=${PTHREAD_LIBS} \
+ KDEDIR=${LOCALBASE}
+CONFIGURE_ARGS= --prefix=${PREFIX} --qtdir=${X11BASE} \
--with-qca-inc=${X11BASE}/include/plugins/qca \
--with-qca-lib=${X11BASE}/lib
MAKE_ARGS+= QTDIR=${X11BASE} \
QMAKESPEC=${LOCALBASE}/share/qt/mkspecs/freebsd-g++
+.if defined(WITH_KDE)
+LIB_DEPENDS= kdecore:${PORTSDIR}/x11/kdelibs3
+_NO_KDE_CONFTARGET_HACK= yes
+PLIST_SUB+= KDE=""
+.else
+CONFIGURE_ARGS+= --disable-kde
+PLIST_SUB+= KDE="@comment "
+.endif
+
+pre-everything::
+ @${ECHO} "============================================================="
+ @${ECHO}
+ @${ECHO} "You can build ${PKGNAME} with the following options:"
+ @${ECHO}
+ @${ECHO} "WITH_KDE enable kde tray support"
+ @${ECHO}
+ @${ECHO} "============================================================="
+
+pre-install:
+.if defined(WITH_KDE)
+ @for size in 16x16 32x32 48x48; do \
+ ${MKDIR} ${LOCALBASE}/share/icons/hicolor/${size}/apps; \
+ done
+.endif
+
post-install:
${STRIP_CMD} ${PREFIX}/bin/psi
diff --git a/net-im/psi/pkg-plist b/net-im/psi/pkg-plist
index 84c2d1fb03b..60429303ce7 100644
--- a/net-im/psi/pkg-plist
+++ b/net-im/psi/pkg-plist
@@ -241,3 +241,18 @@ bin/psi
@dirrm %%DATADIR%%/designer
@dirrm %%DATADIR%%/certs
@dirrm %%DATADIR%%
+%%KDE%%@cwd %%LOCALBASE%%
+%%KDE%%share/applnk/Internet/psi.desktop
+%%KDE%%share/icons/hicolor/16x16/apps/psi.png
+%%KDE%%share/icons/hicolor/32x32/apps/psi.png
+%%KDE%%share/icons/hicolor/48x48/apps/psi.png
+%%KDE%%@unexec rmdir %D/share/applnk/Internet 2>/dev/null || true
+%%KDE%%@unexec rmdir %D/share/applnk 2>/dev/null || true
+%%KDE%%@unexec rmdir %D/share/icons/hicolor/16x16/apps 2>/dev/null || true
+%%KDE%%@unexec rmdir %D/share/icons/hicolor/16x16 2>/dev/null || true
+%%KDE%%@unexec rmdir %D/share/icons/hicolor/32x32/apps 2>/dev/null || true
+%%KDE%%@unexec rmdir %D/share/icons/hicolor/32x32 2>/dev/null || true
+%%KDE%%@unexec rmdir %D/share/icons/hicolor/48x48/apps 2>/dev/null || true
+%%KDE%%@unexec rmdir %D/share/icons/hicolor/48x48 2>/dev/null || true
+%%KDE%%@unexec rmdir %D/share/icons/hicolor 2>/dev/null || true
+%%KDE%%@unexec rmdir %D/share/icons 2>/dev/null || true