aboutsummaryrefslogtreecommitdiffstats
path: root/net-im
diff options
context:
space:
mode:
authoravilla <avilla@FreeBSD.org>2012-01-15 09:41:45 +0800
committeravilla <avilla@FreeBSD.org>2012-01-15 09:41:45 +0800
commita11250756d537d97cb3e05cf53c21225b5db6282 (patch)
tree5bcea5a7f2fdf7ae5f6f4ec6d838ed8c4df81b8a /net-im
parent99bfa25eadd38d407cc0a13fabbcfbf07ccd924d (diff)
downloadfreebsd-ports-graphics-a11250756d537d97cb3e05cf53c21225b5db6282.tar.gz
freebsd-ports-graphics-a11250756d537d97cb3e05cf53c21225b5db6282.tar.zst
freebsd-ports-graphics-a11250756d537d97cb3e05cf53c21225b5db6282.zip
- Fix build with Clang solving an ambiguity with parenthesis.
Diffstat (limited to 'net-im')
-rw-r--r--net-im/telepathy-qt4/Makefile2
-rw-r--r--net-im/telepathy-qt4/files/patch-TelepathyQt4__optional-interface-factory.h20
2 files changed, 21 insertions, 1 deletions
diff --git a/net-im/telepathy-qt4/Makefile b/net-im/telepathy-qt4/Makefile
index e1761cdda21..52c0ea698be 100644
--- a/net-im/telepathy-qt4/Makefile
+++ b/net-im/telepathy-qt4/Makefile
@@ -24,8 +24,8 @@ USE_PYTHON_BUILD= 2.5+
USE_QT_VER= 4
QT_COMPONENTS= dbus gui network qtestlib_build xml \
moc_build qmake_build rcc_build uic_build
-MAKE_JOBS_SAFE= yes
USE_CMAKE= yes
+MAKE_JOBS_SAFE= yes
USE_LDCONFIG= yes
PORTDOCS= AUTHORS ChangeLog HACKING NEWS README html
diff --git a/net-im/telepathy-qt4/files/patch-TelepathyQt4__optional-interface-factory.h b/net-im/telepathy-qt4/files/patch-TelepathyQt4__optional-interface-factory.h
new file mode 100644
index 00000000000..e45a9fc0d3d
--- /dev/null
+++ b/net-im/telepathy-qt4/files/patch-TelepathyQt4__optional-interface-factory.h
@@ -0,0 +1,20 @@
+--- ./TelepathyQt4/optional-interface-factory.h.orig 2012-01-13 15:03:15.336883448 +0100
++++ ./TelepathyQt4/optional-interface-factory.h 2012-01-13 15:03:58.296892805 +0100
+@@ -97,7 +97,7 @@
+ InterfaceSupportedChecking check = CheckInterfaceSupported) const
+ {
+ // Check for the remote object supporting the interface
+- QString name(QLatin1String(Interface::staticInterfaceName()));
++ QString name( (QLatin1String(Interface::staticInterfaceName())) );
+ if (check == CheckInterfaceSupported && !mInterfaces.contains(name)) {
+ return 0;
+ }
+@@ -113,7 +113,7 @@
+ Q_UNUSED(interfaceMustBeASubclassOfAbstractInterface);
+
+ // If there is a interface cached already, return it
+- QString name(QLatin1String(Interface::staticInterfaceName()));
++ QString name( (QLatin1String(Interface::staticInterfaceName())) );
+ AbstractInterface *cached = getCached(name);
+ if (cached)
+ return static_cast<Interface *>(cached);