aboutsummaryrefslogtreecommitdiffstats
path: root/net-im
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2009-02-28 13:13:58 +0800
committermarcus <marcus@FreeBSD.org>2009-02-28 13:13:58 +0800
commitbb8aac2119fc8558f759ad414e17f27941e08888 (patch)
tree1c5f7f526c1e5e1d6df53a6791e0ba58cd028ff3 /net-im
parentc321624463c5d8883efee4548b2a531115e5e506 (diff)
downloadfreebsd-ports-graphics-bb8aac2119fc8558f759ad414e17f27941e08888.tar.gz
freebsd-ports-graphics-bb8aac2119fc8558f759ad414e17f27941e08888.tar.zst
freebsd-ports-graphics-bb8aac2119fc8558f759ad414e17f27941e08888.zip
Add telepathy-farsight, a video conferencing connection manager for the
Telepathy framework. Install this package to use Telepathy instant messaging clients with Farsight/Nice servers.
Diffstat (limited to 'net-im')
-rw-r--r--net-im/Makefile1
-rw-r--r--net-im/telepathy-farsight/Makefile33
-rw-r--r--net-im/telepathy-farsight/distinfo3
-rw-r--r--net-im/telepathy-farsight/files/patch-telepathy-farsight_Makefile.in11
-rw-r--r--net-im/telepathy-farsight/pkg-descr5
-rw-r--r--net-im/telepathy-farsight/pkg-plist26
6 files changed, 79 insertions, 0 deletions
diff --git a/net-im/Makefile b/net-im/Makefile
index dd281fbb448..a95766dcc1b 100644
--- a/net-im/Makefile
+++ b/net-im/Makefile
@@ -136,6 +136,7 @@
SUBDIR += sim-im-devel
SUBDIR += tapioca-qt
SUBDIR += telepathy-butterfly
+ SUBDIR += telepathy-farsight
SUBDIR += telepathy-gabble
SUBDIR += telepathy-glib
SUBDIR += telepathy-haze
diff --git a/net-im/telepathy-farsight/Makefile b/net-im/telepathy-farsight/Makefile
new file mode 100644
index 00000000000..feb27972bd1
--- /dev/null
+++ b/net-im/telepathy-farsight/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: telepathy-farsight
+# Date created: 27 February 2009
+# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= telepathy-farsight
+PORTVERSION= 0.0.4
+CATEGORIES= net-im
+MASTER_SITES= http://telepathy.freedesktop.org/releases/${PORTNAME}/
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= Farsight Connection Manager for Telepathy Framework
+
+LIB_PC_DEPENDS= gobject-2.0.pc:${PORTSDIR}/devel/glib20 \
+ dbus-glib-1.pc:${PORTSDIR}/devel/dbus-glib \
+ telepathy-glib.pc:${PORTSDIR}/net-im/telepathy-glib \
+ farsight2-0.10.pc:${PORTSDIR}/net-im/farsight2
+
+BUILD_DEPENDS= xsltproc:${PORTSDIR}/textproc/libxslt
+
+BUILD_DEPENDS+= ${LIB_PC_DEPENDS:C|^|${LOCALBASE}/libdata/pkgconfig/|g}
+RUN_DEPENDS+= ${LIB_PC_DEPENDS:C|^|${LOCALBASE}/libdata/pkgconfig/|g}
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_PYTHON= yes
+USE_GNOME= gnomehack pkgconfig glib20
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
+
+.include <bsd.port.mk>
diff --git a/net-im/telepathy-farsight/distinfo b/net-im/telepathy-farsight/distinfo
new file mode 100644
index 00000000000..59c3148d8d6
--- /dev/null
+++ b/net-im/telepathy-farsight/distinfo
@@ -0,0 +1,3 @@
+MD5 (telepathy-farsight-0.0.4.tar.gz) = 2862c3c07d150485b22b2614391c36e2
+SHA256 (telepathy-farsight-0.0.4.tar.gz) = 4fc1b56648449f8aad72df347947672771007263b2a2f5ee0b8485eedf13c8e5
+SIZE (telepathy-farsight-0.0.4.tar.gz) = 571617
diff --git a/net-im/telepathy-farsight/files/patch-telepathy-farsight_Makefile.in b/net-im/telepathy-farsight/files/patch-telepathy-farsight_Makefile.in
new file mode 100644
index 00000000000..1215ad50b91
--- /dev/null
+++ b/net-im/telepathy-farsight/files/patch-telepathy-farsight_Makefile.in
@@ -0,0 +1,11 @@
+--- telepathy-farsight/Makefile.in.orig 2009-02-28 00:03:16.000000000 -0500
++++ telepathy-farsight/Makefile.in 2009-02-28 00:03:37.000000000 -0500
+@@ -250,7 +250,7 @@ libtelepathy_farsight_la_SOURCES = \
+
+ nodist_libtelepathy_farsight_la_SOURCES = $(BUILT_SOURCES)
+ lib_LTLIBRARIES = libtelepathy-farsight.la
+-pkgconfigdir = ${libdir}/pkgconfig
++pkgconfigdir = $(prefix)/libdata/pkgconfig
+ pkgconfig_DATA = telepathy-farsight.pc
+ AM_CFLAGS = \
+ $(ERROR_CFLAGS) \
diff --git a/net-im/telepathy-farsight/pkg-descr b/net-im/telepathy-farsight/pkg-descr
new file mode 100644
index 00000000000..b4674f36484
--- /dev/null
+++ b/net-im/telepathy-farsight/pkg-descr
@@ -0,0 +1,5 @@
+Farsight is a video conferencing connection manager for the Telepathy
+framework. Install this package to use Telepathy instant messaging clients
+with Farsight/Nice servers.
+
+WWW: http://telepathy.freedesktop.org/
diff --git a/net-im/telepathy-farsight/pkg-plist b/net-im/telepathy-farsight/pkg-plist
new file mode 100644
index 00000000000..0c5f246bd13
--- /dev/null
+++ b/net-im/telepathy-farsight/pkg-plist
@@ -0,0 +1,26 @@
+include/telepathy-1.0/telepathy-farsight/channel.h
+include/telepathy-1.0/telepathy-farsight/stream.h
+lib/libtelepathy-farsight.a
+lib/libtelepathy-farsight.la
+lib/libtelepathy-farsight.so
+lib/libtelepathy-farsight.so.0
+%%PYTHON_SITELIBDIR%%/tpfarsight.a
+%%PYTHON_SITELIBDIR%%/tpfarsight.la
+%%PYTHON_SITELIBDIR%%/tpfarsight.so
+libdata/pkgconfig/telepathy-farsight.pc
+share/gtk-doc/html/telepathy-farsight/TfChannel.html
+share/gtk-doc/html/telepathy-farsight/TfStream.html
+share/gtk-doc/html/telepathy-farsight/ch01.html
+share/gtk-doc/html/telepathy-farsight/home.png
+share/gtk-doc/html/telepathy-farsight/index.html
+share/gtk-doc/html/telepathy-farsight/index.sgml
+share/gtk-doc/html/telepathy-farsight/left.png
+share/gtk-doc/html/telepathy-farsight/right.png
+share/gtk-doc/html/telepathy-farsight/style.css
+share/gtk-doc/html/telepathy-farsight/telepathy-farsight.devhelp
+share/gtk-doc/html/telepathy-farsight/telepathy-farsight.devhelp2
+share/gtk-doc/html/telepathy-farsight/up.png
+@dirrm share/gtk-doc/html/telepathy-farsight
+@dirrmtry share/gtk-doc/html
+@dirrmtry share/gtk-doc
+@dirrm include/telepathy-1.0/telepathy-farsight