aboutsummaryrefslogtreecommitdiffstats
path: root/net-im
diff options
context:
space:
mode:
authornovel <novel@FreeBSD.org>2005-08-08 02:40:50 +0800
committernovel <novel@FreeBSD.org>2005-08-08 02:40:50 +0800
commitbc4bdae2d0139a6d0cd746ddf14a3340797711b3 (patch)
tree8f03e055deafe78abce43a1232946500980feff0 /net-im
parent449f14181ae00f803e201ffc086430c7b8a60032 (diff)
downloadfreebsd-ports-graphics-bc4bdae2d0139a6d0cd746ddf14a3340797711b3.tar.gz
freebsd-ports-graphics-bc4bdae2d0139a6d0cd746ddf14a3340797711b3.tar.zst
freebsd-ports-graphics-bc4bdae2d0139a6d0cd746ddf14a3340797711b3.zip
Fix plist.
Reported by: pointyhat via krion Approved by: portmgr (krion)
Diffstat (limited to 'net-im')
-rw-r--r--net-im/gaim-ignorance/Makefile19
-rw-r--r--net-im/gaim-ignorance/pkg-plist7
2 files changed, 20 insertions, 6 deletions
diff --git a/net-im/gaim-ignorance/Makefile b/net-im/gaim-ignorance/Makefile
index 94d027822da..6072b49f4be 100644
--- a/net-im/gaim-ignorance/Makefile
+++ b/net-im/gaim-ignorance/Makefile
@@ -7,6 +7,7 @@
PORTNAME= ignorance
PORTVERSION= 1.3.1.2
+PORTREVISION= 1
CATEGORIES= misc
MASTER_SITES= http://bard.sytes.net/ignorance/
PKGNAMEPREFIX= gaim-
@@ -23,8 +24,7 @@ USE_LIBTOOL_VER=15
USE_REINPLACE= yes
EXAMPLESDIR_REL=${EXAMPLESDIR:S,^${PREFIX}/,,}
-PLIST_FILES= lib/gaim/ignorance.so ${EXAMPLESDIR_REL}/ignorance
-PLIST_DIRS= ${EXAMPLESDIR_REL}
+PLIST_SUB= EXAMPLESDIR_REL=${EXAMPLESDIR_REL}
SUB_FILES= pkg-message
@@ -32,16 +32,23 @@ SUB_FILES= pkg-message
PORTDOCS= README
.endif
+post-extract:
+ @${REINPLACE_CMD} -e "s/ignorance.conf/ignorance.conf.sample/g" ${WRKSRC}/Makefile.in
+ @${MV} ${WRKSRC}/ignorance.conf ${WRKSRC}/ignorance.conf.sample
+
post-patch:
@${REINPLACE_CMD} -e 's|-g3||' ${WRKSRC}/configure
post-install:
- ${MKDIR} ${EXAMPLESDIR}
- ${INSTALL_DATA} ${WRKSRC}/ignorance ${EXAMPLESDIR}
+ @${MKDIR} ${EXAMPLESDIR}
+ @${INSTALL_DATA} ${WRKSRC}/ignorance ${EXAMPLESDIR}
.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
.endif
@${CAT} ${PKGMESSAGE}
+ @if ${TEST} ! -f ${PREFIX}/etc/gaim/ignorance.conf; then \
+ ${CP} ${PREFIX}/etc/gaim/ignorance.conf.sample ${PREFIX}/etc/gaim/ignorance.conf; \
+ fi
.include <bsd.port.mk>
diff --git a/net-im/gaim-ignorance/pkg-plist b/net-im/gaim-ignorance/pkg-plist
new file mode 100644
index 00000000000..dcf245b54fe
--- /dev/null
+++ b/net-im/gaim-ignorance/pkg-plist
@@ -0,0 +1,7 @@
+@comment $FreeBSD$
+lib/gaim/ignorance.so
+%%EXAMPLESDIR_REL%%/ignorance
+@unexec if cmp -s %D/etc/gaim/ignorance.conf %D/etc/gaim/ignorance.conf.sample; then rm -f %D/etc/gaim/ignorance.conf;fi
+etc/gaim/ignorance.conf.sample
+@dirrm %%EXAMPLESDIR_REL%%
+@unexec rmdir %D/etc/gaim/ 2>/dev/null || true