aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt/bandwidthd/Makefile
diff options
context:
space:
mode:
authorkrion <krion@FreeBSD.org>2003-11-06 17:15:28 +0800
committerkrion <krion@FreeBSD.org>2003-11-06 17:15:28 +0800
commit7b70435edd5051214fd61d7873c9b7391bb7d8dd (patch)
tree83788bc50b738e79733d3f0faa5348ce47523bb6 /net-mgmt/bandwidthd/Makefile
parentbc0064c44428f240862a693428c832b6e9018038 (diff)
downloadfreebsd-ports-graphics-7b70435edd5051214fd61d7873c9b7391bb7d8dd.tar.gz
freebsd-ports-graphics-7b70435edd5051214fd61d7873c9b7391bb7d8dd.tar.zst
freebsd-ports-graphics-7b70435edd5051214fd61d7873c9b7391bb7d8dd.zip
bandwidthd tracks usage of TCP/IP network subnets and
builds HTML files with graphs to display network utilization. Charts are built by individual IP. It color codes HTTP, TCP, UDP, ICMP, VPN, and P2P traffic. Unlike MRTG, it tracks each individual IP address, not the status of any particular link. PR: 58830 Submitted by: Clement Laforet <sheepkiller@cultdeadsheep.org>
Diffstat (limited to 'net-mgmt/bandwidthd/Makefile')
-rw-r--r--net-mgmt/bandwidthd/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/net-mgmt/bandwidthd/Makefile b/net-mgmt/bandwidthd/Makefile
new file mode 100644
index 00000000000..5108087e720
--- /dev/null
+++ b/net-mgmt/bandwidthd/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: bandwidthd
+# Date created: Sun Nov 2
+# Whom: Clement Laforet <sheepkiller@cultdeadsheep.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= bandwidthd
+PORTVERSION= 1.1.5
+CATEGORIES= net
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= sheepkiller@cultdeadsheep.org
+COMMENT= Tracks bandwidth usage by IP address
+
+LIB_DEPENDS+= gd.4:${PORTSDIR}/graphics/gd
+
+USE_GMAKE= YES
+USE_REINPLACE= YES
+CFLAGS+= -DFREEBSD -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+MAKE_ENV+= LDFLAGS="${LDFLAGS}"
+
+post-patch:
+ @${REINPLACE_CMD} -e 's!localtime(!localtime((time_t *)!' ${WRKSRC}/graph.c
+
+post-install:
+ @${INSTALL_SCRIPT} ${FILESDIR}/bandwidthd.sh \
+ ${PREFIX}/etc/rc.d/bandwidthd.sh.sample
+
+.include <bsd.port.mk>