aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt
diff options
context:
space:
mode:
authorcrees <crees@FreeBSD.org>2011-08-26 18:58:07 +0800
committercrees <crees@FreeBSD.org>2011-08-26 18:58:07 +0800
commit1adcbc92d7572235a50a5145438666be44b7cd76 (patch)
treeccad57fcff5efdde5126a721e07f1a2a65379a09 /net-mgmt
parentd676fdd5f443d9369fbe21ba391dba596c15fdbd (diff)
downloadfreebsd-ports-graphics-1adcbc92d7572235a50a5145438666be44b7cd76.tar.gz
freebsd-ports-graphics-1adcbc92d7572235a50a5145438666be44b7cd76.tar.zst
freebsd-ports-graphics-1adcbc92d7572235a50a5145438666be44b7cd76.zip
This is a PERL interface to the Zenoss Monitoring System
JSON API. It allows the ability to execute all available functions provided by the Zenoss API programmatically. Anything you could do from the Zenoss interface can be achieved via this module. This is a full service implementation, providing the construction of the call to the API and the handling of the response. WWW: http://search.cpan.org/dist/Zenoss/ PR: ports/160193 Submitted by: Phil Phillips
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/Makefile1
-rw-r--r--net-mgmt/p5-Zenoss/Makefile44
-rw-r--r--net-mgmt/p5-Zenoss/distinfo2
-rw-r--r--net-mgmt/p5-Zenoss/pkg-descr8
-rw-r--r--net-mgmt/p5-Zenoss/pkg-plist24
5 files changed, 79 insertions, 0 deletions
diff --git a/net-mgmt/Makefile b/net-mgmt/Makefile
index c97995a7a74..afa7e78358d 100644
--- a/net-mgmt/Makefile
+++ b/net-mgmt/Makefile
@@ -222,6 +222,7 @@
SUBDIR += p5-SNMP_Session
SUBDIR += p5-Telnet-Cisco
SUBDIR += p5-Tie-NetAddr-IP
+ SUBDIR += p5-Zenoss
SUBDIR += packit
SUBDIR += pads
SUBDIR += pancho
diff --git a/net-mgmt/p5-Zenoss/Makefile b/net-mgmt/p5-Zenoss/Makefile
new file mode 100644
index 00000000000..b06c0f6c14d
--- /dev/null
+++ b/net-mgmt/p5-Zenoss/Makefile
@@ -0,0 +1,44 @@
+# New ports collection makefile for: p5-Zenoss
+# Date created: 25 August 2011
+# Whom: Phil Phillips
+#
+# $FreeBSD$
+#
+
+PORTNAME= Zenoss
+PORTVERSION= 1.10
+CATEGORIES= net-mgmt perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= pphillips@experts-exchange.com
+COMMENT= Perl interface to the Zenoss JSON API
+
+RUN_DEPENDS= p5-Moose>=1.0:${PORTSDIR}/devel/p5-Moose \
+ p5-JSON>=2.0:${PORTSDIR}/converters/p5-JSON \
+ p5-libwww>=5.0:${PORTSDIR}/www/p5-libwww
+
+PERL_CONFIGURE= yes
+
+MAN3= Zenoss::Examples.3 \
+ Zenoss.3 \
+ Zenoss::Router::Network.3 \
+ Zenoss::Router::Search.3 \
+ Zenoss::Router::DetailNav.3 \
+ Zenoss::Router::Template.3 \
+ Zenoss::Router::Process.3 \
+ Zenoss::Connector.3 \
+ Zenoss::Router::Report.3 \
+ Zenoss::MetaHelper.3 \
+ Zenoss::Router::ZenPack.3 \
+ Zenoss::Router::Tree.3 \
+ Zenoss::Router.3 \
+ Zenoss::Router::Messaging.3 \
+ Zenoss::Router::Events.3 \
+ Zenoss::Router::Service.3 \
+ Zenoss::Router::Device.3 \
+ Zenoss::Response.3 \
+ Zenoss::Error.3 \
+ Zenoss::Router::Mib.3
+
+.include <bsd.port.mk>
diff --git a/net-mgmt/p5-Zenoss/distinfo b/net-mgmt/p5-Zenoss/distinfo
new file mode 100644
index 00000000000..d72c3eb06f7
--- /dev/null
+++ b/net-mgmt/p5-Zenoss/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Zenoss-1.10.tar.gz) = 976a52550fa78fa847d0b02432afe932d63a425a021f23e888a37491ab3b1f81
+SIZE (Zenoss-1.10.tar.gz) = 32830
diff --git a/net-mgmt/p5-Zenoss/pkg-descr b/net-mgmt/p5-Zenoss/pkg-descr
new file mode 100644
index 00000000000..56a8a1748d0
--- /dev/null
+++ b/net-mgmt/p5-Zenoss/pkg-descr
@@ -0,0 +1,8 @@
+This is a PERL interface to the Zenoss Monitoring System
+JSON API. It allows the ability to execute all available functions
+provided by the Zenoss API programmatically. Anything you could do from
+the Zenoss interface can be achieved via this module. This is a
+full service implementation, providing the construction of the call
+to the API and the handling of the response.
+
+WWW: http://search.cpan.org/dist/Zenoss/
diff --git a/net-mgmt/p5-Zenoss/pkg-plist b/net-mgmt/p5-Zenoss/pkg-plist
new file mode 100644
index 00000000000..bb936779403
--- /dev/null
+++ b/net-mgmt/p5-Zenoss/pkg-plist
@@ -0,0 +1,24 @@
+%%SITE_PERL%%/Zenoss.pm
+%%SITE_PERL%%/Zenoss/Connector.pm
+%%SITE_PERL%%/Zenoss/Error.pm
+%%SITE_PERL%%/Zenoss/Examples.pod
+%%SITE_PERL%%/Zenoss/MetaHelper.pm
+%%SITE_PERL%%/Zenoss/Response.pm
+%%SITE_PERL%%/Zenoss/Router.pm
+%%SITE_PERL%%/Zenoss/Router/DetailNav.pm
+%%SITE_PERL%%/Zenoss/Router/Device.pm
+%%SITE_PERL%%/Zenoss/Router/Events.pm
+%%SITE_PERL%%/Zenoss/Router/Messaging.pm
+%%SITE_PERL%%/Zenoss/Router/Mib.pm
+%%SITE_PERL%%/Zenoss/Router/Network.pm
+%%SITE_PERL%%/Zenoss/Router/Process.pm
+%%SITE_PERL%%/Zenoss/Router/Report.pm
+%%SITE_PERL%%/Zenoss/Router/Search.pm
+%%SITE_PERL%%/Zenoss/Router/Service.pm
+%%SITE_PERL%%/Zenoss/Router/Template.pm
+%%SITE_PERL%%/Zenoss/Router/Tree.pm
+%%SITE_PERL%%/Zenoss/Router/ZenPack.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Zenoss/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Zenoss
+@dirrm %%SITE_PERL%%/Zenoss/Router
+@dirrm %%SITE_PERL%%/Zenoss