aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt
diff options
context:
space:
mode:
authorstefan <stefan@FreeBSD.org>2010-07-01 03:43:40 +0800
committerstefan <stefan@FreeBSD.org>2010-07-01 03:43:40 +0800
commit272e382777a39ba325dd288ff4ba0d67ce135fd0 (patch)
treecc163faa8b8f9820748f6f18512c607e070b55c0 /net-mgmt
parenta7f1c938d8912b081aec42bf883b6a10c9df94aa (diff)
downloadfreebsd-ports-graphics-272e382777a39ba325dd288ff4ba0d67ce135fd0.tar.gz
freebsd-ports-graphics-272e382777a39ba325dd288ff4ba0d67ce135fd0.tar.zst
freebsd-ports-graphics-272e382777a39ba325dd288ff4ba0d67ce135fd0.zip
Add optional IPMI support.
PR: 146581 Submitted by: Alex Deiter <alex.deiter@gmail.com> Approved by: maintainer Feature safe: yes
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/zabbix-server/Makefile6
-rw-r--r--net-mgmt/zabbix2-server/Makefile6
2 files changed, 12 insertions, 0 deletions
diff --git a/net-mgmt/zabbix-server/Makefile b/net-mgmt/zabbix-server/Makefile
index 6f7832e8853..f9c1ad5f84c 100644
--- a/net-mgmt/zabbix-server/Makefile
+++ b/net-mgmt/zabbix-server/Makefile
@@ -60,6 +60,7 @@ OPTIONS= MYSQL "Use MySQL backend" on \
SQLITE "Use SQLite backend" off \
IPV6 "Support for IPv6" on \
LDAP "Support for checking LDAP servers" on \
+ IPMI "Support for IPMI" off \
JABBER "Use jabber media type" on \
FPING "Use fping for pinging hosts" on \
SSH "Use libssh2 for SSH-based checks" off
@@ -87,6 +88,11 @@ USE_OPENLDAP= yes
CONFIGURE_ARGS+= --with-ldap
.endif
+.ifdef WITH_IPMI
+LIB_DEPENDS+= OpenIPMI:${PORTSDIR}/sysutils/openipmi
+CONFIGURE_ARGS+= --with-openipmi
+.endif
+
.ifndef WITHOUT_JABBER
LIB_DEPENDS+= iksemel:${PORTSDIR}/textproc/iksemel
CONFIGURE_ARGS+= --with-jabber
diff --git a/net-mgmt/zabbix2-server/Makefile b/net-mgmt/zabbix2-server/Makefile
index 6f7832e8853..f9c1ad5f84c 100644
--- a/net-mgmt/zabbix2-server/Makefile
+++ b/net-mgmt/zabbix2-server/Makefile
@@ -60,6 +60,7 @@ OPTIONS= MYSQL "Use MySQL backend" on \
SQLITE "Use SQLite backend" off \
IPV6 "Support for IPv6" on \
LDAP "Support for checking LDAP servers" on \
+ IPMI "Support for IPMI" off \
JABBER "Use jabber media type" on \
FPING "Use fping for pinging hosts" on \
SSH "Use libssh2 for SSH-based checks" off
@@ -87,6 +88,11 @@ USE_OPENLDAP= yes
CONFIGURE_ARGS+= --with-ldap
.endif
+.ifdef WITH_IPMI
+LIB_DEPENDS+= OpenIPMI:${PORTSDIR}/sysutils/openipmi
+CONFIGURE_ARGS+= --with-openipmi
+.endif
+
.ifndef WITHOUT_JABBER
LIB_DEPENDS+= iksemel:${PORTSDIR}/textproc/iksemel
CONFIGURE_ARGS+= --with-jabber