aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt
diff options
context:
space:
mode:
authorrafan <rafan@FreeBSD.org>2007-10-08 12:14:54 +0800
committerrafan <rafan@FreeBSD.org>2007-10-08 12:14:54 +0800
commit4a4838b8360b5a6fc1bd295fca88a6b77e4471b5 (patch)
treee96e7ed5e31fafaaea606b03175bc635f25301bb /net-mgmt
parentf03186100847bc3a3e050355fe0fc0755ab53b90 (diff)
downloadfreebsd-ports-graphics-4a4838b8360b5a6fc1bd295fca88a6b77e4471b5.tar.gz
freebsd-ports-graphics-4a4838b8360b5a6fc1bd295fca88a6b77e4471b5.tar.zst
freebsd-ports-graphics-4a4838b8360b5a6fc1bd295fca88a6b77e4471b5.zip
- When libexecdir does not exist, the installed perl based plugins gets wrong
use lib directive. This is due to the installation procedure assumes the existence of libexecdir. Fix this problem and bump PORTREVISION. PR: ports/115443 Reported by: Stefan Kaltenbrunner <stefan at kaltenbrunner.cc> Patched by: Jarrod Sayers <jarrod at netleader.com.au> (maintainer)
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/nagios-plugins/Makefile2
-rw-r--r--net-mgmt/nagios-plugins/files/patch-plugins-scripts__subst.in11
2 files changed, 12 insertions, 1 deletions
diff --git a/net-mgmt/nagios-plugins/Makefile b/net-mgmt/nagios-plugins/Makefile
index ab8b847f1bc..4be6e3ca375 100644
--- a/net-mgmt/nagios-plugins/Makefile
+++ b/net-mgmt/nagios-plugins/Makefile
@@ -7,7 +7,7 @@
PORTNAME= nagios-plugins
PORTVERSION= 1.4.9
-PORTREVISION= 2
+PORTREVISION= 3
PORTEPOCH= 1
CATEGORIES= net-mgmt
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED}
diff --git a/net-mgmt/nagios-plugins/files/patch-plugins-scripts__subst.in b/net-mgmt/nagios-plugins/files/patch-plugins-scripts__subst.in
new file mode 100644
index 00000000000..35b676b9520
--- /dev/null
+++ b/net-mgmt/nagios-plugins/files/patch-plugins-scripts__subst.in
@@ -0,0 +1,11 @@
+--- plugins-scripts/subst.in.orig Wed Aug 31 07:41:42 2005
++++ plugins-scripts/subst.in Sun Sep 30 18:16:42 2007
+@@ -1,7 +1,7 @@
+ #!/usr/bin/awk
+
+ function which(c,path) {
+- cmd = "test -x " c;
++ cmd = "[ " c " = @libexecdir@ ] || test -x " c;
+
+ if (system(cmd)==0) {
+ return c;