aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2008-04-11 23:20:52 +0800
committermiwi <miwi@FreeBSD.org>2008-04-11 23:20:52 +0800
commit557351ff1da53e4e2fc8e9a0278b4eb2dd500aea (patch)
tree2fefd4a87616f864e98e334c521afcede7da87d0 /net-mgmt
parentfa360c3e6ba2c335b84e7fea56268c42f1dd3922 (diff)
downloadfreebsd-ports-graphics-557351ff1da53e4e2fc8e9a0278b4eb2dd500aea.tar.gz
freebsd-ports-graphics-557351ff1da53e4e2fc8e9a0278b4eb2dd500aea.tar.zst
freebsd-ports-graphics-557351ff1da53e4e2fc8e9a0278b4eb2dd500aea.zip
- Unbreak
- Fix build with gcc 4.2 Submitted by: gahr
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/cflowd/Makefile4
-rw-r--r--net-mgmt/cflowd/files/patch-classes_include_CflowdAsMatrix.hh21
-rw-r--r--net-mgmt/cflowd/files/patch-snmp++-classes-include-snmp++_notifyqueue.h13
3 files changed, 20 insertions, 18 deletions
diff --git a/net-mgmt/cflowd/Makefile b/net-mgmt/cflowd/Makefile
index 2b09c341349..5b6ccd64574 100644
--- a/net-mgmt/cflowd/Makefile
+++ b/net-mgmt/cflowd/Makefile
@@ -37,10 +37,6 @@ PATCH_SITES+= http://net.doit.wisc.edu/~plonka/cflowd/
PATCHFILES+= cflowd-${PORTVERSION:S|.|-|g}-djp.patch
.endif
-.if ${OSVERSION} >= 700042
-BROKEN= Does not compile
-.endif
-
post-extract:
${CHMOD} -R u+w ${WRKSRC}
diff --git a/net-mgmt/cflowd/files/patch-classes_include_CflowdAsMatrix.hh b/net-mgmt/cflowd/files/patch-classes_include_CflowdAsMatrix.hh
index a99d0dcd6aa..df1c42426a8 100644
--- a/net-mgmt/cflowd/files/patch-classes_include_CflowdAsMatrix.hh
+++ b/net-mgmt/cflowd/files/patch-classes_include_CflowdAsMatrix.hh
@@ -1,24 +1,17 @@
---- ./classes/include/CflowdAsMatrix.hh.orig Mon Sep 21 18:31:43 1998
-+++ ./classes/include/CflowdAsMatrix.hh Mon Apr 9 14:02:43 2007
-@@ -55,7 +55,7 @@
+--- classes/include/CflowdAsMatrix.hh.orig 2008-04-08 21:29:31.000000000 +0200
++++ classes/include/CflowdAsMatrix.hh 2008-04-08 21:31:22.000000000 +0200
+@@ -55,7 +55,9 @@
#include "CflowdAsMatrixTrafficCounter.hh"
#include "CflowdRawFlow.hh"
-typedef map<CflowdAsMatrixKey, CflowdAsMatrixTrafficCounter, less<CflowdAsMatrixKey> > CflowdAsMatrixMap_t;
++class iterator;
++
+typedef std::map<CflowdAsMatrixKey, CflowdAsMatrixTrafficCounter, std::less<CflowdAsMatrixKey> > CflowdAsMatrixMap_t;
//---------------------------------------------------------------------------
// class CflowdAsMatrix : public CflowdAsMatrixMap_t
-@@ -70,7 +70,7 @@
- class CflowdAsMatrix : public CflowdAsMatrixMap_t
- {
- public:
-- typedef CflowdAsMatrixMap_t::iterator iterator;
-+ typedef CflowdAsMatrixMap_t::iterator std::iterator;
- typedef CflowdAsMatrixMap_t::const_iterator const_iterator;
-
- //-------------------------------------------------------------------------
-@@ -87,7 +87,7 @@
+@@ -87,7 +89,7 @@
// Reads the contents of a CflowdAsMatrix from an istream. Returns
// the istream.
//-------------------------------------------------------------------------
@@ -27,7 +20,7 @@
//-------------------------------------------------------------------------
// int read(int fd)
-@@ -103,7 +103,7 @@
+@@ -103,7 +105,7 @@
// Writes the contents of a CflowdAsMatrix to an ostream. Returns
// the ostream.
//-------------------------------------------------------------------------
diff --git a/net-mgmt/cflowd/files/patch-snmp++-classes-include-snmp++_notifyqueue.h b/net-mgmt/cflowd/files/patch-snmp++-classes-include-snmp++_notifyqueue.h
new file mode 100644
index 00000000000..b24711a5a8d
--- /dev/null
+++ b/net-mgmt/cflowd/files/patch-snmp++-classes-include-snmp++_notifyqueue.h
@@ -0,0 +1,13 @@
+--- snmp++/classes/include/snmp++/notifyqueue.h.orig 2008-04-08 21:30:13.000000000 +0200
++++ snmp++/classes/include/snmp++/notifyqueue.h 2008-04-08 21:30:29.000000000 +0200
+@@ -94,8 +94,8 @@
+ const TargetCollection &notify_targets,
+ const AddressCollection &notify_addresses);
+ ~CNotifyEvent();
+- Snmp * CNotifyEvent::GetId();
+- int CNotifyEvent::notify_filter(const Oid &trapid,
++ Snmp * GetId();
++ int notify_filter(const Oid &trapid,
+ const SnmpTarget &target) const;
+ int Callback(SnmpTarget & target, Pdu & pdu, int status);
+