aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt
diff options
context:
space:
mode:
authortdb <tdb@FreeBSD.org>2005-12-06 05:34:11 +0800
committertdb <tdb@FreeBSD.org>2005-12-06 05:34:11 +0800
commita0abd572e39b2d402177200fbb3017db903093b5 (patch)
tree8442691d49a7a705b6c733f12f1bf8c33196b456 /net-mgmt
parenta2aaeb6ad71ab47ccde8c168fbbc05ad52d95d76 (diff)
downloadfreebsd-ports-graphics-a0abd572e39b2d402177200fbb3017db903093b5.tar.gz
freebsd-ports-graphics-a0abd572e39b2d402177200fbb3017db903093b5.tar.zst
freebsd-ports-graphics-a0abd572e39b2d402177200fbb3017db903093b5.zip
- Add net-mgmt/check_snmp_pkgvuln
check_snmp_pkgvuln is a Nagios plugin that detects hosts that are running vulnerable ports based on the database of security vulnerabilities provided by portaudit. The plugin communicates with the host via SNMP using the HOST-RESOURCES-MIB::hrSWInstalledName MIB. WWW: http://www.cultdeadsheep.org/~clement/ Approved by: clement (mentor)
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/Makefile1
-rw-r--r--net-mgmt/check_snmp_pkgvuln/Makefile38
-rw-r--r--net-mgmt/check_snmp_pkgvuln/distinfo3
-rw-r--r--net-mgmt/check_snmp_pkgvuln/pkg-descr6
-rw-r--r--net-mgmt/check_snmp_pkgvuln/pkg-plist2
5 files changed, 50 insertions, 0 deletions
diff --git a/net-mgmt/Makefile b/net-mgmt/Makefile
index 1dbffcc446b..3160c37337f 100644
--- a/net-mgmt/Makefile
+++ b/net-mgmt/Makefile
@@ -31,6 +31,7 @@
SUBDIR += cdpr
SUBDIR += cfgstoragemk
SUBDIR += cflowd
+ SUBDIR += check_snmp_pkgvuln
SUBDIR += choparp
SUBDIR += cidr
SUBDIR += cisco_conf
diff --git a/net-mgmt/check_snmp_pkgvuln/Makefile b/net-mgmt/check_snmp_pkgvuln/Makefile
new file mode 100644
index 00000000000..98bc671bdbc
--- /dev/null
+++ b/net-mgmt/check_snmp_pkgvuln/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: check_snmp_pkgvuln
+# Date created: 2 November 2005
+# Whom: Jarrod Sayers <jarrod@netleader.com.au>
+#
+# $FreeBSD$
+#
+
+PORTNAME= check_snmp_pkgvuln
+PORTVERSION= 0.01
+CATEGORIES= net-mgmt
+MASTER_SITES= http://www.cultdeadsheep.org/~clement/FreeBSD/nagios/
+PKGNAMEPREFIX= nagios-
+PKGNAMESUFFIX= -plugin
+DISTNAME= ${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= jarrod@netleader.com.au
+COMMENT= Security vulnerability plugin for Nagios
+
+RUN_DEPENDS= snmpwalk:${PORTSDIR}/net-mgmt/net-snmp \
+ portaudit:${PORTSDIR}/security/portaudit
+
+NAGIOS_PLUGIN_DIR?= libexec/nagios
+
+NO_WRKSUBDIR= yes
+USE_REINPLACE= yes
+
+PLIST_SUB= NAGIOS_PLUGIN_DIR=${NAGIOS_PLUGIN_DIR}
+
+post-patch:
+ ${REINPLACE_CMD} -e 's|/usr/local/|${PREFIX}/|' ${WRKSRC}/${PORTNAME}
+
+do-build:
+
+do-install:
+ @${MKDIR} ${PREFIX}/${NAGIOS_PLUGIN_DIR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${PREFIX}/${NAGIOS_PLUGIN_DIR}
+
+.include <bsd.port.mk>
diff --git a/net-mgmt/check_snmp_pkgvuln/distinfo b/net-mgmt/check_snmp_pkgvuln/distinfo
new file mode 100644
index 00000000000..720b3cc799e
--- /dev/null
+++ b/net-mgmt/check_snmp_pkgvuln/distinfo
@@ -0,0 +1,3 @@
+MD5 (check_snmp_pkgvuln-0.01.tar.gz) = e715c013c7f8c953059b57d8c320802a
+SHA256 (check_snmp_pkgvuln-0.01.tar.gz) = 2170cacc3207c0af0a00825b94c615f02fce050b69c705ed1de49a123f8bd3ca
+SIZE (check_snmp_pkgvuln-0.01.tar.gz) = 1268
diff --git a/net-mgmt/check_snmp_pkgvuln/pkg-descr b/net-mgmt/check_snmp_pkgvuln/pkg-descr
new file mode 100644
index 00000000000..8f88e86d323
--- /dev/null
+++ b/net-mgmt/check_snmp_pkgvuln/pkg-descr
@@ -0,0 +1,6 @@
+check_snmp_pkgvuln is a Nagios plugin that detects hosts that are running
+vulnerable ports based on the database of security vulnerabilities
+provided by portaudit. The plugin communicates with the host via SNMP
+using the HOST-RESOURCES-MIB::hrSWInstalledName MIB.
+
+WWW: http://www.cultdeadsheep.org/~clement/
diff --git a/net-mgmt/check_snmp_pkgvuln/pkg-plist b/net-mgmt/check_snmp_pkgvuln/pkg-plist
new file mode 100644
index 00000000000..f17dd8c006b
--- /dev/null
+++ b/net-mgmt/check_snmp_pkgvuln/pkg-plist
@@ -0,0 +1,2 @@
+%%NAGIOS_PLUGIN_DIR%%/check_snmp_pkgvuln
+@unexec rmdir %D/%%NAGIOS_PLUGIN_DIR%% 2>/dev/null || true